diff options
author | LaMont Jones <lamont@debian.org> | 2003-05-07 08:36:40 -0600 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:27 -0800 |
commit | e21d47d7813159bb71e0671df9b52ec0470c358d (patch) | |
tree | 3c7770ea846123c291f599044e9f234ac17616bb /unix.c | |
parent | 8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff) | |
parent | deda2c0fd8689349fea2a900199a76ff7ecb319e (diff) | |
download | scm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip |
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low
* Fix hppa compile. Closes: #144062
scm (5d6-3.1) unstable; urgency=low
* NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171
scm (5d6-3) unstable; urgency=low
* Add build depend on xlibs-dev (Closes: #148020)
scm (5d6-2) unstable; urgency=low
* Remove libregexx-dev from build-depends.
* Change build to use ./scmlit rather than scmlit (should fix some build
problems) (looks like alpha is mostly building)
* New release (Closes: #140175)
* Built with turtlegraphics last time (Closes: #58515)
scm (5d6-1) unstable; urgency=low
* New upstream.
* Add xlib and turtlegr to requested list of features. (closes
some bug)
* Make clean actually clean most everything up.
* Remove hacks renaming build to something else and just set build as a
.PHONY target in debian/rules.
* Add the turtlegr code.
scm (5d5-1) unstable; urgency=low
* New upstream
* Has fixes for 64 bit archs. May fix alpha compile problem. Does fix
(Closes: #140175)
* Take out -O2 arg.
scm (5d4-3) unstable; urgency=low
* Don't link with regexx, but just use libc6's regular expression
functions.
* Define (terms) to output /usr/share/common-licenses/GPL (Closes:
#119321)
scm (5d4-2) unstable; urgency=low
* Add texinfo to build depends (Closes: #107011)
scm (5d4-1) unstable; urgency=low
* New upstream release.
* Move install-info --remove to prerm.
scm (5d3-5) unstable; urgency=low
* Move scm info files to section "The Algorithmic Language Scheme" to
match up with guile.
scm (5d3-4) unstable; urgency=low
* Fix build depends (Closes: #76691)
scm (5d3-3) unstable; urgency=low
* Fix path in scm dhelp file.
scm (5d3-2) unstable; urgency=low
* Actually put the header files in the package. Oops.
scm (5d3-1) unstable; urgency=low
* New upstream. (Closes: #74761)
* Make (terms) use new license location.
* Make use libregexx rather than librx.
* Fix build depends for above.
* Using new regex lib seems to fix crash (Closes: #66787)
* Consider adding scm-dev package with headers, but instead just add the
headers to the scm package. (Closes: #70787)
* Add doc-base support.
Diffstat (limited to 'unix.c')
-rw-r--r-- | unix.c | 52 |
1 files changed, 31 insertions, 21 deletions
@@ -15,26 +15,26 @@ * the Free Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111, USA. * * As a special exception, the Free Software Foundation gives permission - * for additional uses of the text contained in its release of GUILE. + * for additional uses of the text contained in its release of SCM. * - * The exception is that, if you link the GUILE library with other files + * The exception is that, if you link the SCM library with other files * to produce an executable, this does not by itself cause the * resulting executable to be covered by the GNU General Public License. * Your use of that executable is in no way restricted on account of - * linking the GUILE library code into it. + * linking the SCM library code into it. * * This exception does not however invalidate any other reasons why * the executable file might be covered by the GNU General Public License. * * This exception applies only to the code released by the - * Free Software Foundation under the name GUILE. If you copy + * Free Software Foundation under the name SCM. If you copy * code from other Free Software Foundation releases into a copy of - * GUILE, as the General Public License permits, the exception does + * SCM, as the General Public License permits, the exception does * not apply to the code that you add in this way. To avoid misleading * anyone as to the status of such modified files, you must delete * this exception notice from them. * - * If you write modifications of your own for GUILE, it is your choice + * If you write modifications of your own for SCM, it is your choice * whether to permit this exception to apply to your modifications. * If you do not wish that, delete this exception notice. */ @@ -49,8 +49,15 @@ /* #include <sys/wait.h> */ #include <sys/stat.h> +extern SCM stat2scm P((struct stat *stat_temp)); -SCM stat2scm P((struct stat *stat_temp)); +SCM scm_mknod P((SCM path, SCM mode, SCM dev)); +SCM scm_acct P((SCM path)); +SCM scm_nice P((SCM incr)); +SCM scm_sync P((void)); +SCM scm_symlink P((SCM oldpath, SCM newpath)); +SCM scm_readlink P((SCM path)); +SCM scm_lstat P((SCM str)); #ifndef STDC_HEADERS void sync P((void)); @@ -62,13 +69,16 @@ SCM stat2scm P((struct stat *stat_temp)); # ifdef SVR4 # include <unistd.h> # endif +# ifdef __OpenBSD__ +# include <unistd.h> +# endif #endif /* STDC_HEADERS */ /* Only the superuser can successfully execute mknod and acct */ /* int mknod P((const char *path, mode_t mode, dev_t dev)); should be in stat.h */ static char s_mknod[] = "mknod"; -SCM l_mknod(path, mode, dev) +SCM scm_mknod(path, mode, dev) SCM path, mode, dev; { int val; @@ -79,7 +89,7 @@ SCM l_mknod(path, mode, dev) return val ? BOOL_F : BOOL_T; } static char s_acct[] = "acct"; -SCM l_acct(path) +SCM scm_acct(path) SCM path; { int val; @@ -93,21 +103,21 @@ SCM l_acct(path) } static char s_nice[] = "nice"; -SCM l_nice(incr) +SCM scm_nice(incr) SCM incr; { ASSERT(INUMP(incr), incr, ARG1, s_nice); return nice(INUM(incr)) ? BOOL_F : BOOL_T; } -SCM l_sync() +SCM scm_sync() { sync(); return UNSPECIFIED; } static char s_symlink[] = "symlink"; -SCM l_symlink(oldpath, newpath) +SCM scm_symlink(oldpath, newpath) SCM oldpath, newpath; { int val; @@ -117,7 +127,7 @@ SCM l_symlink(oldpath, newpath) return val ? BOOL_F : BOOL_T; } static char s_readlink[] = "readlink"; -SCM l_readlink(path) +SCM scm_readlink(path) SCM path; { int i; @@ -128,7 +138,7 @@ SCM l_readlink(path) return makfromstr(buf, (sizet)i); } static char s_lstat[] = "lstat"; -SCM l_lstat(str) +SCM scm_lstat(str) SCM str; { int i; @@ -140,17 +150,17 @@ SCM l_lstat(str) } static iproc subr1s[] = { - {s_nice, l_nice}, - {s_acct, l_acct}, - {s_lstat, l_lstat}, - {s_readlink, l_readlink}, + {s_nice, scm_nice}, + {s_acct, scm_acct}, + {s_lstat, scm_lstat}, + {s_readlink, scm_readlink}, {0, 0}}; void init_unix() { - make_subr("sync", tc7_subr_0, l_sync); + make_subr("sync", tc7_subr_0, scm_sync); init_iprocs(subr1s, tc7_subr_1); - make_subr(s_symlink, tc7_subr_2, l_symlink); - make_subr(s_mknod, tc7_subr_3, l_mknod); + make_subr(s_symlink, tc7_subr_2, scm_symlink); + make_subr(s_mknod, tc7_subr_3, scm_mknod); add_feature("unix"); } |