diff options
author | LaMont Jones <lamont@debian.org> | 2003-05-07 08:36:40 -0600 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:27 -0800 |
commit | e21d47d7813159bb71e0671df9b52ec0470c358d (patch) | |
tree | 3c7770ea846123c291f599044e9f234ac17616bb /script.c | |
parent | 8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff) | |
parent | deda2c0fd8689349fea2a900199a76ff7ecb319e (diff) | |
download | scm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip |
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low
* Fix hppa compile. Closes: #144062
scm (5d6-3.1) unstable; urgency=low
* NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171
scm (5d6-3) unstable; urgency=low
* Add build depend on xlibs-dev (Closes: #148020)
scm (5d6-2) unstable; urgency=low
* Remove libregexx-dev from build-depends.
* Change build to use ./scmlit rather than scmlit (should fix some build
problems) (looks like alpha is mostly building)
* New release (Closes: #140175)
* Built with turtlegraphics last time (Closes: #58515)
scm (5d6-1) unstable; urgency=low
* New upstream.
* Add xlib and turtlegr to requested list of features. (closes
some bug)
* Make clean actually clean most everything up.
* Remove hacks renaming build to something else and just set build as a
.PHONY target in debian/rules.
* Add the turtlegr code.
scm (5d5-1) unstable; urgency=low
* New upstream
* Has fixes for 64 bit archs. May fix alpha compile problem. Does fix
(Closes: #140175)
* Take out -O2 arg.
scm (5d4-3) unstable; urgency=low
* Don't link with regexx, but just use libc6's regular expression
functions.
* Define (terms) to output /usr/share/common-licenses/GPL (Closes:
#119321)
scm (5d4-2) unstable; urgency=low
* Add texinfo to build depends (Closes: #107011)
scm (5d4-1) unstable; urgency=low
* New upstream release.
* Move install-info --remove to prerm.
scm (5d3-5) unstable; urgency=low
* Move scm info files to section "The Algorithmic Language Scheme" to
match up with guile.
scm (5d3-4) unstable; urgency=low
* Fix build depends (Closes: #76691)
scm (5d3-3) unstable; urgency=low
* Fix path in scm dhelp file.
scm (5d3-2) unstable; urgency=low
* Actually put the header files in the package. Oops.
scm (5d3-1) unstable; urgency=low
* New upstream. (Closes: #74761)
* Make (terms) use new license location.
* Make use libregexx rather than librx.
* Fix build depends for above.
* Using new regex lib seems to fix crash (Closes: #66787)
* Consider adding scm-dev package with headers, but instead just add the
headers to the scm package. (Closes: #70787)
* Add doc-base support.
Diffstat (limited to 'script.c')
-rw-r--r-- | script.c | 41 |
1 files changed, 27 insertions, 14 deletions
@@ -15,26 +15,26 @@ * the Free Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111, USA. * * As a special exception, the Free Software Foundation gives permission - * for additional uses of the text contained in its release of GUILE. + * for additional uses of the text contained in its release of SCM. * - * The exception is that, if you link the GUILE library with other files + * The exception is that, if you link the SCM library with other files * to produce an executable, this does not by itself cause the * resulting executable to be covered by the GNU General Public License. * Your use of that executable is in no way restricted on account of - * linking the GUILE library code into it. + * linking the SCM library code into it. * * This exception does not however invalidate any other reasons why * the executable file might be covered by the GNU General Public License. * * This exception applies only to the code released by the - * Free Software Foundation under the name GUILE. If you copy + * Free Software Foundation under the name SCM. If you copy * code from other Free Software Foundation releases into a copy of - * GUILE, as the General Public License permits, the exception does + * SCM, as the General Public License permits, the exception does * not apply to the code that you add in this way. To avoid misleading * anyone as to the status of such modified files, you must delete * this exception notice from them. * - * If you write modifications of your own for GUILE, it is your choice + * If you write modifications of your own for SCM, it is your choice * whether to permit this exception to apply to your modifications. * If you do not wish that, delete this exception notice. */ @@ -52,13 +52,13 @@ #ifdef linux # include <unistd.h> /* for X_OK define */ #endif /* def linux */ -#ifdef __svr4__ +#ifdef __SVR4 # include <unistd.h> /* for X_OK define */ #else # ifdef __sgi__ # include <unistd.h> /* for X_OK define */ # endif /* def __sgi__ */ -#endif /* def __svr4__ */ +#endif /* def __SVR4 */ /* Concatentate str2 onto str1 at position n and return concatenated string if file exists; 0 otherwise. */ @@ -124,7 +124,7 @@ char *scm_sep_init_try(path, sep, initname) # define X_OK 1 #endif /* ndef X_OK */ -#ifdef unix +#ifdef HAVE_UNIX # include <stdio.h> char *script_find_executable(name) @@ -156,7 +156,6 @@ char *script_find_executable(name) #endif /* unix */ #ifdef MSDOS - # define DEFAULT_PATH "C:\\DOS" # define PATH_DELIMITER ';' # define ABSOLUTE_FILENAME_P(fname) ((fname[0] == '\\') \ @@ -170,6 +169,20 @@ char *dld_find_executable(file) } #endif /* def MSDOS */ +#ifdef __IBMC__ +# define PATH_DELIMITER ';' +# define ABSOLUTE_FILENAME_P(fname) ((fname[0] == '/') \ + || (fname[0] == '\\') \ + || (fname[0] && (fname[1] == ':'))) + +char *dld_find_executable(file) + const char *file; +{ + /* fprintf(stderr, "dld_find_executable %s -> %s\n", file, scm_cat_path(0L, file, 0L)); fflush(stderr); */ + return scm_cat_path(0L, file, 0L); +} +#endif /* def __IBMC__ */ + /* Given dld_find_executable()'s best guess for the pathname of this executable, find (and verify the existence of) initname in the implementation-vicinity of this program. Returns a newly allocated @@ -227,7 +240,7 @@ char *find_impl_file(exec_path, generic_name, initname, sep) path = scm_sep_init_try(path, sep, initname); if (path) return path; } - if (!strcmp(peer,"src")) break; + if (!strcmp(peer, "src")) break; } if (generic_name) { @@ -242,7 +255,7 @@ char *find_impl_file(exec_path, generic_name, initname, sep) path = scm_sep_init_try(path, sep, initname); if (path) return path; } - if (!strcmp(peer,"src")) break; + if (!strcmp(peer, "src")) break; }} /* Look for initname in executable-name peer directory. */ @@ -377,7 +390,7 @@ char **script_process_argv(argc, argv) int nargc = argc, argi = 1, nargi = 1; char *narg, **nargv; if (!(argc > 2 && script_meta_arg_P(argv[1]))) return 0L; - if (!(nargv = (char **)malloc((1 + nargc) * sizeof(char*)))) return 0L; + if (!(nargv = (char **)malloc((1 + nargc) * sizeof(char *)))) return 0L; nargv[0] = argv[0]; while (((argi+1) < argc) && (script_meta_arg_P(argv[argi]))) { FILE *f = fopen(argv[++argi], "r"); @@ -389,7 +402,7 @@ char **script_process_argv(argc, argv) case '\n': goto found_args; } found_args: while ((narg = script_read_arg(f))) - if (!(nargv = (char **)realloc(nargv, (1 + ++nargc) * sizeof(char*)))) + if (!(nargv = (char **)realloc(nargv, (1 + ++nargc) * sizeof(char *)))) return 0L; else nargv[nargi++] = narg; fclose(f); |