diff options
author | Thomas Bushnell <tb@debian.org> | 2005-10-27 12:00:49 -0700 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:29 -0800 |
commit | 4e063c0de0bf319c9201cefa6f399364041bb7b9 (patch) | |
tree | 61a326cd4ab69f610d2e10313db2a641b6d0b4dd /scmhob.scm | |
parent | 5f7b0413c1bb0f96bb613ad74c0978f44116a136 (diff) | |
parent | 302e3218b7d487539ec305bf23881a6ee7d5be99 (diff) | |
download | scm-4e063c0de0bf319c9201cefa6f399364041bb7b9.tar.gz scm-4e063c0de0bf319c9201cefa6f399364041bb7b9.zip |
Import Debian changes 5e1-1debian/5e1-1
scm (5e1-1) unstable; urgency=low
* New upstream release. (Closes: #335970)
* debian/rules (SCM_OPTIONS): Remove -F turtlegr; the file supporting
this option seems to have gone by the wayside.
* debian/rules (binary-arch): Don't try to install grtest.scm; it's gone
now.
* debian/rules (build-stamp): Use tee to capture output of ./build so
that we can capture a copy of the file in the build log.
* scm.1: Fix spelling errors in manual page:
verobse -> verbose;
qoutes -> quotes;
aguments -> arguments;
neccessary -> necessary;
preceeds -> precedes.
syncronization -> synchronization.
(Closes: #300131)
* debian/postinst, debian/prerm: Assume that install-docs is in the
standard place, and test for it there with test -x. (Closes: #292996)
Diffstat (limited to 'scmhob.scm')
-rw-r--r-- | scmhob.scm | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -32,6 +32,11 @@ (define (logsleft x y) (ash x y)) (define (logsright x y) (ash x (- 0 y))) +(define logical:logand logand) +(define logical:logior logior) +(define logical:logxor logxor) +(define logical:lognot lognot) + ; immediate-integer (30-bit signed int) versions of arithmetic primitives: (define %eqv? eqv?) |