diff options
author | Thomas Bushnell <tb@debian.org> | 2006-10-23 23:31:59 -0700 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:35 -0800 |
commit | 906cc4f0899080f1b832af98b7ccbcc257b8a64e (patch) | |
tree | 14e3ec231debdca4da9c1a3ccc0536033c1c8a4b /hobbit.scm | |
parent | 3d573fa54db0fdcae8b2a20356faa46c8e335206 (diff) | |
parent | 50eb784bfcf15ee3c6b0b53d747db92673395040 (diff) | |
download | scm-d630f15ab83720baf4b6d44de1697a2cf789ad9f.tar.gz scm-d630f15ab83720baf4b6d44de1697a2cf789ad9f.zip |
Import Debian changes 5e3-1debian/5e3-1
scm (5e3-1) unstable; urgency=low
* New upstream release.
* debian/control (Architecture): Add ia64 to list of supported archs. Now
everything but s390 is listed. (Closes: #335980)
(Build-Depends): Require at least version 3a4 of slib.
* Change to continue.h from version 5e1-2 repeated here.
* Change to xgen.scm from version 5e2-4 repeated here.
* Change to scm.1 from version 5e2-4 repeated here.
Diffstat (limited to 'hobbit.scm')
-rw-r--r-- | hobbit.scm | 30 |
1 files changed, 22 insertions, 8 deletions
@@ -209,7 +209,9 @@ tcs-cons-imcar tcs-cons-nimcar tcs-cons-gloc tcs-closures tcs-subrs
tc7-asubr tcs-symbols tc7-ssymbol tcs-bignums tc16-bigpos tc3-cons
tc3-cons-gloc tc3-closure tc7-ssymbol tc7-msymbol tc7-string
- tc7-vector tc7-bvect tc7-ivect tc7-uvect tc7-fvect tc7-dvect tc7-cvect
+ tc7-vector tc7-Vbool
+ tc7-VfixZ32 tc7-VfixN32 tc7-VfixZ16 tc7-VfixN16 tc7-VfixZ8 tc7-VfixN8
+ tc7-VfloR32 tc7-VfloC32 tc7-VfloR64 tc7-VfloC64
tc7-contin tc7-cclo tc7-asubr
;;; tc7-subr-0 tc7-subr-1
tc7-cxr
@@ -2382,7 +2384,7 @@ atanh sqrt expt integer-expt))
(define *interpreter-defined-vars* '())
-;; '(*features*
+;; '(slib:features
;; most-positive-fixnum most-negative-fixnum))
;; defs in *extra-hobbit-primitive-defs* are used when the extra primitive
@@ -2507,6 +2509,13 @@ ($atanh "ATANH_FUN" 1)
($sqrt "SQRT_FUN" 1) ($expt "EXPT_FUN" 2)
($log "LOG_FUN" 1) ($abs "ABS_FUN" 1) ($exp "EXP_FUN" 1)
+ (real-sin "SIN_FUN" 1) (real-cos "COS_FUN" 1) (real-tan "TAN_FUN" 1)
+ (real-asin "ASIN_FUN" 1) (real-acos "ACOS_FUN" 1) (real-atan "ATAN_FUN" 1)
+ (real-sinh "SINH_FUN" 1) (real-cosh "COSH_FUN" 1)
+ (real-tanh "TANH_FUN" 1) (real-asinh "ASINH_FUN" 1) (real-acosh "ACOSH_FUN" 1)
+ (real-atanh "ATANH_FUN" 1)
+ (real-sqrt "SQRT_FUN" 1) (real-expt "EXPT_FUN" 2)
+ (real-ln "LOG_FUN" 1) (real-exp "EXP_FUN" 1)
(inexact->exact "in2ex" 1)
(make-rectangular "makrect" 2) (make-polar "makpolar" 2)
@@ -6028,13 +6037,18 @@ #f))
(else #f)))
-
(define *float-recognize-ops*
- '($sin $cos $tan $asin $acos $atan $sinh $cosh $tanh $asinh $tanh
- $asinh $acosh $atanh $sqrt $expt $log $abs $exp
- sin cos tan asin acos atan sinh cosh tanh asinh tanh
- asinh acosh atanh))
-
+ '(ln sqrt log exp
+ sin cos tan asin acos atan
+ sinh cosh tanh asinh acosh atanh
+ real-sin real-cos real-tan
+ real-asin real-acos real-atan
+ real-sinh real-cosh real-tanh
+ real-asinh real-acosh real-atanh
+ real-sqrt real-expt real-ln real-exp
+ $sin $cos $tan $asin $acos $atan
+ $sinh $cosh $tanh $asinh $acosh $atanh
+ $sqrt $expt $log $abs $exp))
(define *check-redefining-passed* '())
|