diff options
author | Thomas Bushnell <tb@debian.org> | 2007-12-28 15:56:00 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:38 -0800 |
commit | 967ca9f9b4c42630fb0feb1e5b9186266fa4d854 (patch) | |
tree | 8bbb64f76bd25bf5dc59c856167f46f67cfca2e9 /dynl.c | |
parent | 25fbaa7f8700665d5aea046956175a35035f7fd5 (diff) | |
parent | 710a97992705d67c3ded0d4b270c5978ce29b11f (diff) | |
download | scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.tar.gz scm-967ca9f9b4c42630fb0feb1e5b9186266fa4d854.zip |
Import Debian changes 5e4-1debian/5e4-1
scm (5e4-1) unstable; urgency=low
* New upstream release.
* debian/control: Require at least version 3a5 of slib.
* debian/postrm: New file to remove /usr/lib/scm/implcat and
/usr/lib/scm/slibcat upon purge. (Closes: #455124). Thanks to Kumar
Appaiah for the fix.
* debian/control (Architecture): Add armel and armeb. (Closes: #408792).
* debian/rules (install): Don't use -s when installing. dh_strip should
be sufficient, and this should make the nostrip build option work.
(Closes: #438004).
* continue.h: Repeat change from 5e1-2.
* xgen.scm: Repeat change from 5e2-4.
* scm.1: Repeat change from 5e2-4.
* build.scm: Repeat change from 5e3-5.
Diffstat (limited to 'dynl.c')
-rw-r--r-- | dynl.c | 18 |
1 files changed, 9 insertions, 9 deletions
@@ -60,7 +60,7 @@ void listundefs() int i; char **undefs = dld_list_undefined_sym(); puts(" undefs:"); - for(i = dld_undefined_sym_count;i--;) { + for (i = dld_undefined_sym_count;i--;) { putc('"', stdout); fputs(undefs[i], stdout); puts("\""); @@ -181,7 +181,7 @@ int prinshl(exp, port, writing) SCM exp; SCM port; int writing; { lputs("#<shl ", port); - intprint(CDR(exp), -16, port); + scm_intprint(CDR(exp), -16, port); lputc('>', port); return 1; } @@ -379,7 +379,7 @@ int prinshl(exp, port, writing) SCM exp; SCM port; int writing; { lputs("#<shl ", port); - intprint(CDR(exp), -16, port); + scm_intprint(CDR(exp), -16, port); lputc('>', port); return 1; } @@ -405,7 +405,7 @@ SCM l_dyn_link(fname) lputs(s_link, cur_errp); lputs(": ", cur_errp); lputs(dlr, cur_errp); - newline(cur_errp); + scm_newline(cur_errp); }} return BOOL_F; } @@ -432,7 +432,7 @@ SCM l_dyn_call(symb, shl) lputs(s_call, cur_errp); lputs(": ", cur_errp); lputs(dlr, cur_errp); - newline(cur_errp); + scm_newline(cur_errp); } return BOOL_F; } @@ -448,7 +448,7 @@ SCM l_dyn_main_call(symb, shl, args) { int i; int (*func)P((int argc, const char **argv)) = 0; - const char **argv; + char **argv; /* SCM oloadpath = *loc_loadpath; */ ASRTER(NIMP(symb) && STRINGP(symb), symb, ARG1, s_main_call); ASRTER(NIMP(shl) && CAR(shl)==tc16_shl, shl, ARG2, s_main_call); @@ -461,7 +461,7 @@ SCM l_dyn_main_call(symb, shl, args) lputs(s_main_call, cur_errp); lputs(": ", cur_errp); lputs(dlr, cur_errp); - newline(cur_errp); + scm_newline(cur_errp); } return BOOL_F; } @@ -529,7 +529,7 @@ int prinshl(exp, port, writing) SCM exp; SCM port; int writing; { lputs("#<shl ", port); - intprint(CDR(exp), 16, port); + scm_intprint(CDR(exp), 16, port); lputc('>', port); return 1; } @@ -673,7 +673,7 @@ int prinshl(exp, port, writing) SCM exp; SCM port; int writing; { lputs("#<shl ", port); - intprint(CDR(exp), 16, port); + scm_intprint(CDR(exp), 16, port); lputc('>', port); return 1; } |