diff options
author | Thomas Bushnell <tb@debian.org> | 2008-02-04 20:53:13 -0500 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:41 -0800 |
commit | e9ed1ad5236ca6314136c4220ac672167b643fc5 (patch) | |
tree | 5b3d3a3b8c604225515a3ac6b09b6d036b14d165 /bytenumb.c | |
parent | 4bf8faaea412b017e299fd17a1b736119c86f18c (diff) | |
parent | 90889a692076f2c62486607d0354e0fca52364bc (diff) | |
download | scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.tar.gz scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.zip |
Import Debian changes 5e5-1debian/5e5-1
scm (5e5-1) unstable; urgency=low
* New upstream release.
* continue.h: Repeat change from 5e1-2.
* xgen.scm: Repeat change from 5e2-4.
* scm.1: Repeat change from 5e2-4.
* build.scm: Repeat change from 5e3-5.
* Makefile: Repeat change from 5e3-2.
* debian/control (Build-Depends): Require at least version 3b1 of slib.
(scm Depends): Likewise.
(libscm-dev Depends): Likewise.
* Makefile (scm.info): Add explicit dependency on features.txi and
platform.txi. For some reason the one through $(texifiles) is
failing mysteriously. Perhaps this is a make bug.
Diffstat (limited to 'bytenumb.c')
-rw-r--r-- | bytenumb.c | 41 |
1 files changed, 21 insertions, 20 deletions
@@ -1,24 +1,25 @@ -/* "bytenumb.scm" Byte integer and IEEE floating-point conversions. */ -/* Copyright (C) 2007 Aubrey Jaffer */ -/* */ -/* Permission to copy this software, to modify it, to redistribute it, */ -/* to distribute modified versions, and to use it for any purpose is */ -/* granted, subject to the following restrictions and understandings. */ -/* */ -/* 1. Any copy made of this software must include this copyright notice */ -/* in full. */ -/* */ -/* 2. I have made no warranty or representation that the operation of */ -/* this software will be error-free, and I am under no obligation to */ -/* provide any services, by way of maintenance, update, or otherwise. */ -/* */ -/* 3. In conjunction with products arising from the use of this */ -/* material, there shall be no use of my name in any advertising, */ -/* promotional, or sales literature without prior written consent in */ -/* each case. */ +/* "bytenumb.scm" Byte integer and IEEE floating-point conversions. + * Copyright (C) 2007 Free Software Foundation, Inc. + * + * This program is free software: you can redistribute it and/or modify + * it under the terms of the GNU Lesser General Public License as + * published by the Free Software Foundation, either version 3 of the + * License, or (at your option) any later version. + * + * This program is distributed in the hope that it will be useful, but + * WITHOUT ANY WARRANTY; without even the implied warranty of + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU + * Lesser General Public License for more details. + * + * You should have received a copy of the GNU Lesser General Public + * License along with this program. If not, see + * <http://www.gnu.org/licenses/>. + */ -/* For documentation see: */ -/* http://cvs.savannah.gnu.org/viewcvs/slib/slib/bytenumb.scm?view=markup */ +/* Author: Aubrey Jaffer */ + +/* For documentation see: + http://cvs.savannah.gnu.org/viewcvs/slib/slib/bytenumb.scm?view=markup */ #include <stdlib.h> #include <math.h> |