diff options
author | Thomas Bushnell <tb@debian.org> | 2008-02-04 20:53:13 -0500 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:41 -0800 |
commit | e9ed1ad5236ca6314136c4220ac672167b643fc5 (patch) | |
tree | 5b3d3a3b8c604225515a3ac6b09b6d036b14d165 /build | |
parent | 4bf8faaea412b017e299fd17a1b736119c86f18c (diff) | |
parent | 90889a692076f2c62486607d0354e0fca52364bc (diff) | |
download | scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.tar.gz scm-e9ed1ad5236ca6314136c4220ac672167b643fc5.zip |
Import Debian changes 5e5-1debian/5e5-1
scm (5e5-1) unstable; urgency=low
* New upstream release.
* continue.h: Repeat change from 5e1-2.
* xgen.scm: Repeat change from 5e2-4.
* scm.1: Repeat change from 5e2-4.
* build.scm: Repeat change from 5e3-5.
* Makefile: Repeat change from 5e3-2.
* debian/control (Build-Depends): Require at least version 3b1 of slib.
(scm Depends): Likewise.
(libscm-dev Depends): Likewise.
* Makefile (scm.info): Add explicit dependency on features.txi and
platform.txi. For some reason the one through $(texifiles) is
failing mysteriously. Perhaps this is a make bug.
Diffstat (limited to 'build')
-rwxr-xr-x | build | 33 |
1 files changed, 17 insertions, 16 deletions
@@ -1,21 +1,21 @@ #! /bin/sh :;exec ./scmlit -no-init-file -f $0 -e"(bi)" build "$@" -;; +;;;; "build" Script for compiling SCM. ;; Copyright (C) 1994-2006 Free Software Foundation, Inc. ;; -;; This program is free software; you can redistribute it and/or modify -;; it under the terms of the GNU General Public License as published by -;; the Free Software Foundation; either version 2, or (at your option) -;; any later version. +;; This program is free software: you can redistribute it and/or modify +;; it under the terms of the GNU General Public License as +;; published by the Free Software Foundation, either version 3 of the +;; License, or (at your option) any later version. ;; -;; This program is distributed in the hope that it will be useful, -;; but WITHOUT ANY WARRANTY; without even the implied warranty of -;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the -;; GNU General Public License for more details. +;; This program is distributed in the hope that it will be useful, but +;; WITHOUT ANY WARRANTY; without even the implied warranty of +;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU +;; General Public License for more details. ;; -;; You should have received a copy of the GNU General Public License -;; along with this software; see the file COPYING. If not, write to -;; the Free Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111, USA. +;; You should have received a copy of the GNU General Public +;; License along with this program. If not, see +;; <http://www.gnu.org/licenses/>. (require 'getopt) (require 'getopt-parameters) @@ -65,10 +65,11 @@ (display "\ This directory contains the distribution of scm" pipe) (display scm-info pipe) - (display ". Scm conforms to + (display ". SCM conforms to Revised^5 Report on the Algorithmic Language Scheme and the IEEE P1178 -specification. SCM runs under Amiga, Atari-ST, MacOS, MS-DOS, OS/2, -NOS/VE, Unicos, VMS, Unix and similar systems. +specification. SCM runs under Amiga, Atari-ST, MacOS, MS-DOS, OS/2, +NOS/VE, Unicos, VMS, Unix and similar systems. SCM supports the SLIB +Scheme library; both SCM and SLIB are GNU packages. @center @url{http://swiss.csail.mit.edu/~jaffer/SCM} @@ -77,7 +78,7 @@ NOS/VE, Unicos, VMS, Unix and similar systems. pipe) (print-manifest pipe) (close-port pipe) - (set! scm-info (string-append "scm" scm-info ".info")) + (set! scm-info (string-append "scm-" scm-info ".info")) (append-info-node scm-info "SLIB" "README") (append-info-node scm-info "Making SCM" "README") (append-info-node scm-info "Editing Scheme Code" "README") |