summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in.210
-rw-r--r--toolchain/external-toolchain/ext-tool.mk4
-rw-r--r--toolchain/kernel-headers/Config.in4
-rw-r--r--toolchain/uClibc/Config.in8
-rw-r--r--toolchain/uClibc/uclibc.mk2
5 files changed, 16 insertions, 12 deletions
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index 5df04e01b..2a9ce24ef 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -119,6 +119,16 @@ choice
bool "Native POSIX Threading (NPTL)"
endchoice
+config BR2_PROGRAM_INVOCATION
+ bool "Enable 'program invocation name'"
+ help
+ Support for the GNU-specific program_invocation_name and
+ program_invocation_short_name strings. Some GNU packages
+ (like tar and coreutils) utilize these for extra useful
+ output, but in general are not required.
+ If you have an external binary toolchain that has been built
+ with program invocation support then enable this option.
+
config BR2_GCC_CROSS_CXX
bool
help
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index d441a9252..568ac3a35 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -115,7 +115,8 @@ check_glibc = \
$(call check_glibc_feature,BR2_INET_IPV6,IPv6 support) ;\
$(call check_glibc_feature,BR2_INET_RPC,RPC support) ;\
$(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
- $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support)
+ $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support) ;\
+ $(call check_glibc_feature,BR2_PROGRAM_INVOCATION,Program invocation support)
#
# Check the conformity of Buildroot configuration with regard to the
@@ -160,6 +161,7 @@ check_uclibc = \
$(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_LOCALE__,BR2_ENABLE_LOCALE,$${UCLIBC_CONFIG_FILE},Locale support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_WCHAR__,BR2_USE_WCHAR,$${UCLIBC_CONFIG_FILE},Wide char support) ;\
+ $(call check_uclibc_feature,__UCLIBC_HAS_PROGRAM_INVOCATION_NAME__,BR2_PROGRAM_INVOCATION,$${UCLIBC_CONFIG_FILE},Program invocation support) ;\
#
# Check that the Buildroot configuration of the ABI matches the
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 689c85dd5..ad78b0067 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -49,9 +49,9 @@ config BR2_KERNEL_HEADERS_RT
config BR2_DEFAULT_KERNEL_HEADERS
string
default "2.6.26.8" if BR2_KERNEL_HEADERS_2_6_26
- default "2.6.27.28" if BR2_KERNEL_HEADERS_2_6_27
+ default "2.6.27.29" if BR2_KERNEL_HEADERS_2_6_27
default "2.6.28.10" if BR2_KERNEL_HEADERS_2_6_28
default "2.6.29.6" if BR2_KERNEL_HEADERS_2_6_29
- default "2.6.30.3" if BR2_KERNEL_HEADERS_2_6_30
+ default "2.6.30.4" if BR2_KERNEL_HEADERS_2_6_30
default "2.6" if BR2_KERNEL_HEADERS_SNAP
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index b7678a356..d0486abd6 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -68,14 +68,6 @@ config BR2_PTHREAD_DEBUG
help
Build the thread library with debugging enabled.
-config BR2_UCLIBC_PROGRAM_INVOCATION
- bool "Enable 'program invocation name'"
- help
- Support for the GNU-specific program_invocation_name and
- program_invocation_short_name strings. Some GNU packages
- (like tar and coreutils) utilize these for extra useful
- output, but in general are not required.
-
config BR2_UCLIBC_INSTALL_TEST_SUITE
bool "Compile and install uClibc tests"
select BR2_PACKAGE_MAKE
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 80d7d9861..de8e1d562 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -353,7 +353,7 @@ ifeq ($(BR2_USE_WCHAR),y)
else
$(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_UCLIBC_PROGRAM_INVOCATION),y)
+ifeq ($(BR2_PROGRAM_INVOCATION),y)
$(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y,g' $(UCLIBC_DIR)/.oldconfig
else
$(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=n,g' $(UCLIBC_DIR)/.oldconfig