summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in2
-rwxr-xr-xtoolchain/dependencies/check-host-lzma.sh13
-rw-r--r--toolchain/dependencies/dependencies.mk6
-rw-r--r--toolchain/gdb/Config.in20
-rw-r--r--toolchain/helpers.mk3
-rw-r--r--toolchain/kernel-headers/Config.in4
-rw-r--r--toolchain/kernel-headers/linux-3.0.12-headers_install-fix-__packed-in-exported-kernel-head.patch (renamed from toolchain/kernel-headers/linux-3.0.8-headers_install-fix-__packed-in-exported-kernel-head.patch)0
-rw-r--r--toolchain/toolchain-common.in8
-rw-r--r--toolchain/toolchain-external/Config.in14
-rw-r--r--toolchain/uClibc/uClibc-0.9.32-linuxthreads-errno-fix.patch2
-rw-r--r--toolchain/uClibc/uClibc.snapshot.linuxthreads-errno-fix.patch2
11 files changed, 47 insertions, 27 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 5ff2a9152..2f4709a42 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -11,6 +11,7 @@ choice
config BR2_TOOLCHAIN_BUILDROOT
bool "Buildroot toolchain"
select BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
config BR2_TOOLCHAIN_EXTERNAL
bool "External toolchain"
@@ -22,6 +23,7 @@ config BR2_TOOLCHAIN_EXTERNAL
config BR2_TOOLCHAIN_CTNG
bool "Crosstool-NG toolchain"
select BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
help
Say 'y' if you want to generate the toolchain with crosstool-NG
( http://ymorin.is-a-geek.org/projects/crosstool )
diff --git a/toolchain/dependencies/check-host-lzma.sh b/toolchain/dependencies/check-host-lzma.sh
deleted file mode 100755
index 34e8f0379..000000000
--- a/toolchain/dependencies/check-host-lzma.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-ok=""
-
-for bin in /usr/bin/lzma $LZMA
-do
-# TODO: add check for proper functionality here..
- $bin --version > /dev/null 2>&1 && ok="$bin"
- if test "x$ok" != "x" ; then
- break
- fi
-done
-echo "$ok"
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 6eac05df8..24d66663b 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -16,12 +16,14 @@ DL_TOOLS = \
$(findstring git,$(DL_TOOLS_DEPENDENCIES)) \
$(findstring bzr,$(DL_TOOLS_DEPENDENCIES))
-dependencies: $(DEPENDENCIES_HOST_PREREQ)
+core-dependencies:
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
CONFIG_FILE="$(CONFIG_DIR)/.config" \
DL_TOOLS="$(DL_TOOLS)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh
+dependencies: core-dependencies $(DEPENDENCIES_HOST_PREREQ)
+
dependencies-source:
dependencies-clean:
@@ -35,5 +37,5 @@ dependencies-dirclean:
# Toplevel Makefile options
#
#############################################################
-.PHONY: dependencies
+.PHONY: dependencies core-dependencies
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index e593698d2..9868580c9 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -4,6 +4,8 @@ config BR2_PACKAGE_GDB
bool "Build gdb debugger for the Target"
select BR2_PACKAGE_NCURSES
depends on BR2_USE_WCHAR
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on !BR2_sh && !BR2_sh64
help
Build the full gdb debugger to run on the target.
@@ -26,7 +28,7 @@ config BR2_PACKAGE_GDB_HOST
choice
prompt "GDB debugger Version"
- default BR2_GDB_VERSION_6_6 if !BR2_bfin
+ default BR2_GDB_VERSION_6_6 if BR2_bfin
default BR2_GDB_VERSION_6_7_1_AVR32_2_1_5 if BR2_avr32
default BR2_GDB_VERSION_7_3
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
@@ -50,25 +52,33 @@ choice
bool "gdb 7.0.1"
depends on !BR2_bfin
depends on BR2_DEPRECATED
- select BR2_PTHREAD_DEBUG if !BR2_PTHREADS_NONE
+ depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
config BR2_GDB_VERSION_7_1
bool "gdb 7.1"
depends on !BR2_bfin
- select BR2_PTHREAD_DEBUG if !BR2_PTHREADS_NONE
+ depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
config BR2_GDB_VERSION_7_2
bool "gdb 7.2.x"
depends on !BR2_bfin
- select BR2_PTHREAD_DEBUG if !BR2_PTHREADS_NONE
+ depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
config BR2_GDB_VERSION_7_3
bool "gdb 7.3.x"
depends on !BR2_bfin
- select BR2_PTHREAD_DEBUG if !BR2_PTHREADS_NONE
+ depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
endchoice
+comment "gdb 7.x support needs pthread debug support in toolchain"
+ depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
+ depends on !BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+
config BR2_GDB_VERSION
string
default "6.6a" if BR2_GDB_VERSION_6_6
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 96919d4b1..65cc9982d 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -195,7 +195,8 @@ check_uclibc = \
$(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_LOCALE__,BR2_ENABLE_LOCALE,$${UCLIBC_CONFIG_FILE},Locale support) ;\
$(call check_uclibc_feature,__UCLIBC_HAS_WCHAR__,BR2_USE_WCHAR,$${UCLIBC_CONFIG_FILE},Wide char support) ;\
- $(call check_uclibc_feature,__UCLIBC_HAS_THREADS__,BR2_TOOLCHAIN_HAS_THREADS,$${UCLIBC_CONFIG_FILE},Thread support)
+ $(call check_uclibc_feature,__UCLIBC_HAS_THREADS__,BR2_TOOLCHAIN_HAS_THREADS,$${UCLIBC_CONFIG_FILE},Thread support) ;\
+ $(call check_uclibc_feature,__PTHREADS_DEBUG_SUPPORT__,BR2_TOOLCHAIN_HAS_THREADS_DEBUG,$${UCLIBC_CONFIG_FILE},Thread debugging support)
#
# Check that the Buildroot configuration of the ABI matches the
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 701a02de7..9e72b00d2 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -57,7 +57,7 @@ config BR2_DEFAULT_KERNEL_HEADERS
default "2.6.37.6" if BR2_KERNEL_HEADERS_2_6_37
default "2.6.38.8" if BR2_KERNEL_HEADERS_2_6_38
default "2.6.39.4" if BR2_KERNEL_HEADERS_2_6_39
- default "3.0.8" if BR2_KERNEL_HEADERS_3_0
- default "3.1" if BR2_KERNEL_HEADERS_3_1
+ default "3.0.12" if BR2_KERNEL_HEADERS_3_0
+ default "3.1.4" if BR2_KERNEL_HEADERS_3_1
default "2.6" if BR2_KERNEL_HEADERS_SNAP
default $BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION
diff --git a/toolchain/kernel-headers/linux-3.0.8-headers_install-fix-__packed-in-exported-kernel-head.patch b/toolchain/kernel-headers/linux-3.0.12-headers_install-fix-__packed-in-exported-kernel-head.patch
index 8777b7163..8777b7163 100644
--- a/toolchain/kernel-headers/linux-3.0.8-headers_install-fix-__packed-in-exported-kernel-head.patch
+++ b/toolchain/kernel-headers/linux-3.0.12-headers_install-fix-__packed-in-exported-kernel-head.patch
diff --git a/toolchain/toolchain-common.in b/toolchain/toolchain-common.in
index 2d1100809..56ac85f5c 100644
--- a/toolchain/toolchain-common.in
+++ b/toolchain/toolchain-common.in
@@ -26,6 +26,14 @@ config BR2_INSTALL_LIBSTDCPP
config BR2_TOOLCHAIN_HAS_THREADS
bool
+config BR2_TOOLCHAIN_HAS_THREADS_DEBUG
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ bool
+
+config BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ default y if !BR2_TOOLCHAIN_HAS_THREADS
+ bool
+
config BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
bool
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 678babd25..eadfe50cf 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -175,6 +175,7 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_SH2A_201103
select BR2_INET_RPC
select BR2_USE_WCHAR
select BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG
select BR2_INSTALL_LIBSTDCPP
help
Sourcery CodeBench toolchain for the SuperH architecture,
@@ -191,6 +192,7 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_SH2A_201009
select BR2_INET_RPC
select BR2_USE_WCHAR
select BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG
select BR2_INSTALL_LIBSTDCPP
help
Sourcery CodeBench toolchain for the SuperH architecture,
@@ -224,6 +226,7 @@ config BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2010RC1
select BR2_INET_RPC
select BR2_USE_WCHAR
select BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG
help
Toolchain for the Blackfin architecture, from
http://blackfin.uclinux.org.
@@ -285,6 +288,7 @@ config BR2_TOOLCHAIN_EXTERNAL_GLIBC
select BR2_USE_WCHAR
select BR2_ENABLE_LOCALE
select BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG
select BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
config BR2_TOOLCHAIN_EXTERNAL_UCLIBC
@@ -361,6 +365,16 @@ config BR2_TOOLCHAIN_EXTERNAL_HAS_THREADS
support. If you don't know, leave the default value,
Buildroot will tell you if it's correct or not.
+config BR2_TOOLCHAIN_EXTERNAL_HAS_THREADS_DEBUG
+ bool "Toolchain has threads debugging support?"
+ depends on BR2_TOOLCHAIN_EXTERNAL_HAS_THREADS
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG
+ default y
+ help
+ Select this option if your external toolchain has thread
+ debugging support. If you don't know, leave the default
+ value, Buildroot will tell you if it's correct or not.
+
endif # BR2_TOOLCHAIN_EXTERNAL_CUSTOM_UCLIBC
config BR2_TOOLCHAIN_EXTERNAL_CXX
diff --git a/toolchain/uClibc/uClibc-0.9.32-linuxthreads-errno-fix.patch b/toolchain/uClibc/uClibc-0.9.32-linuxthreads-errno-fix.patch
index 73351737e..c4d0d00df 100644
--- a/toolchain/uClibc/uClibc-0.9.32-linuxthreads-errno-fix.patch
+++ b/toolchain/uClibc/uClibc-0.9.32-linuxthreads-errno-fix.patch
@@ -63,8 +63,6 @@ index 6e520fa..f4a9ebb 100644
# ifdef __UCLIBC_HAS_THREADS__
/* When using threads, errno is a per-thread value. */
-diff --git a/libc/sysdeps/linux/common/bits/uClibc_errno.h b/libc/sysdeps/linux/common/bits/uClibc_errno.h
-index 9c15618..79eb7e6 100644
--
1.7.1
diff --git a/toolchain/uClibc/uClibc.snapshot.linuxthreads-errno-fix.patch b/toolchain/uClibc/uClibc.snapshot.linuxthreads-errno-fix.patch
index 73351737e..c4d0d00df 100644
--- a/toolchain/uClibc/uClibc.snapshot.linuxthreads-errno-fix.patch
+++ b/toolchain/uClibc/uClibc.snapshot.linuxthreads-errno-fix.patch
@@ -63,8 +63,6 @@ index 6e520fa..f4a9ebb 100644
# ifdef __UCLIBC_HAS_THREADS__
/* When using threads, errno is a per-thread value. */
-diff --git a/libc/sysdeps/linux/common/bits/uClibc_errno.h b/libc/sysdeps/linux/common/bits/uClibc_errno.h
-index 9c15618..79eb7e6 100644
--
1.7.1