summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in.28
-rw-r--r--toolchain/external-toolchain/ext-tool.mk12
2 files changed, 20 insertions, 0 deletions
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index f04f18a21..fc6759dd6 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -56,6 +56,14 @@ config BR2_ENABLE_LOCALE_WHITELIST
will be available on the target - That purely depends on the
support for that locale in the selected packages.
+# uClibc toolchains require a separatly-compiled gettext/libintl when
+# locale support is enabled. This isn't necessary with glibc
+# toolchains as glibc includes gettext/libintl.
+config BR2_NEEDS_GETTEXT
+ bool
+ default y if (BR2_TOOLCHAIN_BUILDROOT && BR2_ENABLE_LOCALE)
+ default y if (BR2_TOOLCHAIN_EXTERNAL_UCLIBC && BR2_ENABLE_LOCALE)
+
config BR2_USE_WCHAR
bool "Enable WCHAR support"
help
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 2c2562cde..bb4809ccd 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -232,6 +232,15 @@ check_arm_abi = \
fi ; \
#
+# Check that the external toolchain supports C++
+#
+check_cplusplus = \
+ if ! test -x $(TARGET_CXX) ; then \
+ echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
+ exit 1 ; \
+ fi ; \
+
+#
# Check that the cross-compiler given in the configuration exists
#
check_cross_compiler_exists = \
@@ -288,6 +297,9 @@ endif
ifeq ($(BR2_arm),y)
$(Q)$(call check_arm_abi)
endif
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ $(Q)$(call check_cplusplus)
+endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
$(Q)$(call check_uclibc,$(SYSROOT_DIR))
else