summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in.215
-rwxr-xr-xtoolchain/dependencies/dependencies.sh23
-rw-r--r--toolchain/external-toolchain/ext-tool.mk12
-rw-r--r--toolchain/kernel-headers/Config.in6
-rw-r--r--toolchain/kernel-headers/linux-2.6.32.14-scsi-use-__uX-types-for-headers-exported-to-user-space.patch (renamed from toolchain/kernel-headers/linux-2.6.32.13-scsi-use-__uX-types-for-headers-exported-to-user-space.patch)0
-rw-r--r--toolchain/kernel-headers/linux-2.6.33.5-scsi-use-__uX-types-for-headers-exported-to-user-space.patch (renamed from toolchain/kernel-headers/linux-2.6.33.4-scsi-use-__uX-types-for-headers-exported-to-user-space.patch)0
-rw-r--r--toolchain/uClibc/uClibc-0.9.31.config2
7 files changed, 50 insertions, 8 deletions
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index f04f18a21..595ab8719 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -56,6 +56,21 @@ config BR2_ENABLE_LOCALE_WHITELIST
will be available on the target - That purely depends on the
support for that locale in the selected packages.
+# glibc and eglibc directly include gettext, so a separatly compiled
+# gettext isn't needed and shouldn't be built to avoid conflicts. Some
+# packages always need gettext, other packages only need gettext when
+# locale support is enabled. See the documentation for how packages
+# should rely on the following two options.
+
+config BR2_NEEDS_GETTEXT
+ bool
+ default y if BR2_TOOLCHAIN_BUILDROOT
+ default y if BR2_TOOLCHAIN_EXTERNAL_UCLIBC
+
+config BR2_NEEDS_GETTEXT_IF_LOCALE
+ bool
+ default y if (BR2_NEEDS_GETTEXT && BR2_ENABLE_LOCALE)
+
config BR2_USE_WCHAR
bool "Enable WCHAR support"
help
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index 923c76bcd..34149c1a3 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -23,10 +23,10 @@ fi
# sanity check for CWD in LD_LIBRARY_PATH
# try not to rely on egrep..
if test -n "$LD_LIBRARY_PATH" ; then
- /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep ':.:' >/dev/null 2>&1 ||
- /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep 'TRiGGER_start:' >/dev/null 2>&1 ||
- /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep ':TRiGGER_end' >/dev/null 2>&1 ||
- /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep '::' >/dev/null 2>&1
+ /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep ':\.:' >/dev/null 2>&1 ||
+ /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep 'TRiGGER_start\.:' >/dev/null 2>&1 ||
+ /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep ':\.TRiGGER_end' >/dev/null 2>&1 ||
+ /bin/echo TRiGGER_start"$LD_LIBRARY_PATH"TRiGGER_end | /bin/grep 'TRiGGER_start\.TRiGGER_end' >/dev/null 2>&1
if test $? = 0; then
/bin/echo -e "\nYou seem to have the current working directory in your"
/bin/echo -e "LD_LIBRARY_PATH environment variable. This doesn't work.\n"
@@ -34,6 +34,21 @@ if test -n "$LD_LIBRARY_PATH" ; then
fi
fi;
+# sanity check for CWD in PATH. Having the current working directory
+# in the PATH makes the toolchain build process break.
+# try not to rely on egrep..
+if test -n "$PATH" ; then
+ /bin/echo TRiGGER_start"$PATH"TRiGGER_end | /bin/grep ':\.:' >/dev/null 2>&1 ||
+ /bin/echo TRiGGER_start"$PATH"TRiGGER_end | /bin/grep 'TRiGGER_start\.:' >/dev/null 2>&1 ||
+ /bin/echo TRiGGER_start"$PATH"TRiGGER_end | /bin/grep ':\.TRiGGER_end' >/dev/null 2>&1 ||
+ /bin/echo TRiGGER_start"$PATH"TRiGGER_end | /bin/grep 'TRIGGER_start\.TRIGGER_end' >/dev/null 2>&1
+ if test $? = 0; then
+ /bin/echo -e "\nYou seem to have the current working directory in your"
+ /bin/echo -e "PATH environment variable. This doesn't work.\n"
+ exit 1;
+ fi
+fi;
+
# Verify that which is installed
if ! which which > /dev/null ; then
/bin/echo -e "\nYou must install 'which' on your build machine\n";
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 2c2562cde..bb4809ccd 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -232,6 +232,15 @@ check_arm_abi = \
fi ; \
#
+# Check that the external toolchain supports C++
+#
+check_cplusplus = \
+ if ! test -x $(TARGET_CXX) ; then \
+ echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
+ exit 1 ; \
+ fi ; \
+
+#
# Check that the cross-compiler given in the configuration exists
#
check_cross_compiler_exists = \
@@ -288,6 +297,9 @@ endif
ifeq ($(BR2_arm),y)
$(Q)$(call check_arm_abi)
endif
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ $(Q)$(call check_cplusplus)
+endif
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
$(Q)$(call check_uclibc,$(SYSROOT_DIR))
else
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 3b0c93b84..c58e24339 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -58,12 +58,12 @@ config BR2_DEFAULT_KERNEL_VERSION
config BR2_DEFAULT_KERNEL_HEADERS
string
- default "2.6.27.46" if BR2_KERNEL_HEADERS_2_6_27
+ default "2.6.27.47" if BR2_KERNEL_HEADERS_2_6_27
default "2.6.28.10" if BR2_KERNEL_HEADERS_2_6_28
default "2.6.29.6" if BR2_KERNEL_HEADERS_2_6_29
default "2.6.30.10" if BR2_KERNEL_HEADERS_2_6_30
default "2.6.31.13" if BR2_KERNEL_HEADERS_2_6_31
- default "2.6.32.13" if BR2_KERNEL_HEADERS_2_6_32
- default "2.6.33.4" if BR2_KERNEL_HEADERS_2_6_33
+ default "2.6.32.14" if BR2_KERNEL_HEADERS_2_6_32
+ default "2.6.33.5" if BR2_KERNEL_HEADERS_2_6_33
default "2.6" if BR2_KERNEL_HEADERS_SNAP
default $BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION
diff --git a/toolchain/kernel-headers/linux-2.6.32.13-scsi-use-__uX-types-for-headers-exported-to-user-space.patch b/toolchain/kernel-headers/linux-2.6.32.14-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
index 2fc6176e8..2fc6176e8 100644
--- a/toolchain/kernel-headers/linux-2.6.32.13-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
+++ b/toolchain/kernel-headers/linux-2.6.32.14-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
diff --git a/toolchain/kernel-headers/linux-2.6.33.4-scsi-use-__uX-types-for-headers-exported-to-user-space.patch b/toolchain/kernel-headers/linux-2.6.33.5-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
index 1089c7106..1089c7106 100644
--- a/toolchain/kernel-headers/linux-2.6.33.4-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
+++ b/toolchain/kernel-headers/linux-2.6.33.5-scsi-use-__uX-types-for-headers-exported-to-user-space.patch
diff --git a/toolchain/uClibc/uClibc-0.9.31.config b/toolchain/uClibc/uClibc-0.9.31.config
index 57541b93f..87f241111 100644
--- a/toolchain/uClibc/uClibc-0.9.31.config
+++ b/toolchain/uClibc/uClibc-0.9.31.config
@@ -62,7 +62,7 @@ DOPIC=y
# ARCH_HAS_NO_SHARED is not set
# ARCH_HAS_NO_LDSO is not set
HAVE_SHARED=y
-FORCE_SHAREABLE_TEXT_SEGMENTS=y
+# FORCE_SHAREABLE_TEXT_SEGMENTS is not set
LDSO_LDD_SUPPORT=y
# LDSO_CACHE_SUPPORT is not set
# LDSO_PRELOAD_FILE_SUPPORT is not set