summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/cramfs/cramfs.mk20
-rw-r--r--target/squashfs/squashfsroot.mk20
2 files changed, 6 insertions, 34 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index 54a0fa845..334048cd4 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -39,24 +39,10 @@ cramfs-dirclean:
# Build the cramfs root filesystem image
#
#############################################################
-CRAMFS_ENDIANNESS=-l
-ifeq ($(strip $(BR2_armeb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_mips)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
CRAMFS_ENDIANNESS=-b
+else
+CRAMFS_ENDIANNESS=-l
endif
CRAMFS_TARGET=$(IMAGE).cramfs
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index 515153a0a..c9eb74327 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -35,24 +35,10 @@ squashfs-dirclean:
# Build the squashfs root filesystem image
#
#############################################################
-SQUASHFS_ENDIANNESS=-le
-ifeq ($(strip $(BR2_armeb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_mips)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
SQUASHFS_ENDIANNESS=-be
+else
+SQUASHFS_ENDIANNESS=-le
endif
SQUASHFS_TARGET:=$(IMAGE).squashfs