summaryrefslogtreecommitdiffstats
path: root/target/ubifs
diff options
context:
space:
mode:
Diffstat (limited to 'target/ubifs')
-rw-r--r--target/ubifs/Config.in103
-rw-r--r--target/ubifs/ubifsroot.mk125
2 files changed, 0 insertions, 228 deletions
diff --git a/target/ubifs/Config.in b/target/ubifs/Config.in
deleted file mode 100644
index 886c34bfb..000000000
--- a/target/ubifs/Config.in
+++ /dev/null
@@ -1,103 +0,0 @@
-config BR2_TARGET_ROOTFS_UBIFS
- bool "ubifs root filesystem"
- depends on BROKEN # upstream git gone, should use mtd-utils
- select BR2_HOST_FAKEROOT
- help
- Build a ubifs root filesystem
-
-config BR2_TARGET_ROOTFS_UBIFS_LEBSIZE
- hex "UBI logical erase block size"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default 0x1f800
-
-config BR2_TARGET_ROOTFS_UBIFS_MINIOSIZE
- hex "UBI minimum I/O size"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default 0x800
- help
- Some comment required here
-
-config BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT
- int "Maximum LEB count"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default 2048
- help
- Some comment required here
-
-config BR2_TARGET_ROOTFS_UBIFS_OUTPUT
- string "Output File"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default "$(IMAGE).ubifs"
-
-choice
- prompt "ubifs runtime compression"
- default BR2_TARGET_ROOTFS_UBIFS_RT_LZO
- depends on BR2_TARGET_ROOTFS_UBIFS
- help
- Select which compression format to use at run-time within
- the ubifs file system.
-
-config BR2_TARGET_ROOTFS_UBIFS_RT_NONE
- bool "no compression"
- help
- Don't use run-time compression.
-
-config BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB
- bool "gzip"
- help
- Use zlib compression at run-time.
-
-config BR2_TARGET_ROOTFS_UBIFS_RT_LZO
- bool "lzo"
- help
- Use lzo compression at run-time.
-
-endchoice
-
-choice
- prompt "Compression method"
- default BR2_TARGET_ROOTFS_UBIFS_NONE
- depends on BR2_TARGET_ROOTFS_UBIFS
- help
- Select which compression format to compress the final image
- into.
-
-config BR2_TARGET_ROOTFS_UBIFS_NONE
- bool "no compression"
- help
- Do not compress the ubifs filesystem.
-
-config BR2_TARGET_ROOTFS_UBIFS_GZIP
- bool "gzip"
- help
- Do compress the ubifs filesystem with gzip.
- Note that you either have to have gzip installed on your
- host or select to build a gzip for your host. See the
- packages submenu.
-
-config BR2_TARGET_ROOTFS_UBIFS_BZIP2
- bool "bzip2"
- help
- Do compress the ubifs filesystem with bzip2.
- Note that you either have to have bzip2 installed on your
- host or select to build a bzip2 for your host. See the
- packages submenu.
-
-config BR2_TARGET_ROOTFS_UBIFS_LZMA
- bool "lzma"
- help
- Do compress the ubifs filesystem with lzma.
- Note that you either have to have lzma installed on your
- host or select to build a lzma for your host. See the
- packages submenu.
-
-endchoice
-
-config BR2_TARGET_ROOTFS_UBIFS_COPYTO
- string "also copy the image to..."
- depends on BR2_TARGET_ROOTFS_UBIFS
- default ""
- help
- Copies the resulting image to a secondary location
- like a tftp server's root directory.
-
diff --git a/target/ubifs/ubifsroot.mk b/target/ubifs/ubifsroot.mk
deleted file mode 100644
index e73d4f926..000000000
--- a/target/ubifs/ubifsroot.mk
+++ /dev/null
@@ -1,125 +0,0 @@
-#############################################################
-#
-# mkfs.ubifs to build to target ubifs filesystems
-#
-#############################################################
-#MKFS_UBIFS_VERSION=2582f128dad78591bc3adcc87c343c690bb82e61
-#MKFS_UBIFS_URL=http://git.infradead.org/users/dedekind/mkfs.ubifs.git?a=snapshot;h=$(MKFS_UBIFS_VERSION);sf=tgz
-MKFS_UBIFS_VERSION=v0.4
-MKFS_UBIFS_URL=http://git.infradead.org/users/dedekind/mkfs.ubifs.git?a=snapshot;h=refs/tags/mkfs.ubifs-$(MKFS_UBIFS_VERSION);sf=tgz
-MKFS_UBIFS_SOURCE:=mkfs.ubifs-$(MKFS_UBIFS_VERSION).tar.gz
-MKFS_UBIFS_DIR:= $(BUILD_DIR)/mkfs-ubifs-$(MKFS_UBIFS_VERSION)
-MKFS_UBIFS_CAT:=$(ZCAT)
-MKFS_UBIFS_NAME:=mkfs.ubifs
-
-$(DL_DIR)/$(MKFS_UBIFS_SOURCE):
- $(WGET) -O $(DL_DIR)/$(MKFS_UBIFS_SOURCE) "$(MKFS_UBIFS_URL)"
-
-$(MKFS_UBIFS_DIR)/.unpacked: $(DL_DIR)/$(MKFS_UBIFS_SOURCE)
- $(ZCAT) $(DL_DIR)/$(MKFS_UBIFS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- mv $(BUILD_DIR)/$(MKFS_UBIFS_NAME) $(MKFS_UBIFS_DIR)
- toolchain/patch-kernel.sh $(MKFS_UBIFS_DIR) target/ubifs/ mkfs-ubifs-\*.patch
- touch $@
-
-$(MKFS_UBIFS_DIR)/mkfs.ubifs: $(MKFS_UBIFS_DIR)/.unpacked
- $(MAKE) -C $(MKFS_UBIFS_DIR)
- touch -c $@
-
-mkfs.ubifs-dirclean:
- rm -rf $(MKFS_UBIFS_DIR)
-
-mkfs.ubifs: $(MKFS_UBIFS_DIR)/mkfs.ubifs
-
-#############################################################
-#
-# Build the ubifs root filesystem image
-#
-#############################################################
-
-UBIFS_OPTS := -e $(BR2_TARGET_ROOTFS_UBIFS_LEBSIZE) -c $(BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT) -m $(BR2_TARGET_ROOTFS_UBIFS_MINIOSIZE)
-
-UBIFS_BASE := $(call qstrip,$(BR2_TARGET_ROOTFS_UBIFS_OUTPUT))
-
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB),y)
-UBIFS_OPTS += -x zlib
-endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_LZI),y)
-UBIFS_OPTS += -x lzo
-endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
-UBIFS_OPTS += -x none
-endif
-
-UBIFS_ROOTFS_COMPRESSOR:=
-UBIFS_ROOTFS_COMPRESSOR_EXT:=
-UBIFS_ROOTFS_COMPRESSOR_PREREQ:=
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_GZIP),y)
-UBIFS_ROOTFS_COMPRESSOR:=gzip -9 -c
-UBIFS_ROOTFS_COMPRESSOR_EXT:=gz
-#UBIFS_ROOTFS_COMPRESSOR_PREREQ:= gzip-host
-endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_BZIP2),y)
-UBIFS_ROOTFS_COMPRESSOR:=bzip2 -9 -c
-UBIFS_ROOTFS_COMPRESSOR_EXT:=bz2
-#UBIFS_ROOTFS_COMPRESSOR_PREREQ:= bzip2-host
-endif
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS_LZMA),y)
-UBIFS_ROOTFS_COMPRESSOR:=lzma -9 -c
-UBIFS_ROOTFS_COMPRESSOR_EXT:=lzma
-UBIFS_ROOTFS_COMPRESSOR_PREREQ:= lzma-host
-endif
-
-ifneq ($(UBIFS_ROOTFS_COMPRESSOR),)
-UBIFS_TARGET := $(UBIFS_BASE).$(UBIFS_ROOTFS_COMPRESSOR_EXT)
-else
-UBIFS_TARGET := $(UBIFS_BASE)
-endif
-
-$(UBIFS_BASE): host-fakeroot makedevs mkfs.ubifs
- # Use fakeroot to pretend all target binaries are owned by root
- rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
- touch $(BUILD_DIR)/.fakeroot.00000
- cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
- echo "chown -R 0:0 $(TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-ifneq ($(TARGET_DEVICE_TABLE),)
- # Use fakeroot to pretend to create all needed device nodes
- echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-endif
- # Use fakeroot so mkfs.ubifs believes the previous fakery
- echo "$(MKFS_UBIFS_DIR)/mkfs.ubifs -d $(TARGET_DIR) " \
- "$(UBIFS_OPTS) -o $(UBIFS_BASE)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
- chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
- $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
- -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-
-ifneq ($(UBIFS_ROOTFS_COMPRESSOR),)
-$(UBIFS_BASE).$(UBIFS_ROOTFS_COMPRESSOR_EXT): $(UBIFS_ROOTFS_COMPRESSOR_PREREQ) $(UBIFS_BASE)
- $(UBIFS_ROOTFS_COMPRESSOR) $(UBIFS_BASE) > $(UBIFS_TARGET)
-endif
-
-UBIFS_COPYTO := $(call qstrip,$(BR2_TARGET_ROOTFS_UBIFS_COPYTO))
-
-ubifsroot: $(UBIFS_TARGET)
- @ls -l $(UBIFS_TARGET)
-ifneq ($(UBIFS_COPYTO),)
- @cp -f $(UBIFS_TARGET) $(UBIFS_COPYTO)
-endif
-
-ubifsroot-source: $(DL_DIR)/$(MKFS_UBIFS_SOURCE)
-
-ubifsroot-clean:
- -$(MAKE) -C $(MKFS_UBIFS_DIR) clean
-
-ubifsroot-dirclean:
- rm -rf $(MKFS_UBIFS_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_UBIFS),y)
-TARGETS+=ubifsroot
-endif
-