summaryrefslogtreecommitdiffstats
path: root/target/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'target/u-boot')
-rw-r--r--target/u-boot/Config.in9
-rw-r--r--target/u-boot/Makefile.in11
2 files changed, 14 insertions, 6 deletions
diff --git a/target/u-boot/Config.in b/target/u-boot/Config.in
index bd0251be5..a4994c4cc 100644
--- a/target/u-boot/Config.in
+++ b/target/u-boot/Config.in
@@ -13,16 +13,20 @@ config BR2_TARGET_UBOOT_BOARDNAME
choice
prompt "U-Boot Version"
- default BR2_TARGET_UBOOT_2009_03
+ default BR2_TARGET_UBOOT_2009_06
help
Select the specific U-Boot version you want to use
+config BR2_TARGET_UBOOT_2009_06
+ bool "u-boot-2009.06"
+
config BR2_TARGET_UBOOT_2009_03
bool "u-boot-2009.03"
+ depends on BR2_DEPRECATED || BR2_RECENT
config BR2_TARGET_UBOOT_2009_01
bool "u-boot-2009.01"
- depends on BR2_DEPRECATED || BR2_RECENT
+ depends on BR2_DEPRECATED
config BR2_TARGET_UBOOT_2008_10
bool "u-boot-2008.10"
@@ -39,6 +43,7 @@ endchoice
config BR2_UBOOT_VERSION
string
+ default "2009.06" if BR2_TARGET_UBOOT_2009_06
default "2009.03" if BR2_TARGET_UBOOT_2009_03
default "2009.01" if BR2_TARGET_UBOOT_2009_01
default "2008.10" if BR2_TARGET_UBOOT_2008_10
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index cd184045d..b74e43aab 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -186,16 +186,19 @@ $(U_BOOT_TOOLS): $(U_BOOT_DIR)/$(U_BOOT_BIN)
$(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)
mkdir -p $(@D)
- $(TARGET_CC) -I$(U_BOOT_DIR)/include -DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/mkimage.c \
- $(addprefix $(U_BOOT_DIR)/tools/,crc32.c image.c md5.c sha1.c fdt*.c)
+ $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(U_BOOT_DIR)/tools \
+ -DUSE_HOSTCC -o $@ \
+ $(U_BOOT_DIR)/tools/mkimage.c $(U_BOOT_DIR)/common/image.c \
+ $(addprefix $(U_BOOT_DIR)/lib_generic/,crc32.c md5.c sha1.c) \
+ $(U_BOOT_DIR)/libfdt/fdt*.c
+
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
$(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/$(U_BOOT_BIN)
mkdir -p $(@D)
$(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \
-DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/tools/crc32.c
+ $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/lib_generic/crc32.c
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv