summaryrefslogtreecommitdiffstats
path: root/target/tar
diff options
context:
space:
mode:
Diffstat (limited to 'target/tar')
-rw-r--r--target/tar/Config.in59
-rw-r--r--target/tar/tarroot.mk64
2 files changed, 0 insertions, 123 deletions
diff --git a/target/tar/Config.in b/target/tar/Config.in
deleted file mode 100644
index 020965480..000000000
--- a/target/tar/Config.in
+++ /dev/null
@@ -1,59 +0,0 @@
-config BR2_TARGET_ROOTFS_TAR
- bool "tar the root filesystem"
- select BR2_HOST_FAKEROOT
- help
- Build a tar archive of the root filesystem
-
-choice
- prompt "Compression method"
- default BR2_TARGET_ROOTFS_TAR_NONE
- depends on BR2_TARGET_ROOTFS_TAR
- help
- Select compressor for tar archive of the root filesystem
-
-config BR2_TARGET_ROOTFS_TAR_NONE
- bool "no compression"
- help
- Do not compress the tarball.
-
-config BR2_TARGET_ROOTFS_TAR_GZIP
- bool "gzip"
- help
- Do compress the tarball with gzip.
- Note that you either have to have gzip installed on your host
- or select to build a gzip for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_TAR_BZIP2
- bool "bzip2"
- help
- Do compress the tarball with bzip2.
- Note that you either have to have bzip2 installed on your host
- or select to build a bzip2 for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_TAR_LZMA
- bool "lzma"
- help
- Do compress the tarball with lzma.
- Note that you either have to have lzma installed on your host
- or select to build a lzma for your host. See the packages submenu.
-
-endchoice
-
-config BR2_TARGET_ROOTFS_TAR_OPTIONS
- string "other random options to pass to tar"
- depends on BR2_TARGET_ROOTFS_TAR
- default ""
- help
- Any other flags you want to pass to tar
- Refer to tar --help for details
-
-config BR2_TARGET_ROOTFS_TAR_COPYTO
- string "also copy the image to..."
- depends on BR2_TARGET_ROOTFS_TAR
- default ""
- help
- Copies the resulting image to a secondary location
- like a tftp server's root directory.
-
- Example: $(IMAGE)-$(DATE).tar
-
diff --git a/target/tar/tarroot.mk b/target/tar/tarroot.mk
deleted file mode 100644
index a7e95df98..000000000
--- a/target/tar/tarroot.mk
+++ /dev/null
@@ -1,64 +0,0 @@
-#############################################################
-#
-# tar to archive target filesystem
-#
-#############################################################
-
-TAR_OPTS:=$(BR2_TARGET_ROOTFS_TAR_OPTIONS)
-TAR_TARGET:=$(IMAGE).tar
-
-TAR_COMPRESSOR:=
-TAR_COMPRESSOR_EXT:=.none
-ifeq ($(BR2_TARGET_ROOTFS_TAR_GZIP),y)
-TAR_COMPRESSOR:=gzip -9 -c
-TAR_COMPRESSOR_EXT:=gz
-endif
-ifeq ($(BR2_TARGET_ROOTFS_TAR_BZIP2),y)
-TAR_COMPRESSOR:=bzip2 -9 -c
-TAR_COMPRESSOR_EXT:=bz2
-endif
-ifeq ($(BR2_TARGET_ROOTFS_TAR_LZMA),y)
-TAR_COMPRESSOR:=lzma -9 -c
-TAR_COMPRESSOR_EXT:=lzma
-endif
-ROOTFS_TAR_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_TAR_COPYTO))
-
-tarroot: host-fakeroot makedevs
- # Use fakeroot to pretend all target binaries are owned by root
- rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
- touch $(BUILD_DIR)/.fakeroot.00000
- cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
- echo "chown -R 0:0 $(TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
-ifneq ($(TARGET_DEVICE_TABLE),)
- # Use fakeroot to pretend to create all needed device nodes
- echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
-endif
- # Use fakeroot so tar believes the previous fakery
- echo "tar -c$(TAR_OPTS)f $(TAR_TARGET) -C $(TARGET_DIR) ." \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
- chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
- $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
-ifneq ($(TAR_COMPRESSOR),)
- -rm -f $(TAR_TARGET).$()
- PATH="$(STAGING_DIR)/sbin:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/usr/bin:$(PATH)" $(TAR_COMPRESSOR) $(TAR_TARGET) > $(TAR_TARGET).$(TAR_COMPRESSOR_EXT)
-endif
-ifneq ($(ROOTFS_TAR_COPYTO),)
- $(Q)cp -f $(TAR_TARGET) $(ROOTFS_TAR_COPYTO)
-endif
- -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
-
-tarroot-source:
-
-tarroot-clean:
-
-tarroot-dirclean:
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_TAR),y)
-TARGETS+=tarroot
-endif