summaryrefslogtreecommitdiffstats
path: root/target/ext2
diff options
context:
space:
mode:
Diffstat (limited to 'target/ext2')
-rw-r--r--target/ext2/Config.in75
-rw-r--r--target/ext2/ext2root.mk146
-rw-r--r--target/ext2/genext2fs-1.4-nosquash.patch14
-rw-r--r--target/ext2/genext2fs-1.4-remove_ugly_warnings.patch21
4 files changed, 0 insertions, 256 deletions
diff --git a/target/ext2/Config.in b/target/ext2/Config.in
deleted file mode 100644
index e94fb401c..000000000
--- a/target/ext2/Config.in
+++ /dev/null
@@ -1,75 +0,0 @@
-config BR2_TARGET_ROOTFS_EXT2
- bool "ext2 root filesystem"
- default y
- select BR2_HOST_FAKEROOT
- help
- Build an ext2 root filesystem
-
-config BR2_TARGET_ROOTFS_EXT2_BLOCKS
- int "size in blocks (leave at 0 for auto calculation)"
- depends on BR2_TARGET_ROOTFS_EXT2
- default 0
-
-config BR2_TARGET_ROOTFS_EXT2_INODES
- int "inodes (leave at 0 for auto calculation)"
- depends on BR2_TARGET_ROOTFS_EXT2
- default 0
-
-config BR2_TARGET_ROOTFS_EXT2_RESBLKS
- int "reserved blocks percentage"
- depends on BR2_TARGET_ROOTFS_EXT2
- default 0
-
-config BR2_TARGET_ROOTFS_EXT2_SQUASH
- bool "Make all files be owned by root"
- depends on BR2_TARGET_ROOTFS_EXT2
- default y
-
-config BR2_TARGET_ROOTFS_EXT2_OUTPUT
- string "Output File"
- depends on BR2_TARGET_ROOTFS_EXT2
- default "$(IMAGE).ext2"
-
-choice
- prompt "Compression method"
- default BR2_TARGET_ROOTFS_EXT2_NONE
- depends on BR2_TARGET_ROOTFS_EXT2
- help
- Select compressor for ext2 filesystem of the root filesystem
-
-config BR2_TARGET_ROOTFS_EXT2_NONE
- bool "no compression"
- help
- Do not compress the ext2 filesystem.
-
-config BR2_TARGET_ROOTFS_EXT2_GZIP
- bool "gzip"
- help
- Do compress the ext2 filesystem with gzip.
- Note that you either have to have gzip installed on your host
- or select to build a gzip for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_EXT2_BZIP2
- bool "bzip2"
- help
- Do compress the ext2 filesystem with bzip2.
- Note that you either have to have bzip2 installed on your host
- or select to build a bzip2 for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_EXT2_LZMA
- bool "lzma"
- help
- Do compress the ext2 filesystem with lzma.
- Note that you either have to have lzma installed on your host
- or select to build a lzma for your host. See the packages submenu.
-
-endchoice
-
-config BR2_TARGET_ROOTFS_EXT2_COPYTO
- string "also copy the image to..."
- depends on BR2_TARGET_ROOTFS_EXT2
- default ""
- help
- Copies the resulting image to a secondary location
- like a tftp server's root directory.
-
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
deleted file mode 100644
index 622b29329..000000000
--- a/target/ext2/ext2root.mk
+++ /dev/null
@@ -1,146 +0,0 @@
-#############################################################
-#
-# genext2fs to build to target ext2 filesystems
-#
-#############################################################
-GENEXT2_VERSION=1.4
-GENEXT2_DIR=$(BUILD_DIR)/genext2fs-$(GENEXT2_VERSION)
-GENEXT2_SOURCE=genext2fs-$(GENEXT2_VERSION).tar.gz
-GENEXT2_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/genext2fs
-
-$(DL_DIR)/$(GENEXT2_SOURCE):
- $(call DOWNLOAD,$(GENEXT2_SITE),$(GENEXT2_SOURCE))
-
-$(GENEXT2_DIR)/.unpacked: $(DL_DIR)/$(GENEXT2_SOURCE)
- $(ZCAT) $(DL_DIR)/$(GENEXT2_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- toolchain/patch-kernel.sh $(GENEXT2_DIR) target/ext2/ genext2fs\*.patch
- touch $@
-
-$(GENEXT2_DIR)/.configured: $(GENEXT2_DIR)/.unpacked
- chmod a+x $(GENEXT2_DIR)/configure
- (cd $(GENEXT2_DIR); rm -rf config.cache; \
- ./configure $(QUIET) \
- CC="$(HOSTCC)" \
- --prefix=$(STAGING_DIR) \
- )
- touch $@
-
-$(GENEXT2_DIR)/genext2fs: $(GENEXT2_DIR)/.configured
- $(MAKE) CFLAGS="-Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
- -D_FILE_OFFSET_BITS=64" -C $(GENEXT2_DIR)
- touch -c $@
-
-genext2fs: $(GENEXT2_DIR)/genext2fs
-
-
-
-#############################################################
-#
-# Build the ext2 root filesystem image
-#
-#############################################################
-
-EXT2_OPTS :=
-
-ifeq ($(BR2_TARGET_ROOTFS_EXT2_SQUASH),y)
-EXT2_OPTS += -U
-endif
-
-ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
-EXT2_OPTS += -b $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)
-endif
-
-ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_INODES)),0)
-EXT2_OPTS += -N $(BR2_TARGET_ROOTFS_EXT2_INODES)
-endif
-
-ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)),)
-EXT2_OPTS += -m $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)
-endif
-
-EXT2_BASE := $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_OUTPUT))
-
-EXT2_ROOTFS_COMPRESSOR:=
-EXT2_ROOTFS_COMPRESSOR_EXT:=
-EXT2_ROOTFS_COMPRESSOR_PREREQ:=
-ifeq ($(BR2_TARGET_ROOTFS_EXT2_GZIP),y)
-EXT2_ROOTFS_COMPRESSOR:=gzip -9 -c
-EXT2_ROOTFS_COMPRESSOR_EXT:=gz
-#EXT2_ROOTFS_COMPRESSOR_PREREQ:= gzip-host
-endif
-ifeq ($(BR2_TARGET_ROOTFS_EXT2_BZIP2),y)
-EXT2_ROOTFS_COMPRESSOR:=bzip2 -9 -c
-EXT2_ROOTFS_COMPRESSOR_EXT:=bz2
-#EXT2_ROOTFS_COMPRESSOR_PREREQ:= bzip2-host
-endif
-ifeq ($(BR2_TARGET_ROOTFS_EXT2_LZMA),y)
-EXT2_ROOTFS_COMPRESSOR:=lzma -9 -c
-EXT2_ROOTFS_COMPRESSOR_EXT:=lzma
-EXT2_ROOTFS_COMPRESSOR_PREREQ:= lzma-host
-endif
-
-ifneq ($(EXT2_ROOTFS_COMPRESSOR),)
-EXT2_TARGET := $(EXT2_BASE).$(EXT2_ROOTFS_COMPRESSOR_EXT)
-else
-EXT2_TARGET := $(EXT2_BASE)
-endif
-
-$(EXT2_BASE): host-fakeroot makedevs genext2fs
- # Use fakeroot to pretend all target binaries are owned by root
- rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
- touch $(BUILD_DIR)/.fakeroot.00000
- cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
- echo "chown -R 0:0 $(TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
-ifneq ($(TARGET_DEVICE_TABLE),)
- # Use fakeroot to pretend to create all needed device nodes
- echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
-endif
- # Use fakeroot so genext2fs believes the previous fakery
-ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
- GENEXT2_REALSIZE=`LC_ALL=C du -s -c -k $(TARGET_DIR) | grep total | sed -e "s/total//"`; \
- GENEXT2_ADDTOROOTSIZE=`if [ $$GENEXT2_REALSIZE -ge 20000 ]; then echo 16384; else echo 2400; fi`; \
- GENEXT2_SIZE=`expr $$GENEXT2_REALSIZE + $$GENEXT2_ADDTOROOTSIZE`; \
- GENEXT2_ADDTOINODESIZE=`find $(TARGET_DIR) | wc -l`; \
- GENEXT2_INODES=`expr $$GENEXT2_ADDTOINODESIZE + 400`; \
- set -x; \
- echo "$(GENEXT2_DIR)/genext2fs -b $$GENEXT2_SIZE " \
- "-N $$GENEXT2_INODES -d $(TARGET_DIR) " \
- "$(EXT2_OPTS) $(EXT2_BASE)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
-else
- echo "$(GENEXT2_DIR)/genext2fs -d $(TARGET_DIR) " \
- "$(EXT2_OPTS) $(EXT2_BASE)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
-endif
- chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
- $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
- -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
-
-ifneq ($(EXT2_ROOTFS_COMPRESSOR),)
-$(EXT2_BASE).$(EXT2_ROOTFS_COMPRESSOR_EXT): $(EXT2_ROOTFS_COMPRESSOR_PREREQ) $(EXT2_BASE)
- $(EXT2_ROOTFS_COMPRESSOR) $(EXT2_BASE) > $(EXT2_TARGET)
-endif
-
-EXT2_COPYTO := $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_COPYTO))
-
-ext2root: $(EXT2_TARGET)
- @ls -l $(EXT2_TARGET)
-ifneq ($(EXT2_COPYTO),)
- @cp -f $(EXT2_TARGET) $(EXT2_COPYTO)
-endif
-
-ext2root-source: $(DL_DIR)/$(GENEXT2_SOURCE)
-
-ext2root-clean:
- -$(MAKE) -C $(GENEXT2_DIR) clean
-
-ext2root-dirclean:
- rm -rf $(GENEXT2_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_EXT2),y)
-TARGETS+=ext2root
-endif
diff --git a/target/ext2/genext2fs-1.4-nosquash.patch b/target/ext2/genext2fs-1.4-nosquash.patch
deleted file mode 100644
index 236dfccdf..000000000
--- a/target/ext2/genext2fs-1.4-nosquash.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-nosquash/genext2fs.c
---- genext2fs-1.4/genext2fs.c 2006-12-19 17:45:31.000000000 +0100
-+++ genext2fs-1.4-nosquash/genext2fs.c 2007-02-09 10:47:05.000000000 +0100
-@@ -1629,10 +1629,6 @@
- mtime = st.st_mtime;
- name = dent->d_name;
- mode = get_mode(&st);
-- if(squash_uids)
-- uid = gid = 0;
-- if(squash_perms)
-- mode &= ~(FM_IRWXG | FM_IRWXO);
- if(stats)
- switch(st.st_mode & S_IFMT)
- {
diff --git a/target/ext2/genext2fs-1.4-remove_ugly_warnings.patch b/target/ext2/genext2fs-1.4-remove_ugly_warnings.patch
deleted file mode 100644
index ef23dfbe8..000000000
--- a/target/ext2/genext2fs-1.4-remove_ugly_warnings.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru genext2fs-1.4/genext2fs.c genext2fs-1.4-remove_ugly_warnings/genext2fs.c
---- genext2fs-1.4/genext2fs.c 2007-02-09 10:54:56.000000000 +0100
-+++ genext2fs-1.4-remove_ugly_warnings/genext2fs.c 2007-02-09 10:54:30.000000000 +0100
-@@ -1606,7 +1606,7 @@
- static void
- add2fs_from_dir(filesystem *fs, uint32 this_nod, int squash_uids, int squash_perms, uint32 fs_timestamp, struct stats *stats)
- {
-- uint32 nod;
-+ uint32 nod = 0;
- uint32 uid, gid, mode, ctime, mtime;
- const char *name;
- FILE *fh;
-@@ -2056,7 +2056,7 @@
- static filesystem *
- load_fs(FILE * fh, int swapit)
- {
-- size_t fssize;
-+ size_t fssize = 0;
- filesystem *fs;
- if((fseek(fh, 0, SEEK_END) < 0) || ((ssize_t)(fssize = ftell(fh)) == -1))
- perror_msg_and_die("input filesystem image");