summaryrefslogtreecommitdiffstats
path: root/target/device
diff options
context:
space:
mode:
Diffstat (limited to 'target/device')
-rw-r--r--target/device/Arm/Config.in4
-rw-r--r--target/device/Arm/Makefile.in2
-rw-r--r--target/device/Arm/integrator926_defconfig4
-rw-r--r--target/device/Arm/integrator926_huge_defconfig4
-rw-r--r--target/device/Atmel/at91rm9200df/at91rm9200df_defconfig4
-rw-r--r--target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig4
-rw-r--r--target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig4
-rw-r--r--target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig4
8 files changed, 15 insertions, 15 deletions
diff --git a/target/device/Arm/Config.in b/target/device/Arm/Config.in
index a52f9ef64..c14f24661 100644
--- a/target/device/Arm/Config.in
+++ b/target/device/Arm/Config.in
@@ -12,8 +12,8 @@ config BR2_TARGET_ARM_INTEGRATOR_926
depends BR2_arm
default n
select BR2_PACKAGE_LINUX
- select BR2_ARM_EABI
- select BR2_KERNEL_HEADERS_2_6_20
+ select BR2_EABI
+ select BR2_KERNEL_HEADERS_2_6_22
select BR2_PTHREADS
select BR2_arm926t
help
diff --git a/target/device/Arm/Makefile.in b/target/device/Arm/Makefile.in
index a55389e7f..db1b81240 100644
--- a/target/device/Arm/Makefile.in
+++ b/target/device/Arm/Makefile.in
@@ -7,7 +7,7 @@ UCLIBC_CONFIG_FILE:=target/device/Arm/uClibc.integrator926.config
endif
# pin some settings
-BR2_ARM_EABI:=y
+BR2_EABI:=y
BR2_GNU_TARGET_SUFFIX:="linux-uclibcgnueabi"
BR2_DEFAULT_KERNEL_HEADERS:="2.6.22.8"
endif
diff --git a/target/device/Arm/integrator926_defconfig b/target/device/Arm/integrator926_defconfig
index 1977375eb..2b4d9c676 100644
--- a/target/device/Arm/integrator926_defconfig
+++ b/target/device/Arm/integrator926_defconfig
@@ -39,8 +39,8 @@ BR2_arm926t=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="ARM926T"
-# BR2_ARM_OABI is not set
-BR2_ARM_EABI=y
+# BR2_OABI is not set
+BR2_EABI=y
# BR2_x86_i386 is not set
# BR2_x86_i486 is not set
# BR2_x86_i586 is not set
diff --git a/target/device/Arm/integrator926_huge_defconfig b/target/device/Arm/integrator926_huge_defconfig
index 43e436ca3..72c0d0757 100644
--- a/target/device/Arm/integrator926_huge_defconfig
+++ b/target/device/Arm/integrator926_huge_defconfig
@@ -39,8 +39,8 @@ BR2_arm926t=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="ARM926T"
-# BR2_ARM_OABI is not set
-BR2_ARM_EABI=y
+# BR2_OABI is not set
+BR2_EABI=y
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
BR2_GCC_TARGET_TUNE="arm9tdmi"
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
index 38cdc8fcd..ddbf9b624 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
+++ b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
@@ -153,8 +153,8 @@ BR2_GCC_VERSION_4_2_1=y
BR2_GCC_SUPPORTS_SYSROOT=y
# BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE is not set
BR2_GCC_VERSION="4.2.1"
-BR2_ARM_OABI=y
-# BR2_ARM_EABI is not set
+BR2_OABI=y
+# BR2_EABI is not set
BR2_TOOLCHAIN_SYSROOT=y
# BR2_GCC_USE_SJLJ_EXCEPTIONS is not set
BR2_EXTRA_GCC_CONFIG_OPTIONS=""
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
index 69afb804b..e11611d25 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
+++ b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
@@ -42,8 +42,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_ARM_OABI=y
-# BR2_ARM_EABI is not set
+BR2_OABI=y
+# BR2_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
index 36dd77a5b..54af41f40 100644
--- a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
+++ b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
@@ -44,8 +44,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_ARM_OABI=y
-# BR2_ARM_EABI is not set
+BR2_OABI=y
+# BR2_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
index 5558c2cf3..265eb0b91 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
+++ b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
@@ -44,8 +44,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_ARM_OABI=y
-# BR2_ARM_EABI is not set
+BR2_OABI=y
+# BR2_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"