summaryrefslogtreecommitdiffstats
path: root/target/device/Atmel
diff options
context:
space:
mode:
Diffstat (limited to 'target/device/Atmel')
-rw-r--r--target/device/Atmel/Makefile.in1
-rw-r--r--target/device/Atmel/arch-arm/Config.in.linux.patches7
-rw-r--r--target/device/Atmel/atngw100-base/Makefile.in1
-rw-r--r--target/device/Atmel/atngw100/Makefile.in1
-rw-r--r--target/device/Atmel/atstk1005/Makefile.in1
-rw-r--r--target/device/Atmel/atstk100x/Makefile.in1
6 files changed, 7 insertions, 5 deletions
diff --git a/target/device/Atmel/Makefile.in b/target/device/Atmel/Makefile.in
index bf7a2d108..c5dfffd70 100644
--- a/target/device/Atmel/Makefile.in
+++ b/target/device/Atmel/Makefile.in
@@ -8,7 +8,6 @@ BOARD_PATH:=$(call qstrip,$(BR2_BOARD_PATH))
ATMEL_TARGET:=$(ATMEL_PATH)/root
TARGET_SKELETON:=$(ATMEL_TARGET)/target_skeleton
-TARGET_DEVICE_TABLE:=$(ATMEL_TARGET)/device_table.txt
TARGET_SKELETON_LINKS:=$(ATMEL_TARGET)/skel.tar.gz
ifeq ($(BR2_avr32),y)
diff --git a/target/device/Atmel/arch-arm/Config.in.linux.patches b/target/device/Atmel/arch-arm/Config.in.linux.patches
index 0ea509196..8cd9a856a 100644
--- a/target/device/Atmel/arch-arm/Config.in.linux.patches
+++ b/target/device/Atmel/arch-arm/Config.in.linux.patches
@@ -2,11 +2,17 @@ choice
prompt "Add AT91 specific patches"
depends on BR2_KERNEL_ARCH_PATCH_ENABLED
depends on BR2_TARGET_ATMEL && BR2_arm
+ default BR2_ARCH_AT91_2_6_30 if BR2_LINUX_2_6_30
default BR2_ARCH_AT91_2_6_28 if BR2_LINUX_2_6_28
default BR2_ARCH_AT91_2_6_27 if BR2_LINUX_2_6_27
help
Select a patch to add to the Linux kernel
+config BR2_ARCH_AT91_2_6_30
+ bool "2.6.30"
+ help
+ Apply the at91 linux-2.6.30 patches
+
config BR2_ARCH_AT91_2_6_28
bool "2.6.28"
help
@@ -22,6 +28,7 @@ config BR2_KERNEL_ARCH_PATCH_VERSION
string
depends on BR2_KERNEL_ARCH_PATCH_ENABLED
depends on BR2_TARGET_ATMEL && BR2_arm
+ default "2.6.30" if BR2_ARCH_AT91_2_6_30
default "2.6.28" if BR2_ARCH_AT91_2_6_28
default "2.6.27" if BR2_ARCH_AT91_2_6_27
diff --git a/target/device/Atmel/atngw100-base/Makefile.in b/target/device/Atmel/atngw100-base/Makefile.in
index 467951f08..c2f296970 100644
--- a/target/device/Atmel/atngw100-base/Makefile.in
+++ b/target/device/Atmel/atngw100-base/Makefile.in
@@ -1,5 +1,4 @@
ifeq ($(BR2_TARGET_AVR32_ATNGW100_BASE),y)
UBOOT_BOARD_NAME:=atngw100
TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
endif
diff --git a/target/device/Atmel/atngw100/Makefile.in b/target/device/Atmel/atngw100/Makefile.in
index 3c34d8d4a..7e02d8e83 100644
--- a/target/device/Atmel/atngw100/Makefile.in
+++ b/target/device/Atmel/atngw100/Makefile.in
@@ -1,5 +1,4 @@
ifeq ($(BR2_TARGET_AVR32_ATNGW100),y)
UBOOT_BOARD_NAME:=atngw100
TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
endif
diff --git a/target/device/Atmel/atstk1005/Makefile.in b/target/device/Atmel/atstk1005/Makefile.in
index 4c3aadffb..84b31070d 100644
--- a/target/device/Atmel/atstk1005/Makefile.in
+++ b/target/device/Atmel/atstk1005/Makefile.in
@@ -1,4 +1,3 @@
ifeq ($(strip $(BR2_TARGET_AVR32_ATSTK1005)),y)
TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
endif
diff --git a/target/device/Atmel/atstk100x/Makefile.in b/target/device/Atmel/atstk100x/Makefile.in
index e9dd4dc42..395c74a6e 100644
--- a/target/device/Atmel/atstk100x/Makefile.in
+++ b/target/device/Atmel/atstk100x/Makefile.in
@@ -1,5 +1,4 @@
ifeq ($(strip $(BR2_TARGET_AVR32_ATSTK1002)),y)
UBOOT_BOARD_NAME:=atstk1002
TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
endif