summaryrefslogtreecommitdiffstats
path: root/target/cramfs
diff options
context:
space:
mode:
Diffstat (limited to 'target/cramfs')
-rw-r--r--target/cramfs/cramfs.mk20
1 files changed, 3 insertions, 17 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index 54a0fa845..334048cd4 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -39,24 +39,10 @@ cramfs-dirclean:
# Build the cramfs root filesystem image
#
#############################################################
-CRAMFS_ENDIANNESS=-l
-ifeq ($(strip $(BR2_armeb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_mips)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
CRAMFS_ENDIANNESS=-b
+else
+CRAMFS_ENDIANNESS=-l
endif
CRAMFS_TARGET=$(IMAGE).cramfs