summaryrefslogtreecommitdiffstats
path: root/target/cramfs/cramfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/cramfs/cramfs.mk')
-rw-r--r--target/cramfs/cramfs.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index 5905eb6e5..bc8424000 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -33,23 +33,24 @@ cramfs-dirclean:
# Build the cramfs root filesystem image
#
#############################################################
+CRAMFS_ENDIANNESS=-l
ifeq ($(strip $(BR2_armeb)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_mips)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_powerpc)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_sh3eb)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_sh4eb)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
ifeq ($(strip $(BR2_sparc)),y)
-CRAMFS_ENDIANNESS=-r
+CRAMFS_ENDIANNESS=-b
endif
cramfsroot: cramfs