summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Makefile.autotools.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index b749baea4..e4397c337 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -130,8 +130,8 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
-# support make external-deps
-ifeq ($(strip $(WGET)),$(TOPDIR)toolchain/wget-show-external-deps.sh)
+# support make source/source-check/external-deps
+ifneq ($(filter source,$(MAKECMDGOALS)),)
$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
else
$(call MESSAGE,"Downloading")