summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/rng-tools/Config.in7
-rw-r--r--package/rng-tools/rng-tools.mk13
3 files changed, 21 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index a86b6b347..4e61ea98a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -182,6 +182,7 @@ source "package/mtd/Config.in"
source "package/ntfs-3g/Config.in"
source "package/ntfsprogs/Config.in"
source "package/pciutils/Config.in"
+source "package/rng-tools/Config.in"
source "package/setserial/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
# busybox has fdisk
diff --git a/package/rng-tools/Config.in b/package/rng-tools/Config.in
new file mode 100644
index 000000000..e6dcf9daa
--- /dev/null
+++ b/package/rng-tools/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RNG_TOOLS
+ bool "rng-tools"
+ select BR2_PACKAGE_ARGP_STANDALONE
+ help
+ Daemon to use hardware random number generators.
+
+ http://sourceforge.net/projects/gkernel/
diff --git a/package/rng-tools/rng-tools.mk b/package/rng-tools/rng-tools.mk
new file mode 100644
index 000000000..755f4f80d
--- /dev/null
+++ b/package/rng-tools/rng-tools.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# rng-tools
+#
+#############################################################
+
+RNG_TOOLS_VERSION = 3
+RNG_TOOLS_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/gkernel
+RNG_TOOLS_CONF_ENV = LIBS="-largp"
+RNG_TOOLS_USE_CONFIG_CACHE = NO
+RNG_TOOLS_DEPENDENCIES = argp-standalone
+
+$(eval $(call AUTOTARGETS,package,rng-tools))