aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/apr-util/Config.in2
-rw-r--r--package/apr/Config.in2
-rw-r--r--package/binutils/binutils.mk5
-rw-r--r--package/bison/Config.in2
-rw-r--r--package/busybox/Config.in2
-rw-r--r--package/busybox/busybox-1.20.0/busybox-1.20.0-buildsys.patch11
-rw-r--r--package/busybox/busybox-1.20.0/busybox-1.20.0-getty.patch17
-rw-r--r--package/busybox/busybox-1.20.0/busybox-1.20.0-lineedit.patch22
-rw-r--r--package/busybox/busybox-1.20.0/busybox-1.20.0-sed.patch29
-rw-r--r--package/ccache/ccache.mk24
-rw-r--r--package/cifs-utils/Config.in2
-rw-r--r--package/crosstool-ng/crosstool-ng.mk2
-rw-r--r--package/directfb/Config.in4
-rw-r--r--package/directfb/directfb.mk3
-rw-r--r--package/dnsmasq/dnsmasq.mk4
-rw-r--r--package/games/gnuchess/Config.in4
-rw-r--r--package/gpsd/gpsd-navcom.patch (renamed from package/gpsd/gpsd-2.95-navcom.patch)0
-rw-r--r--package/heirloom-mailx/heirloom-mailx.mk4
-rw-r--r--package/iperf/Config.in2
-rw-r--r--package/libmpeg2/libmpeg2-0.5.1-armv4l.patch (renamed from package/multimedia/libmpeg2/libmpeg2-0.5.1-armv4l.patch)0
-rw-r--r--package/mtd/mtd.mk5
-rw-r--r--package/ndisc6/ndisc6.mk5
-rw-r--r--package/netsnmp/netsnmp.mk1
-rw-r--r--package/ntfs-3g/ntfs-3g.mk1
-rw-r--r--package/opencv/opencv.mk2
-rw-r--r--package/openssl/openssl.mk2
-rw-r--r--package/oprofile/oprofile.mk5
-rw-r--r--package/pkg-download.mk2
-rw-r--r--package/pptp-linux/pptp-linux.mk1
-rw-r--r--package/socat/socat-no-documentation.patch37
-rw-r--r--package/socat/socat.mk15
-rw-r--r--package/vala/vala-0.15.2-dont-add-dirty-to-valac-version.patch25
-rw-r--r--package/x11r7/xserver_xorg-server/xserver_xorg-server.mk1
33 files changed, 137 insertions, 106 deletions
diff --git a/package/apr-util/Config.in b/package/apr-util/Config.in
index 99b32f2b0..895dbb86d 100644
--- a/package/apr-util/Config.in
+++ b/package/apr-util/Config.in
@@ -5,6 +5,8 @@ config BR2_PACKAGE_APR_UTIL
select BR2_PACKAGE_NEON
select BR2_PACKAGE_NEON_ZLIB
select BR2_PACKAGE_ZLIB
+ # apr really needs shared library support
+ depends on !BR2_PREFER_STATIC_LIB
help
The utility library for the apache runtime project
diff --git a/package/apr/Config.in b/package/apr/Config.in
index 292cadb67..ed319ed05 100644
--- a/package/apr/Config.in
+++ b/package/apr/Config.in
@@ -1,5 +1,7 @@
config BR2_PACKAGE_APR
bool "apr"
+ # apr really needs shared library support
+ depends on !BR2_PREFER_STATIC_LIB
help
The mission of the Apache Portable Runtime (APR) project is to create
and maintain software libraries that provide a predictable and
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 0a5a948a9..1c8a79d07 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -8,8 +8,13 @@
# If not, we do like other packages
BINUTILS_VERSION = $(call qstrip,$(BR2_BINUTILS_VERSION))
ifeq ($(BINUTILS_VERSION),)
+ifeq ($(BR2_avr32),y)
+# avr32 uses a special version
+BINUTILS_VERSION = 2.18-avr32-1.0.1
+else
BINUTILS_VERSION = 2.21
endif
+endif
BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.bz2
BINUTILS_SITE = $(BR2_GNU_MIRROR)/binutils
diff --git a/package/bison/Config.in b/package/bison/Config.in
index da0ac3f1e..1a485c406 100644
--- a/package/bison/Config.in
+++ b/package/bison/Config.in
@@ -2,6 +2,8 @@ config BR2_PACKAGE_BISON
bool "bison"
depends on BR2_USE_WCHAR
select BR2_PACKAGE_M4
+ # m4 uses fork()
+ depends on BR2_USE_MMU
help
General-purpose parser generator that converts a
grammar description for an LALR context-free grammar into a C
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 946134def..a07864474 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -36,7 +36,7 @@ config BR2_BUSYBOX_VERSION
string
default "1.18.5" if BR2_BUSYBOX_VERSION_1_18_X
default "1.19.4" if BR2_BUSYBOX_VERSION_1_19_X
- default "1.20.0" if BR2_BUSYBOX_VERSION_1_20_X
+ default "1.20.1" if BR2_BUSYBOX_VERSION_1_20_X
config BR2_PACKAGE_BUSYBOX_CONFIG
string "BusyBox configuration file to use?"
diff --git a/package/busybox/busybox-1.20.0/busybox-1.20.0-buildsys.patch b/package/busybox/busybox-1.20.0/busybox-1.20.0-buildsys.patch
deleted file mode 100644
index b9d2a5e83..000000000
--- a/package/busybox/busybox-1.20.0/busybox-1.20.0-buildsys.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- busybox-1.20.0/archival/libarchive/Kbuild.src
-+++ busybox-1.20.0-buildsys/archival/libarchive/Kbuild.src
-@@ -60,7 +60,7 @@ lib-$(CONFIG_FEATURE_SEAMLESS_GZ)
- lib-$(CONFIG_FEATURE_SEAMLESS_BZ2) += open_transformer.o decompress_bunzip2.o
- lib-$(CONFIG_FEATURE_SEAMLESS_LZMA) += open_transformer.o decompress_unlzma.o
- lib-$(CONFIG_FEATURE_SEAMLESS_XZ) += open_transformer.o decompress_unxz.o
--lib-$(CONFIG_FEATURE_COMPRESS_USAGE) += decompress_bunzip2.o
-+lib-$(CONFIG_FEATURE_COMPRESS_USAGE) += open_transformer.o decompress_bunzip2.o
- lib-$(CONFIG_FEATURE_COMPRESS_BBCONFIG) += decompress_bunzip2.o
- lib-$(CONFIG_FEATURE_TAR_TO_COMMAND) += data_extract_to_command.o
-
diff --git a/package/busybox/busybox-1.20.0/busybox-1.20.0-getty.patch b/package/busybox/busybox-1.20.0/busybox-1.20.0-getty.patch
deleted file mode 100644
index ed52159ff..000000000
--- a/package/busybox/busybox-1.20.0/busybox-1.20.0-getty.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- busybox-1.20.0/loginutils/getty.c
-+++ busybox-1.20.0-getty/loginutils/getty.c
-@@ -561,8 +561,14 @@ int getty_main(int argc UNUSED_PARAM, ch
- */
- fd = open("/dev/tty", O_RDWR | O_NONBLOCK);
- if (fd >= 0) {
-+ /* TIOCNOTTY sends SIGHUP to the foreground
-+ * process group - which may include us!
-+ * Make sure to not die on it:
-+ */
-+ sighandler_t old = signal(SIGHUP, SIG_IGN);
- ioctl(fd, TIOCNOTTY);
- close(fd);
-+ signal(SIGHUP, old);
- }
- }
-
diff --git a/package/busybox/busybox-1.20.0/busybox-1.20.0-lineedit.patch b/package/busybox/busybox-1.20.0/busybox-1.20.0-lineedit.patch
deleted file mode 100644
index ee236ffc8..000000000
--- a/package/busybox/busybox-1.20.0/busybox-1.20.0-lineedit.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- busybox-1.20.0/libbb/lineedit.c
-+++ busybox-1.20.0-lineedit/libbb/lineedit.c
-@@ -1352,8 +1352,7 @@ static void load_history(line_input_t *s
- /* fill temp_h[], retaining only last MAX_HISTORY lines */
- memset(temp_h, 0, sizeof(temp_h));
- idx = 0;
-- if (!ENABLE_FEATURE_EDITING_SAVE_ON_EXIT)
-- st_parm->cnt_history_in_file = 0;
-+ st_parm->cnt_history_in_file = 0;
- while ((line = xmalloc_fgetline(fp)) != NULL) {
- if (line[0] == '\0') {
- free(line);
-@@ -1361,8 +1360,7 @@ static void load_history(line_input_t *s
- }
- free(temp_h[idx]);
- temp_h[idx] = line;
-- if (!ENABLE_FEATURE_EDITING_SAVE_ON_EXIT)
-- st_parm->cnt_history_in_file++;
-+ st_parm->cnt_history_in_file++;
- idx++;
- if (idx == st_parm->max_history)
- idx = 0;
diff --git a/package/busybox/busybox-1.20.0/busybox-1.20.0-sed.patch b/package/busybox/busybox-1.20.0/busybox-1.20.0-sed.patch
deleted file mode 100644
index 70dc63f46..000000000
--- a/package/busybox/busybox-1.20.0/busybox-1.20.0-sed.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- busybox-1.20.0/editors/sed.c
-+++ busybox-1.20.0-sed/editors/sed.c
-@@ -743,7 +743,7 @@ static int do_subst_command(sed_cmd_t *s
- */
- if (!G.regmatch[0].rm_so && !G.regmatch[0].rm_eo && match_count) {
- pipe_putc(*line++);
-- continue;
-+ goto next;
- }
-
- match_count++;
-@@ -755,7 +755,7 @@ static int do_subst_command(sed_cmd_t *s
- ) {
- for (i = 0; i < G.regmatch[0].rm_eo; i++)
- pipe_putc(*line++);
-- continue;
-+ goto next;
- }
-
- /* print everything before the match */
-@@ -773,7 +773,7 @@ static int do_subst_command(sed_cmd_t *s
- /* if we're not doing this globally, get out now */
- if (sed_cmd->which_match != 0)
- break;
--
-+ next:
- if (*line == '\0')
- break;
-
diff --git a/package/ccache/ccache.mk b/package/ccache/ccache.mk
index f71376ee8..d7106eed1 100644
--- a/package/ccache/ccache.mk
+++ b/package/ccache/ccache.mk
@@ -25,22 +25,22 @@ HOST_CCACHE_CONF_ENV = \
# has zero dependency besides the C library.
HOST_CCACHE_CONF_OPT += ccache_cv_zlib_1_2_3=no
-# We directly hardcode configuration into the binary, as it is much
-# easier to handle than passing an environment variable. Our
-# configuration is:
-# - the cache location
-# - the fact that ccache shouldn't use the compiler binary mtime to
-# - detect a change in the compiler, because in the context of
-# - Buildroot, that completely defeats the purpose of ccache. Of
-# - course, that leaves the user responsible for purging its cache
-# - when the compiler changes.
-define HOST_CCACHE_FIX_CCACHE_DIR
- sed -i 's,getenv("CCACHE_DIR"),"$(CCACHE_CACHE_DIR)",' $(@D)/ccache.c
+# Patch host-ccache as follows:
+# - Use BUILDROOT_CACHE_DIR instead of CCACHE_DIR, because CCACHE_DIR
+# is already used by autotargets for the ccache package.
+# BUILDROOT_CACHE_DIR is exported by Makefile based on config option
+# BR2_CCACHE_DIR.
+# - ccache shouldn't use the compiler binary mtime to detect a change in
+# the compiler, because in the context of Buildroot, that completely
+# defeats the purpose of ccache. Of course, that leaves the user
+# responsible for purging its cache when the compiler changes.
+define HOST_CCACHE_PATCH_CONFIGURATION
+ sed -i 's,getenv("CCACHE_DIR"),getenv("BUILDROOT_CACHE_DIR"),' $(@D)/ccache.c
sed -i 's,getenv("CCACHE_COMPILERCHECK"),"none",' $(@D)/ccache.c
endef
HOST_CCACHE_POST_CONFIGURE_HOOKS += \
- HOST_CCACHE_FIX_CCACHE_DIR
+ HOST_CCACHE_PATCH_CONFIGURATION
$(eval $(call AUTOTARGETS))
$(eval $(call AUTOTARGETS,host))
diff --git a/package/cifs-utils/Config.in b/package/cifs-utils/Config.in
index 43319865f..b433850a1 100644
--- a/package/cifs-utils/Config.in
+++ b/package/cifs-utils/Config.in
@@ -1,5 +1,7 @@
config BR2_PACKAGE_CIFS_UTILS
bool "cifs-utils"
+ # uses fork()
+ depends on BR2_USE_MMU
help
The in-kernel CIFS filesystem is generally the preferred
method for mounting SMB/CIFS shares on Linux. The in-kernel
diff --git a/package/crosstool-ng/crosstool-ng.mk b/package/crosstool-ng/crosstool-ng.mk
index 3540f70a1..09c57ec2a 100644
--- a/package/crosstool-ng/crosstool-ng.mk
+++ b/package/crosstool-ng/crosstool-ng.mk
@@ -3,6 +3,6 @@ CROSSTOOL_NG_SOURCE = crosstool-ng-$(CROSSTOOL_NG_VERSION).tar.bz2
CROSSTOOL_NG_SITE = http://crosstool-ng.org/download/crosstool-ng/
CROSSTOOL_NG_INSTALL_TARGET = NO
CROSSTOOL_NG_MAKE = $(MAKE1)
-HOST_CROSSTOOL_NG_DEPENDENCIES = $(if $(BR2_CCACHE),host-ccache) host-gawk host-automake
+HOST_CROSSTOOL_NG_DEPENDENCIES = $(if $(BR2_CCACHE),host-ccache) host-gawk host-automake host-gperf
$(eval $(call AUTOTARGETS,host))
diff --git a/package/directfb/Config.in b/package/directfb/Config.in
index 26f5091a2..47f9feaaf 100644
--- a/package/directfb/Config.in
+++ b/package/directfb/Config.in
@@ -53,10 +53,6 @@ config BR2_PACKAGE_DIRECTFB_EP9X
bool "compile ep9x graphics driver"
depends on BR2_arm
-config BR2_PACKAGE_DIRECTFB_DAVINCI
- bool "compile TI DaVinci graphics driver"
- depends on BR2_arm
-
config BR2_PACKAGE_DIRECTFB_UNICHROME
bool "compile unichrome graphics driver"
default y
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 7aa03987a..071cdf4fc 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -58,8 +58,7 @@ DIRECTFB_GFX := \
$(if $(BR2_PACKAGE_DIRECTFB_PXA3XX),pxa3xx) \
$(if $(BR2_PACKAGE_DIRECTFB_UNICHROME),unichrome) \
$(if $(BR2_PACKAGE_DIRECTFB_I830),i830) \
- $(if $(BR2_PACKAGE_DIRECTFB_EP9X),ep9x) \
- $(if $(BR2_PACKAGE_DIRECTFB_DAVINCI),davinci)
+ $(if $(BR2_PACKAGE_DIRECTFB_EP9X),ep9x)
ifeq ($(strip $(DIRECTFB_GFX)),)
DIRECTFB_GFX:=none
diff --git a/package/dnsmasq/dnsmasq.mk b/package/dnsmasq/dnsmasq.mk
index 2e3575ccb..4aa7cfbd6 100644
--- a/package/dnsmasq/dnsmasq.mk
+++ b/package/dnsmasq/dnsmasq.mk
@@ -42,11 +42,9 @@ endef
endif
ifeq ($(BR2_PACKAGE_DNSMASQ_LUA),y)
- DNSMASQ_DEPENDENCIES += lua
+ DNSMASQ_DEPENDENCIES += lua host-pkg-config
DNSMASQ_MAKE_OPT += LDFLAGS+="-ldl"
-endif
-ifeq ($(BR2_PACKAGE_DNSMASQ_LUA),y)
define DNSMASQ_ENABLE_LUA
$(SED) 's/lua5.1/lua/g' $(DNSMASQ_DIR)/Makefile
$(SED) 's^.*#define HAVE_LUASCRIPT.*^#define HAVE_LUASCRIPT^' \
diff --git a/package/games/gnuchess/Config.in b/package/games/gnuchess/Config.in
index cae05cbbb..c79c52dd4 100644
--- a/package/games/gnuchess/Config.in
+++ b/package/games/gnuchess/Config.in
@@ -1,6 +1,10 @@
config BR2_PACKAGE_GNUCHESS
bool "gnuchess"
+ depends on BR2_TOOLCHAIN_HAS_THREADS
help
GNU Chess lets most modern computers play a full game of chess.
http://ftp.gnu.org/pub/gnu/chess
+
+comment "gnuchess requires a toolchain with thread support"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/gpsd/gpsd-2.95-navcom.patch b/package/gpsd/gpsd-navcom.patch
index 659cea1d8..659cea1d8 100644
--- a/package/gpsd/gpsd-2.95-navcom.patch
+++ b/package/gpsd/gpsd-navcom.patch
diff --git a/package/heirloom-mailx/heirloom-mailx.mk b/package/heirloom-mailx/heirloom-mailx.mk
index 2b28a3fc4..b1779c0bb 100644
--- a/package/heirloom-mailx/heirloom-mailx.mk
+++ b/package/heirloom-mailx/heirloom-mailx.mk
@@ -12,6 +12,10 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
HEIRLOOM_MAILX_DEPENDENCIES += openssl
endif
+define HEIRLOOM_MAILX_CONFIGURE_CMDS
+ (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(SHELL) ./makeconfig)
+endef
+
define HEIRLOOM_MAILX_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
diff --git a/package/iperf/Config.in b/package/iperf/Config.in
index c4c25b359..c284bfd1b 100644
--- a/package/iperf/Config.in
+++ b/package/iperf/Config.in
@@ -1,6 +1,8 @@
config BR2_PACKAGE_IPERF
bool "iperf"
depends on BR2_INSTALL_LIBSTDCPP
+ # uses fork()
+ depends on BR2_USE_MMU
help
Internet Protocol bandwidth measuring tool for measuring
TCP/UDP performance.
diff --git a/package/multimedia/libmpeg2/libmpeg2-0.5.1-armv4l.patch b/package/libmpeg2/libmpeg2-0.5.1-armv4l.patch
index 70d45ef91..70d45ef91 100644
--- a/package/multimedia/libmpeg2/libmpeg2-0.5.1-armv4l.patch
+++ b/package/libmpeg2/libmpeg2-0.5.1-armv4l.patch
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index 3bcefa5c9..d7947b1cd 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -68,12 +68,17 @@ MTD_TARGETS_UBI_$(BR2_PACKAGE_MTD_UBIUPDATEVOL) += ubiupdatevol
MTD_TARGETS_y += $(addprefix ubi-utils/,$(MTD_TARGETS_UBI_y))
+# only call make if atleast a single tool is enabled
+ifneq ($(MTD_TARGETS_y),)
+
define MTD_BUILD_CMDS
$(MAKE1) $(TARGET_CONFIGURE_OPTS) CROSS=$(TARGET_CROSS) \
BUILDDIR=$(@D) WITHOUT_XATTR=1 WITHOUT_LARGEFILE=1 -C $(@D) \
$(addprefix $(@D)/,$(MTD_TARGETS_y))
endef
+endif
+
define MTD_INSTALL_TARGET_CMDS
for f in $(MTD_TARGETS_y) ; do \
install -D -m 0755 $(@D)/$$f $(TARGET_DIR)/usr/sbin/$${f##*/} ; \
diff --git a/package/ndisc6/ndisc6.mk b/package/ndisc6/ndisc6.mk
index 8451e06a4..7cf4b8aeb 100644
--- a/package/ndisc6/ndisc6.mk
+++ b/package/ndisc6/ndisc6.mk
@@ -10,6 +10,11 @@ NDISC6_SITE = http://www.remlab.net/files/ndisc6/
NDISC6_CONF_ENV = CC="$(TARGET_CC) -std=gnu99"
NDISC6_CONF_OPT = --localstatedir=/var --disable-rpath --disable-suid-install
+ifeq ($(BR2_PACKAGE_LIBINTL),y)
+NDISC6_DEPENDENCIES += libintl
+NDISC6_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -lintl"
+endif
+
NDISC6_BIN_ += dnssort # perl script
NDISC6_BIN_$(BR2_PACKAGE_NDISC6_NAME2ADDR) += name2addr addr2name
NDISC6_BIN_$(BR2_PACKAGE_NDISC6_TCPSPRAY) += tcpspray tcpspray6
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index 448e3fdb0..6d67dc5cd 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -21,6 +21,7 @@ NETSNMP_CONF_OPT = --with-persistent-directory=/var/lib/snmp --disable-static \
--with-mib-modules="host ucd-snmp/dlmod" \
--with-out-mib-modules="disman/event disman/schedule utilities" \
--with-out-transports="Unix"
+NETSNMP_MAKE = $(MAKE1)
NETSNMP_BLOAT_MIBS = BRIDGE DISMAN-EVENT DISMAN-SCHEDULE DISMAN-SCRIPT EtherLike RFC-1215 RFC1155-SMI RFC1213 SCTP SMUX
ifeq ($(BR2_ENDIAN),"BIG")
diff --git a/package/ntfs-3g/ntfs-3g.mk b/package/ntfs-3g/ntfs-3g.mk
index 8e616cb79..748fe1de0 100644
--- a/package/ntfs-3g/ntfs-3g.mk
+++ b/package/ntfs-3g/ntfs-3g.mk
@@ -21,6 +21,7 @@ ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
endif
ifeq ($(BR2_PACKAGE_NTFS_3G_ENCRYPTED),y)
+ NTFS_3G_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
NTFS_3G_CONF_OPT += --enable-crypto
NTFS_3G_DEPENDENCIES += gnutls
endif
diff --git a/package/opencv/opencv.mk b/package/opencv/opencv.mk
index d415e5192..ec9471518 100644
--- a/package/opencv/opencv.mk
+++ b/package/opencv/opencv.mk
@@ -35,6 +35,8 @@ OPENCV_CONF_OPT = \
-DWITH_UNICAP=OFF \
-DWITH_XINE=OFF
+OPENCV_DEPENDENCIES += zlib
+
ifeq ($(BR2_PACKAGE_OPENCV_WITH_PYTHON),y)
OPENCV_CONF_OPT += -DBUILD_NEW_PYTHON_SUPPORT=ON
OPENCV_DEPENDENCIES += python
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 748252ce2..62861c5ee 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -4,7 +4,7 @@
#
#############################################################
-OPENSSL_VERSION = 1.0.0i
+OPENSSL_VERSION = 1.0.0j
OPENSSL_SITE = http://www.openssl.org/source
OPENSSL_INSTALL_STAGING = YES
OPENSSL_DEPENDENCIES = zlib
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index 5da794bad..fc2192843 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -30,7 +30,10 @@ OPROFILE_DEPENDENCIES = popt binutils
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile
- cp -dpfr $(@D)/events/$(OPROFILE_ARCH) $(TARGET_DIR)/usr/share/oprofile
+ if [ -d $(@D)/events/$(OPROFILE_ARCH) ]; then \
+ cp -dpfr $(@D)/events/$(OPROFILE_ARCH) \
+ $(TARGET_DIR)/usr/share/oprofile; \
+ fi
$(INSTALL) -m 644 $(@D)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
$(INSTALL) -m 755 $(@D)/utils/opcontrol $(TARGET_DIR)/usr/bin
$(INSTALL) -m 755 $(addprefix $(@D)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index b833de9e0..7d1e54375 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -206,7 +206,7 @@ endef
define DOWNLOAD_INNER
$(Q)if test -n "$(call qstrip,$(BR2_PRIMARY_SITE))" ; then \
case "$(call geturischeme,$(BR2_PRIMARY_SITE))" in \
- scp) $(call $(DL_MODE)_SCP,$(BR2_PRIMARY_SITE),$(2)) && exit ;; \
+ scp) $(call $(DL_MODE)_SCP,$(BR2_PRIMARY_SITE)/$(2),$(2)) && exit ;; \
*) $(call $(DL_MODE)_WGET,$(BR2_PRIMARY_SITE)/$(2),$(2)) && exit ;; \
esac ; \
fi ; \
diff --git a/package/pptp-linux/pptp-linux.mk b/package/pptp-linux/pptp-linux.mk
index 77ae34d8d..d4c5bc4ee 100644
--- a/package/pptp-linux/pptp-linux.mk
+++ b/package/pptp-linux/pptp-linux.mk
@@ -7,6 +7,7 @@
PPTP_LINUX_VERSION = 1.7.2
PPTP_LINUX_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/pptpclient
PPTP_LINUX_SOURCE = pptp-$(PPTP_LINUX_VERSION).tar.gz
+PPTP_LINUX_MAKE = $(MAKE1)
define PPTP_LINUX_BUILD_CMDS
$(MAKE) -C $(@D) OPTIMIZE= DEBUG= \
diff --git a/package/socat/socat-no-documentation.patch b/package/socat/socat-no-documentation.patch
new file mode 100644
index 000000000..ce088dfaf
--- /dev/null
+++ b/package/socat/socat-no-documentation.patch
@@ -0,0 +1,37 @@
+socat: disable documentation build/installation
+
+The documentation generation process requires a special yold2man
+program, for which we don't have a package in Buildroot. Since we
+generally don't care much about documentation of packages, just adjust
+the package Makefile.in to not build/install its documentation.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -93,7 +93,7 @@
+ Config/Makefile.Cygwin-1-5-25 Config/config.Cygwin-1-5-25.h \
+ Config/Makefile.MacOSX-10-5 Config/config.MacOSX-10-5.h
+
+-all: progs doc
++all: progs
+
+ scmclean: gitclean
+
+@@ -136,13 +136,11 @@
+ strip: progs
+ strip $(PROGS)
+
+-install: progs $(srcdir)/doc/socat.1
++install: progs
+ mkdir -p $(DESTDIR)$(BINDEST)
+ $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)
+ $(INSTALL) -m 755 procan $(DESTDIR)$(BINDEST)
+ $(INSTALL) -m 755 filan $(DESTDIR)$(BINDEST)
+- mkdir -p $(DESTDIR)$(MANDEST)/man1
+- $(INSTALL) -m 644 $(srcdir)/doc/socat.1 $(DESTDIR)$(MANDEST)/man1/
+
+ uninstall:
+ rm -f $(DESTDIR)$(BINDEST)/socat
diff --git a/package/socat/socat.mk b/package/socat/socat.mk
index 5f7feacc2..bd435cf08 100644
--- a/package/socat/socat.mk
+++ b/package/socat/socat.mk
@@ -4,7 +4,7 @@
#
#############################################################
-SOCAT_VERSION = 2.0.0-b4
+SOCAT_VERSION = 2.0.0-b5
SOCAT_SOURCE = socat-$(SOCAT_VERSION).tar.bz2
SOCAT_SITE = http://www.dest-unreach.org/socat/download/
SOCAT_CONF_ENV = sc_cv_termios_ispeed=no \
@@ -12,4 +12,17 @@ SOCAT_CONF_ENV = sc_cv_termios_ispeed=no \
sc_cv_sys_tabdly_shift=11 \
sc_cv_sys_csize_shift=4
+# We need to run autoconf to regenerate the configure script, in order
+# to ensure that the test checking linux/ext2_fs.h works
+# properly. However, the package only uses autoconf and not automake,
+# so we can't use the normal autoreconf logic.
+
+SOCAT_DEPENDENCIES = host-autoconf
+
+define SOCAT_RUN_AUTOCONF
+ (cd $(@D); $(HOST_DIR)/usr/bin/autoconf)
+endef
+
+SOCAT_PRE_CONFIGURE_HOOKS += SOCAT_RUN_AUTOCONF
+
$(eval $(call AUTOTARGETS))
diff --git a/package/vala/vala-0.15.2-dont-add-dirty-to-valac-version.patch b/package/vala/vala-0.15.2-dont-add-dirty-to-valac-version.patch
new file mode 100644
index 000000000..a2a062336
--- /dev/null
+++ b/package/vala/vala-0.15.2-dont-add-dirty-to-valac-version.patch
@@ -0,0 +1,25 @@
+valac: don't append -dirty to version
+
+Don't append -dirty to the valac version number if the Buildroot Git
+tree has uncommited changes.
+
+The patched script is meant for the valac developers, but it also
+activates if you build valac in a subdirectory of a Git tree (e.g.
+as is commonly done in Buildroot).
+
+The effect is that valac gets built as being version x.y.z-dirty, which
+breaks programs (such as Midori) that explicitly check for valac-x.y.z.
+
+Signed-off-by: Simon Dawson <spdawson@gmail.com>
+diff -Nur a/build-aux/git-version-gen b/build-aux/git-version-gen
+--- a/build-aux/git-version-gen 2010-08-15 12:49:03.000000000 +0100
++++ b/build-aux/git-version-gen 2012-05-14 10:17:19.977204570 +0100
+@@ -135,7 +135,7 @@
+ *) # Append the suffix only if there isn't one already.
+ case $v in
+ *-dirty) ;;
+- *) v="$v-dirty" ;;
++ #*) v="$v-dirty" ;;
+ esac ;;
+ esac
+
diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
index df7ba9a9f..29f7c8167 100644
--- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
@@ -58,6 +58,7 @@ XSERVER_XORG_SERVER_DEPENDENCIES = \
XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \
--disable-xnest --disable-xephyr --disable-xvfb \
+ --disable-dmx \
--with-builder-addr=buildroot@uclibc.org \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/pixman-1" \
--with-fontdir=/usr/share/fonts/X11/ --localstatedir=/var