aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/avahi/avahi.mk2
-rw-r--r--package/busybox/S10mdev20
-rw-r--r--package/busybox/busybox.mk15
-rw-r--r--package/dropbear/dropbear-0.53.1-static_build_fix.patch26
-rw-r--r--package/dropbear/dropbear.mk9
-rw-r--r--package/haserl/Config.in2
-rw-r--r--package/makedevs/README35
-rw-r--r--package/multimedia/ffmpeg/Config.in1
-rw-r--r--package/multimedia/ffmpeg/ffmpeg.mk11
-rw-r--r--package/qt/Config.in2
-rwxr-xr-xpackage/udev/S10udev34
11 files changed, 114 insertions, 43 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 4dfa3547a..fdf039086 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -64,7 +64,7 @@ AVAHI_CONF_ENV = ac_cv_func_strtod=yes \
jm_cv_func_working_re_compile_pattern=yes \
ac_use_included_regex=no \
avahi_cv_sys_cxx_works=yes \
- DATADIR=share
+ DATADIRNAME=share
AVAHI_CONF_OPT = --localstatedir=/var \
--disable-qt3 \
diff --git a/package/busybox/S10mdev b/package/busybox/S10mdev
new file mode 100644
index 000000000..d2643d023
--- /dev/null
+++ b/package/busybox/S10mdev
@@ -0,0 +1,20 @@
+#!/bin/sh
+#
+# Start mdev....
+#
+
+case "$1" in
+ start)
+ echo "Starting mdev..."
+ /sbin/mdev -s
+ ;;
+ stop)
+ ;;
+ restart|reload)
+ ;;
+ *)
+ echo $"Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit $?
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index ffd66679e..711d11b0f 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -28,6 +28,19 @@ ifndef BUSYBOX_CONFIG_FILE
BUSYBOX_CONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG))
endif
+# If mdev will be used for device creation enable it and copy S10mdev to /etc/init.d
+ifeq ($(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),y)
+define BUSYBOX_INSTALL_MDEV_SCRIPT
+ install -m 0755 package/busybox/S10mdev $(TARGET_DIR)/etc/init.d
+endef
+define BUSYBOX_SET_MDEV
+ $(call KCONFIG_ENABLE_OPT,CONFIG_MDEV,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_MDEV_CONF,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_MDEV_EXEC,$(BUSYBOX_BUILD_CONFIG))
+ $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_MDEV_LOAD_FIRMWARE,$(BUSYBOX_BUILD_CONFIG))
+endef
+endif
+
# If we have external syslogd, force busybox to use it
ifeq ($(BR2_PACKAGE_SYSKLOGD),y)
define BUSYBOX_SET_SYSKLOGD
@@ -122,6 +135,7 @@ define BUSYBOX_CONFIGURE_CMDS
$(BUSYBOX_SET_IPV6)
$(BUSYBOX_SET_RPC)
$(BUSYBOX_PREFER_STATIC)
+ $(BUSYBOX_SET_MDEV)
$(BUSYBOX_NETKITBASE)
$(BUSYBOX_NETKITTELNET)
@yes "" | $(MAKE) ARCH=$(KERNEL_ARCH) CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -138,6 +152,7 @@ define BUSYBOX_INSTALL_TARGET_CMDS
$(INSTALL) -m 0755 -D package/busybox/udhcpc.script \
$(TARGET_DIR)/usr/share/udhcpc/default.script; \
fi
+ $(BUSYBOX_INSTALL_MDEV_SCRIPT)
endef
define BUSYBOX_UNINSTALL_TARGET_CMDS
diff --git a/package/dropbear/dropbear-0.53.1-static_build_fix.patch b/package/dropbear/dropbear-0.53.1-static_build_fix.patch
new file mode 100644
index 000000000..0e0a91a27
--- /dev/null
+++ b/package/dropbear/dropbear-0.53.1-static_build_fix.patch
@@ -0,0 +1,26 @@
+dropbear: fix static build
+
+the -lcrypt is missing during the link
+
+svr-authpasswd.o: In function `svr_auth_password':
+svr-authpasswd.c:(.text+0xfc): undefined reference to `crypt'
+collect2: ld returned 1 exit status
+
+Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -77,7 +77,7 @@ STRIP=@STRIP@
+ INSTALL=@INSTALL@
+ CPPFLAGS=@CPPFLAGS@
+ CFLAGS+=-I. -I$(srcdir) $(CPPFLAGS) @CFLAGS@
+-LIBS+=@LIBS@
++LIBS+=@CRYPTLIB@ @LIBS@
+ LDFLAGS=@LDFLAGS@
+
+ EXEEXT=@EXEEXT@
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index fab7c9678..d73e99346 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -9,14 +9,13 @@ DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.gz
DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
DROPBEAR_DEPENDENCIES = zlib
DROPBEAR_TARGET_BINS = dbclient dropbearkey dropbearconvert scp ssh
-# configure misdetects this as no, but the result is not used for
-# anything. Unfortunately it breaks the build for other packages also
-# checking for struct sockaddr_storage when using a shared config
-# cache, so force it to yes
-DROPBEAR_CONF_ENV = ac_cv_type_struct_sockaddr_storage=yes
DROPBEAR_MAKE = $(MAKE) MULTI=1 SCPPROGRESS=1 \
PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp"
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+DROPBEAR_MAKE += STATIC=1
+endif
+
define DROPBEAR_FIX_XAUTH
$(SED) 's,^#define XAUTH_COMMAND.*/xauth,#define XAUTH_COMMAND "/usr/bin/xauth,g' $(@D)/options.h
endef
diff --git a/package/haserl/Config.in b/package/haserl/Config.in
index ad9a8e91e..7710fa1c3 100644
--- a/package/haserl/Config.in
+++ b/package/haserl/Config.in
@@ -38,4 +38,4 @@ endchoice
config BR2_PACKAGE_HASERL_VERSION
string
default "0.8.0" if BR2_PACKAGE_HASERL_VERSION_0_8_X
- default "0.9.28" if BR2_PACKAGE_HASERL_VERSION_0_9_X
+ default "0.9.29" if BR2_PACKAGE_HASERL_VERSION_0_9_X
diff --git a/package/makedevs/README b/package/makedevs/README
new file mode 100644
index 000000000..6c54052ee
--- /dev/null
+++ b/package/makedevs/README
@@ -0,0 +1,35 @@
+When building a target filesystem, it is desirable to not have to
+become root and then run 'mknod' a thousand times. Using a device
+table you can create device nodes and directories "on the fly".
+
+You can do all sorts of interesting things with a device table file.
+For example, if you want to adjust the permissions on a particular
+file you can just add an entry like:
+
+ /sbin/foobar f 2755 0 0 - - - - -
+
+and (assuming the file /sbin/foobar exists) it will be made setuid
+root (regardless of what its permissions are on the host filesystem.
+
+Furthermore, you can use a single table entry to create a many device
+minors. For example, if I wanted to create /dev/hda and
+/dev/hda[0-15] I could just use the following two table entries:
+
+ /dev/hda b 640 0 0 3 0 0 0 -
+ /dev/hda b 640 0 0 3 1 1 1 15
+
+Device table entries take the form of:
+
+<name> <type> <mode> <uid> <gid> <major> <minor> <start> <inc> <count>
+
+where name is the file name, type can be one of:
+
+ f A regular file
+ d Directory
+ c Character special device file
+ b Block special device file
+ p Fifo (named pipe)
+
+uid is the user id for the target file, gid is the group id for the
+target file. The rest of the entries (major, minor, etc) apply only
+to device special files.
diff --git a/package/multimedia/ffmpeg/Config.in b/package/multimedia/ffmpeg/Config.in
index 7a9513c09..d11233e94 100644
--- a/package/multimedia/ffmpeg/Config.in
+++ b/package/multimedia/ffmpeg/Config.in
@@ -27,6 +27,7 @@ config BR2_PACKAGE_FFMPEG_NONFREE
config BR2_PACKAGE_FFMPEG_FFMPEG
bool "Build ffmpeg (the command line application)"
+ select BR2_PACKAGE_FFMPEG_SWSCALE
default y
help
FFmpeg is a very fast video and audio converter.
diff --git a/package/multimedia/ffmpeg/ffmpeg.mk b/package/multimedia/ffmpeg/ffmpeg.mk
index 1e8f09a30..172bfc0f3 100644
--- a/package/multimedia/ffmpeg/ffmpeg.mk
+++ b/package/multimedia/ffmpeg/ffmpeg.mk
@@ -4,7 +4,7 @@
#
#############################################################
-FFMPEG_VERSION = 0.6.1
+FFMPEG_VERSION = 0.6.3
FFMPEG_SOURCE = ffmpeg-$(FFMPEG_VERSION).tar.bz2
FFMPEG_SITE = http://ffmpeg.org/releases
FFMPEG_INSTALL_STAGING = YES
@@ -13,6 +13,7 @@ FFMPEG_CONF_OPT = \
--prefix=/usr \
--enable-shared \
--disable-avfilter \
+ $(if $(BR2_HAVE_DOCUMENTATION),,--disable-doc)
ifeq ($(BR2_PACKAGE_FFMPEG_GPL),y)
FFMPEG_CONF_OPT += --enable-gpl
@@ -142,6 +143,14 @@ endif
ifeq ($(BR2_cortex_a8),y)
FFMPEG_CONF_OPT += --enable-neon
endif
+# Set powerpc altivec appropriately
+ifeq ($(BR2_powerpc),y)
+ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+FFMPEG_CONF_OPT -= --enable-altivec
+else
+FFMPEG_CONF_OPT += --disable-altivec
+endif
+endif
FFMPEG_CONF_OPT += $(call qstrip,$(BR2_PACKAGE_FFMPEG_EXTRACONF))
diff --git a/package/qt/Config.in b/package/qt/Config.in
index b223772cf..eafc855a4 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -23,12 +23,12 @@ config BR2_PACKAGE_QT_DEMOS
choice
prompt "Library type"
- default BR2_PACKAGE_QT_SHARED
help
Selects the library type: Shared or Static
config BR2_PACKAGE_QT_SHARED
bool "Shared library"
+ depends on !BR2_PREFER_STATIC_LIB
help
Create and use shared Qt libraries.
If you have multiple programs that depend on Qt or intend to use
diff --git a/package/udev/S10udev b/package/udev/S10udev
index 6418f63cb..0d2a23afa 100755
--- a/package/udev/S10udev
+++ b/package/udev/S10udev
@@ -16,12 +16,6 @@
# /dev/zero, /dev/null -- that's needed to boot and run this script.
#
-# old kernels don't use udev
-case $(uname -r) in
- 2.6*|2.7*) ;;
- *) exit 0;;
-esac
-
# Check for missing binaries
UDEV_BIN=/sbin/udevd
test -x $UDEV_BIN || exit 5
@@ -33,41 +27,13 @@ UDEV_CONFIG=/etc/udev/udev.conf
test -r $UDEV_CONFIG || exit 6
. $UDEV_CONFIG
-# Directory where sysfs is mounted
-SYSFS_DIR=/sys
-
case "$1" in
start)
- # mount sysfs if it's not yet mounted
- if [ ! -d $SYSFS_DIR ]; then
- echo "${0}: SYSFS_DIR \"$SYSFS_DIR\" not found"
- exit 1
- fi
- grep -q "^sysfs $SYSFS_DIR" /proc/mounts ||
- mount -t sysfs /sys /sys ||
- exit 1
-
- # mount $udev_root as ramfs if it's not yet mounted
- # we know 2.6 kernels always support ramfs
- if [ ! -d $udev_root ]; then
- echo "${0}: udev_root \"$udev_root\" not found"
- exit 1
- fi
- grep -q "^udev $udev_root" /proc/mounts ||
- mount -t ramfs udev $udev_root ||
- exit 1
-
- mkdir $udev_root/pts $udev_root/shm
mknod -m 0666 /dev/null c 1 3
- mknod -m 0666 /dev/zero c 1 5
- mknod -m 0600 /dev/console c 5 1
-
- # populate /dev (normally)
echo -n "Populating $udev_root using udev: "
echo -e '\000\000\000\000' > /proc/sys/kernel/hotplug
$UDEV_BIN -d || (echo "FAIL" && exit 1)
$UDEVSTART_BIN || (echo "FAIL" && exit 1)
- mount -t devpts /dev/pts /dev/pts || (echo "FAIL" && exit 1)
echo "done"
;;
stop)