summaryrefslogtreecommitdiffstats
path: root/package/uboot-mkimage
diff options
context:
space:
mode:
Diffstat (limited to 'package/uboot-mkimage')
-rw-r--r--package/uboot-mkimage/Config.in7
-rw-r--r--package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch27
-rw-r--r--package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch29
-rw-r--r--package/uboot-mkimage/uboot-mkimage.mk31
4 files changed, 0 insertions, 94 deletions
diff --git a/package/uboot-mkimage/Config.in b/package/uboot-mkimage/Config.in
deleted file mode 100644
index e1dec5379..000000000
--- a/package/uboot-mkimage/Config.in
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_UBOOT_MKIMAGE
- bool "uboot-mkimage"
- help
- The mkimage tool from Das U-Boot bootloader, which allows
- generation of U-Boot images in various formats.
-
- http://www.denx.de/wiki/U-Boot/WebHome
diff --git a/package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch b/package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch
deleted file mode 100644
index bf524c9a3..000000000
--- a/package/uboot-mkimage/uboot-mkimage-2011.03-drop-configh.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-"make tools-all" should allow building tools such as mkimage and the new
-imximage without any config, but imximage.c currently fails to build
-with:
-imximage.h:27:20: error: config.h: No such file or directory
-
-config.h is not needed in imximage.h nor in imximage.c, and imximage.h
-is only included from imximage.c, so drop this include to fix the build.
-
-Signed-off-by: Lo?c Minier <loic.minier@linaro.org>
----
- tools/imximage.h | 2 --
- 1 files changed, 0 insertions(+), 2 deletions(-)
-
-diff --git a/tools/imximage.h b/tools/imximage.h
-index 38ca6be..d126a46 100644
---- a/tools/imximage.h
-+++ b/tools/imximage.h
-@@ -24,8 +24,6 @@
- #ifndef _IMXIMAGE_H_
- #define _IMXIMAGE_H_
-
--#include <config.h>
--
- #define MAX_HW_CFG_SIZE_V2 121 /* Max number of registers imx can set for v2 */
- #define MAX_HW_CFG_SIZE_V1 60 /* Max number of registers imx can set for v1 */
- #define APP_CODE_BARKER 0xB1
--- 1.7.2.3
diff --git a/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch b/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch
deleted file mode 100644
index 0202eda9b..000000000
--- a/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-[PATCH] Fix tools build with custom HOSTCFLAGS
-
-We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
-overridden on the cmdline.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- config.mk | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-Index: u-boot-2011.03/config.mk
-===================================================================
---- u-boot-2011.03.orig/config.mk
-+++ u-boot-2011.03/config.mk
-@@ -46,10 +46,12 @@
-
- #########################################################################
-
--HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
-- $(HOSTCPPFLAGS)
-+HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
- HOSTSTRIP = strip
-
-+# append CPPFLAGS even if CFLAGS has been overridden on cmdline
-+override HOSTCFLAGS += $(HOSTCPPFLAGS)
-+
- #
- # Mac OS X / Darwin's C preprocessor is Apple specific. It
- # generates numerous errors and warnings. We want to bypass it
diff --git a/package/uboot-mkimage/uboot-mkimage.mk b/package/uboot-mkimage/uboot-mkimage.mk
deleted file mode 100644
index d8a8fbbe9..000000000
--- a/package/uboot-mkimage/uboot-mkimage.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-UBOOT_MKIMAGE_VERSION = 2011.03
-UBOOT_MKIMAGE_SOURCE = u-boot-$(UBOOT_MKIMAGE_VERSION).tar.bz2
-UBOOT_MKIMAGE_SITE = ftp://ftp.denx.de/pub/u-boot
-
-define UBOOT_MKIMAGE_BUILD_CMDS
- $(MAKE) -C $(@D) \
- HOSTCC="$(TARGET_CC)" \
- HOSTCFLAGS="$(TARGET_CFLAGS)" \
- HOSTLDFLAGS="$(TARGET_LDFLAGS)" \
- HOSTSTRIP=true \
- tools
-endef
-
-define UBOOT_MKIMAGE_INSTALL_CMDS
- install -m 0755 -D $(@D)/tools/mkimage $(TARGET_DIR)/usr/bin
-endef
-
-define HOST_UBOOT_MKIMAGE_BUILD_CMDS
- $(MAKE) -C $(@D) \
- HOSTCC="$(HOSTCC)" \
- HOSTCFLAGS="$(HOST_CFLAGS)" \
- HOSTLDFLAGS="$(HOST_LDFLAGS)" \
- tools
-endef
-
-define HOST_UBOOT_MKIMAGE_INSTALL_CMDS
- install -m 0755 -D $(@D)/tools/mkimage $(HOST_DIR)/usr/bin
-endef
-
-$(eval $(call GENTARGETS,package,uboot-mkimage))
-$(eval $(call GENTARGETS,package,uboot-mkimage,host))