summaryrefslogtreecommitdiffstats
path: root/package/tcllib
diff options
context:
space:
mode:
Diffstat (limited to 'package/tcllib')
-rw-r--r--package/tcllib/Config.in11
-rw-r--r--package/tcllib/tcllib.mk14
2 files changed, 25 insertions, 0 deletions
diff --git a/package/tcllib/Config.in b/package/tcllib/Config.in
new file mode 100644
index 000000000..b0a4ad060
--- /dev/null
+++ b/package/tcllib/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_TCLLIB
+ bool "tcllib"
+ help
+ Tcllib is a collection of utility modules for Tcl. These
+ modules provide a wide variety of functionality, from
+ implementations of standard data structures to
+ implementations of common networking protocols. The intent
+ is to collect commonly used function into a single library,
+ which users can rely on to be available and stable
+
+ http://tcl.activestate.com/software/tcllib/
diff --git a/package/tcllib/tcllib.mk b/package/tcllib/tcllib.mk
new file mode 100644
index 000000000..09d617f44
--- /dev/null
+++ b/package/tcllib/tcllib.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# tcllib
+#
+#############################################################
+TCLLIB_VERSION = 1.13
+TCLLIB_SOURCE = tcllib-$(TCLLIB_VERSION).tar.bz2
+TCLLIB_SITE = http://downloads.sourceforge.net/project/tcllib/tcllib/$(TCLLIB_VERSION)
+TCLLIB_LICENSE = tcl license
+TCLLIB_LICENSE_FILES = license.terms
+TCLLIB_DEPENDENCIES = host-tcl
+TCLLIB_CONF_ENV = ac_cv_path_tclsh="$(HOST_DIR)/usr/bin/tclsh8.4"
+
+$(eval $(autotools-package))