aboutsummaryrefslogtreecommitdiffstats
path: root/package/spice/spice.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/spice/spice.mk')
-rw-r--r--package/spice/spice.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/spice/spice.mk b/package/spice/spice.mk
index 2752b8af7..2f7fc20d1 100644
--- a/package/spice/spice.mk
+++ b/package/spice/spice.mk
@@ -26,12 +26,18 @@ SPICE_CONF_OPT = \
--disable-gui \
--disable-opengl \
--disable-smartcard \
- --disable-client \
--disable-automated-tests \
--without-sasl \
SPICE_DEPENDENCIES += host-pkgconf
+ifeq ($(BR2_PACKAGE_SPICE_CLIENT),y)
+SPICE_CONF_OPT += --enable-client
+SPICE_DEPENDENCIES += xlib_libXfixes xlib_libXrandr
+else
+SPICE_CONF_OPT += --disable-client
+endif
+
SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages