summaryrefslogtreecommitdiffstats
path: root/package/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/qt5base.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 33555aef3..736965d36 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -28,7 +28,6 @@ QT5BASE_CONFIGURE_OPTS += \
-no-nis \
-no-libudev \
-no-iconv \
- -no-openssl \
-no-fontconfig \
-no-gif \
-no-libpng \
@@ -82,6 +81,9 @@ else
QT5BASE_CONFIGURE_OPTS += -no-xcb
endif
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_OPENSSL),-openssl,-no-openssl)
+QT5BASE_DEPENDENCIES += $(if $(BR2_PACKAGE_OPENSSL),openssl)
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK) += Qt5Network