summaryrefslogtreecommitdiffstats
path: root/package/python/python-disable_modules_and_ssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/python/python-disable_modules_and_ssl.patch')
-rw-r--r--package/python/python-disable_modules_and_ssl.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/package/python/python-disable_modules_and_ssl.patch b/package/python/python-disable_modules_and_ssl.patch
deleted file mode 100644
index 073296c5f..000000000
--- a/package/python/python-disable_modules_and_ssl.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- python.old/setup.py 2003-11-01 19:23:48.495647848 +0000
-+++ python/setup.py 2003-11-01 19:24:16.044459792 +0000
-@@ -15,7 +15,14 @@
- from distutils.command.install_lib import install_lib
-
- # This global variable is used to hold the list of modules to be disabled.
--disabled_module_list = []
-+try:
-+ disabled_module_list = os.environ["PYTHON_DISABLE_MODULES"].split()
-+except KeyError:
-+ disabled_module_list = []
-+try:
-+ disable_ssl = os.environ["PYTHON_DISABLE_SSL"]
-+except KeyError:
-+ disable_ssl = 0
-
- def add_dir_to_list(dirlist, dir):
- """Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -240,6 +247,7 @@
- return sys.platform
-
- def detect_modules(self):
-+ global disable_ssl
- # Ensure that /usr/local is always used
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-@@ -451,7 +459,8 @@
- ] )
-
- if (ssl_incs is not None and
-- ssl_libs is not None):
-+ ssl_libs is not None and
-+ not disable_ssl):
- exts.append( Extension('_ssl', ['_ssl.c'],
- include_dirs = ssl_incs,
- library_dirs = ssl_libs,