summaryrefslogtreecommitdiffstats
path: root/package/pppd/pppd.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pppd/pppd.mk')
-rw-r--r--package/pppd/pppd.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/pppd/pppd.mk b/package/pppd/pppd.mk
index 259d1dc6d..b13dbabab 100644
--- a/package/pppd/pppd.mk
+++ b/package/pppd/pppd.mk
@@ -23,6 +23,15 @@ ifeq ($(BR2_INET_IPV6),y)
PPPD_MAKE_OPT += HAVE_INET6=y
endif
+# pppd bundles some but not all of the needed kernel headers. The embedded
+# if_pppol2tp.h is unfortunately not compatible with kernel headers > 2.6.34,
+# and has been part of the kernel headers since 2.6.23, so drop it
+define PPPD_DROP_INTERNAL_IF_PPOL2TP_H
+ $(RM) $(@D)/include/linux/if_pppol2tp.h
+endef
+
+PPPD_POST_EXTRACT_HOOKS += PPPD_DROP_INTERNAL_IF_PPOL2TP_H
+
define PPPD_CONFIGURE_CMDS
$(SED) 's/FILTER=y/#FILTER=y/' $(PPPD_DIR)/pppd/Makefile.linux
$(SED) 's/ifneq ($$(wildcard \/usr\/include\/pcap-bpf.h),)/ifdef FILTER/' $(PPPD_DIR)/*/Makefile.linux