summaryrefslogtreecommitdiffstats
path: root/package/polkit
diff options
context:
space:
mode:
Diffstat (limited to 'package/polkit')
-rw-r--r--package/polkit/Config.in11
-rw-r--r--package/polkit/polkit.mk21
2 files changed, 32 insertions, 0 deletions
diff --git a/package/polkit/Config.in b/package/polkit/Config.in
new file mode 100644
index 000000000..da5f98562
--- /dev/null
+++ b/package/polkit/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_POLKIT
+ bool "polkit"
+ depends on BR2_USE_WCHAR # libglib2
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_EXPAT
+ help
+ PolicyKit is a toolkit for defining and handling
+ authorizations. It is used for allowing unprivileged
+ processes to speak to privileged processes.
+
+ http://www.freedesktop.org/wiki/Software/polkit
diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
new file mode 100644
index 000000000..3eb0422be
--- /dev/null
+++ b/package/polkit/polkit.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# polkit
+#
+#############################################################
+
+POLKIT_VERSION = 0.103
+POLKIT_SITE = http://www.freedesktop.org/software/polkit/releases/
+POLKIT_LICENSE = GPLv2
+POLKIT_LICENSE_FILES = COPYING
+
+POLKIT_INSTALL_STAGING = YES
+
+POLKIT_DEPENDENCIES = libglib2 host-intltool expat
+
+# We could also support --with-authfw=pam
+POLKIT_CONF_OPT = \
+ --with-authfw=shadow \
+ --with-os-type=unknown
+
+$(eval $(autotools-package))