aboutsummaryrefslogtreecommitdiffstats
path: root/package/perl
diff options
context:
space:
mode:
Diffstat (limited to 'package/perl')
-rw-r--r--package/perl/perl-configure-qemu.patch53
-rw-r--r--package/perl/perl-make-ext.patch24
-rw-r--r--package/perl/perl-mkppport.patch37
-rw-r--r--package/perl/perl.mk38
4 files changed, 18 insertions, 134 deletions
diff --git a/package/perl/perl-configure-qemu.patch b/package/perl/perl-configure-qemu.patch
deleted file mode 100644
index c2d6b9265..000000000
--- a/package/perl/perl-configure-qemu.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Add qemu support
-
-see https://rt.perl.org/rt3//Public/Bug/Display.html?id=114798
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/Configure
-===================================================================
---- a/Configure
-+++ b/Configure
-@@ -2837,6 +2837,9 @@
- ;;
- *) echo "Using usrinc $usrinc." >&4 ;;
- esac
-+ case "$targetrun" in
-+ *qemu*) targethost=dummy ;;
-+ esac
- case "$targethost" in
- '') echo "Targethost not defined." >&4; croak=y ;;
- *) echo "Using targethost $targethost." >&4
-@@ -2868,7 +2871,7 @@
- case "$targetfrom" in
- '') targetfrom=scp ;;
- esac
-- run=$run-$targetrun
-+ run=$run-`basename $targetrun`
- to=$to-$targetto
- from=$from-$targetfrom
- case "$targetdir" in
-@@ -2908,6 +2911,14 @@
- $targetrun -l $targetuser $targethost "cd \$cwd && ./\$exe \$@"
- EOF
- ;;
-+ *qemu*)
-+ to=:
-+ from=:
-+ cat >$run <<EOF
-+#!/bin/sh
-+$targetrun -L $qemulib "\$@"
-+EOF
-+ ;;
- *) echo "Unknown targetrun '$targetrun'" >&4
- exit 1
- ;;
-@@ -5048,7 +5059,7 @@
- echo " ";
- echo "Checking if your compiler accepts $flag" 2>&1;
- echo "int main(void) { return 0; }" > gcctest.c;
--if $cc -O2 $flag -o gcctest gcctest.c 2>gcctest.out && ./gcctest; then
-+if $cc -O2 $flag -o gcctest gcctest.c 2>gcctest.out && $run ./gcctest; then
- echo "Yes, it does." 2>&1;
- if $test -s gcctest.out ; then
- echo "But your platform does not like it:";
diff --git a/package/perl/perl-make-ext.patch b/package/perl/perl-make-ext.patch
deleted file mode 100644
index e0195e7a2..000000000
--- a/package/perl/perl-make-ext.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Don't use RUN with make (only for perl)
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/make_ext.pl
-===================================================================
---- a/make_ext.pl
-+++ b/make_ext.pl
-@@ -458,11 +458,13 @@
- # Give makefile an opportunity to rewrite itself.
- # reassure users that life goes on...
- my @args = ('config', @$pass_through);
-- system(@run, @make, @args) and print "@run @make @args failed, continuing anyway...\n";
-+# system(@run, @make, @args) and print "@run @make @args failed, continuing anyway...\n";
-+ system(@make, @args) and print "@make @args failed, continuing anyway...\n";
- }
- my @targ = ($target, @$pass_through);
- print "Making $target in $ext_dir\n@run @make @targ\n";
-- my $code = system(@run, @make, @targ);
-+# my $code = system(@run, @make, @targ);
-+ my $code = system(@make, @targ);
- die "Unsuccessful make($ext_dir): code=$code" if $code != 0;
-
- chdir $return_dir || die "Cannot cd to $return_dir: $!";
diff --git a/package/perl/perl-mkppport.patch b/package/perl/perl-mkppport.patch
deleted file mode 100644
index 97f27a202..000000000
--- a/package/perl/perl-mkppport.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Add RUN
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/mkppport
-===================================================================
---- a/mkppport
-+++ b/mkppport
-@@ -1,6 +1,7 @@
- use strict;
- use warnings;
-
-+use Config;
- use Getopt::Long;
- use File::Spec;
- use File::Compare qw( compare );
-@@ -136,14 +137,18 @@
- #----------------------------------------------
- sub run
- {
-+ my @run = $Config{run};
-+ @run = () if not defined $run[0] or $run[0] eq '';
- my @args = ("-I" . File::Spec->catdir((File::Spec->updir) x 2, 'lib'), @_);
- my $run = $perl =~ m/\s/ ? qq("$perl") : $perl;
- for (@args) {
- $_ = qq("$_") if $^O eq 'VMS' && /^[^"]/;
- $run .= " $_";
- }
-- print "running $run\n";
-- system $run and die "$run failed: $?\n";
-+# print "running $run\n";
-+# system $run and die "$run failed: $?\n";
-+ print "running ", join(' ', @run, $run), "\n";
-+ system join(' ', @run, $run) and die "@run $run failed: $?\n";
- }
-
- __END__
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index f3c73dd79..391047d38 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -13,8 +13,11 @@ PERL_LICENSE_FILES = Artistic
PERL_INSTALL_STAGING = YES
PERL_CROSS_VERSION = 0.7
+PERL_CROSS_BASE_VERSION = 5.$(PERL_VERSION_MAJOR).0
PERL_CROSS_SITE = http://download.berlios.de/perlcross
-PERL_CROSS_SOURCE = perl-5.$(PERL_VERSION_MAJOR).0-cross-$(PERL_CROSS_VERSION).tar.gz
+PERL_CROSS_SOURCE = perl-$(PERL_CROSS_BASE_VERSION)-cross-$(PERL_CROSS_VERSION).tar.gz
+PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_CROSS_BASE_VERSION))delta.pod
+PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
# We use the perlcross hack to cross-compile perl. It should
# be extracted over the perl sources, so we don't define that
@@ -32,6 +35,11 @@ define PERL_CROSS_EXTRACT
endef
PERL_POST_EXTRACT_HOOKS += PERL_CROSS_EXTRACT
+define PERL_CROSS_SET_POD
+ $(SED) s/$(PERL_CROSS_OLD_POD)/$(PERL_CROSS_NEW_POD)/g $(@D)/Makefile
+endef
+PERL_POST_PATCH_HOOKS += PERL_CROSS_SET_POD
+
ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
PERL_DEPENDENCIES += berkeleydb
endif
@@ -39,31 +47,22 @@ ifeq ($(BR2_PACKAGE_GDBM),y)
PERL_DEPENDENCIES += gdbm
endif
-# Normally, --mode=cross should automatically do the two steps
-# below, but it doesn't work for some reason.
-PERL_HOST_CONF_OPT = \
- --mode=buildmini \
- --target=$(GNU_TARGET_NAME) \
- --target-arch=$(GNU_TARGET_NAME) \
- --set-target-name=$(GNU_TARGET_NAME)
-
# We have to override LD, because an external multilib toolchain ld is not
# wrapped to provide the required sysroot options. We also can't use ccache
# because the configure script doesn't support it.
PERL_CONF_OPT = \
- --mode=target \
--target=$(GNU_TARGET_NAME) \
--target-tools-prefix=$(TARGET_CROSS) \
--prefix=/usr \
-Dld="$(TARGET_CC_NOCCACHE)" \
- -A ccflags="$(TARGET_CFLAGS)" \
- -A ldflags="$(TARGET_LDFLAGS) -lm" \
- -A mydomain="" \
- -A myhostname="$(BR2_TARGET_GENERIC_HOSTNAME)" \
- -A myuname="Buildroot $(BR2_VERSION_FULL)" \
- -A osname=linux \
- -A osvers=$(LINUX_VERSION) \
- -A perlamdin=root
+ -Dccflags="$(TARGET_CFLAGS)" \
+ -Dldflags="$(TARGET_LDFLAGS) -lm" \
+ -A define:mydomain="" \
+ -A define:myhostname="$(BR2_TARGET_GENERIC_HOSTNAME)" \
+ -A define:myuname="Buildroot $(BR2_VERSION_FULL)" \
+ -A define:osname=linux \
+ -A define:osvers=$(LINUX_VERSION) \
+ -A define:perladmin=root
ifeq ($(shell expr $(PERL_VERSION_MAJOR) % 2), 1)
PERL_CONF_OPT += -Dusedevel
@@ -79,8 +78,7 @@ PERL_CONF_OPT += --only-mod=$(subst $(space),$(comma),$(PERL_MODULES))
endif
define PERL_CONFIGURE_CMDS
- (cd $(@D); HOSTCC='$(HOSTCC_NOCACHE)' ./configure $(PERL_HOST_CONF_OPT))
- (cd $(@D); ./configure $(PERL_CONF_OPT))
+ (cd $(@D); HOSTCC='$(HOSTCC_NOCACHE)' ./configure $(PERL_CONF_OPT))
$(SED) 's/UNKNOWN-/Buildroot $(BR2_VERSION_FULL) /' $(@D)/patchlevel.h
endef