summaryrefslogtreecommitdiffstats
path: root/package/openssh/openssh.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/openssh/openssh.mk')
-rw-r--r--package/openssh/openssh.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index 64274e5a1..988815aae 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -10,12 +10,12 @@ OPENSSH_CONF_ENV = LD="$(TARGET_CC)"
OPENSSH_CONF_OPT = --libexecdir=/usr/lib --disable-lastlog --disable-utmp \
--disable-utmpx --disable-wtmp --disable-wtmpx --without-x
-OPENSSH_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
-
OPENSSH_DEPENDENCIES = zlib openssl
-$(eval $(call AUTOTARGETS,package,openssh))
-
-$(OPENSSH_HOOK_POST_INSTALL):
+define OPENSSH_INSTALL_INITSCRIPT
$(INSTALL) -D -m 755 package/openssh/S50sshd $(TARGET_DIR)/etc/init.d/S50sshd
- touch $@
+endef
+
+OPENSSH_POST_INSTALL_TARGET_HOOKS += OPENSSH_INSTALL_INITSCRIPT
+
+$(eval $(call AUTOTARGETS,package,openssh))