aboutsummaryrefslogtreecommitdiffstats
path: root/package/multimedia/libtheora/libtheora.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/multimedia/libtheora/libtheora.mk')
-rw-r--r--package/multimedia/libtheora/libtheora.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/multimedia/libtheora/libtheora.mk b/package/multimedia/libtheora/libtheora.mk
new file mode 100644
index 000000000..1d311d204
--- /dev/null
+++ b/package/multimedia/libtheora/libtheora.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# libtheora
+#
+#############################################################
+LIBTHEORA_VERSION = 1.0
+LIBTHEORA_SOURCE = libtheora-$(LIBTHEORA_VERSION).tar.bz2
+LIBTHEORA_SITE = http://downloads.xiph.org/releases/theora
+LIBTHEORA_INSTALL_STAGING = YES
+
+LIBTHEORA_CONF_OPT = \
+ --disable-oggtest \
+ --disable-vorbistest \
+ --disable-sdltest \
+ --disable-examples
+
+LIBTHEORA_DEPENDENCIES = libogg libvorbis pkgconfig
+
+$(eval $(call AUTOTARGETS,package/multimedia,libtheora))