summaryrefslogtreecommitdiffstats
path: root/package/libxml2/libxml2.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libxml2/libxml2.mk')
-rw-r--r--package/libxml2/libxml2.mk17
1 files changed, 1 insertions, 16 deletions
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 923a81336..6a974ef8b 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -10,6 +10,7 @@ LIBXML2_INSTALL_STAGING = YES
LIBXML2_AUTORECONF = YES
LIBXML2_LICENSE = MIT
LIBXML2_LICENSE_FILES = COPYING
+LIBXML2_CONFIG_SCRIPTS = xml2-config
ifneq ($(BR2_LARGEFILE),y)
LIBXML2_CONF_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
@@ -17,13 +18,6 @@ endif
LIBXML2_CONF_OPT = --with-gnu-ld --without-python --without-debug
-define LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
- $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xml2-config
- $(SED) "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xml2-config
-endef
-
-LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
-
HOST_LIBXML2_DEPENDENCIES = host-pkgconf
# mesa3d uses functions that are only available with debug
@@ -40,15 +34,6 @@ else
HOST_LIBXML2_CONF_OPT += --without-python
endif
-
-define LIBXML2_REMOVE_CONFIG_SCRIPTS
- $(RM) -f $(TARGET_DIR)/usr/bin/xml2-config
-endef
-
-ifneq ($(BR2_HAVE_DEVFILES),y)
-LIBXML2_POST_INSTALL_TARGET_HOOKS += LIBXML2_REMOVE_CONFIG_SCRIPTS
-endif
-
$(eval $(autotools-package))
$(eval $(host-autotools-package))