summaryrefslogtreecommitdiffstats
path: root/package/libwebsockets
diff options
context:
space:
mode:
Diffstat (limited to 'package/libwebsockets')
-rw-r--r--package/libwebsockets/Config.in9
-rw-r--r--package/libwebsockets/libwebsockets.mk15
2 files changed, 24 insertions, 0 deletions
diff --git a/package/libwebsockets/Config.in b/package/libwebsockets/Config.in
new file mode 100644
index 000000000..1d927bb4e
--- /dev/null
+++ b/package/libwebsockets/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBWEBSOCKETS
+ bool "libwebsockets"
+ select BR2_PACKAGE_ZLIB
+ help
+ Libwebsockets is a lightweight pure C library built to use
+ minimal CPU and memory resources, and provide fast throughput
+ in both directions.
+
+ http://libwebsockets.org/
diff --git a/package/libwebsockets/libwebsockets.mk b/package/libwebsockets/libwebsockets.mk
new file mode 100644
index 000000000..a3d893673
--- /dev/null
+++ b/package/libwebsockets/libwebsockets.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libwebsockets
+#
+################################################################################
+
+LIBWEBSOCKETS_VERSION = v1.1-chrome26-firefox18
+LIBWEBSOCKETS_SITE = http://git.libwebsockets.org/cgi-bin/cgit/libwebsockets/snapshot
+LIBWEBSOCKETS_LICENSE = LGPLv2.1
+LIBWEBSOCKETS_LICENSE_FILES = COPYING
+LIBWEBSOCKETS_DEPENDENCIES = zlib
+LIBWEBSOCKETS_AUTORECONF = YES
+LIBWEBSOCKETS_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))