summaryrefslogtreecommitdiffstats
path: root/package/jamvm/jamvm.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/jamvm/jamvm.mk')
-rw-r--r--package/jamvm/jamvm.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/jamvm/jamvm.mk b/package/jamvm/jamvm.mk
new file mode 100644
index 000000000..f0765d7cd
--- /dev/null
+++ b/package/jamvm/jamvm.mk
@@ -0,0 +1,11 @@
+JAMVM_VERSION = 1.5.4
+JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
+JAMVM_DEPENDENCIES = zlib classpath
+# int inlining seems to crash jamvm, don't build shared version of internal lib
+JAMVM_CONF_OPT = \
+ --with-classpath-install-dir=/usr \
+ --disable-int-inlining \
+ --disable-shared \
+ --without-pic
+
+$(eval $(autotools-package))