summaryrefslogtreecommitdiffstats
path: root/package/gutenprint
diff options
context:
space:
mode:
Diffstat (limited to 'package/gutenprint')
-rw-r--r--package/gutenprint/gutenprint.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/gutenprint/gutenprint.mk b/package/gutenprint/gutenprint.mk
index b5d350dfd..84f5a6da5 100644
--- a/package/gutenprint/gutenprint.mk
+++ b/package/gutenprint/gutenprint.mk
@@ -22,8 +22,11 @@ GUTENPRINT_DEPENDENCIES = cups host-pkgconf \
# so we need to build both a host package and a target package
GUTENPRINT_DEPENDENCIES += host-gutenprint
+GUTENPRINT_CONF_ENV = ac_cv_path_CUPS_CONFIG=$(STAGING_DIR)/usr/bin/cups-config
+
GUTENPRINT_CONF_OPT = --disable-libgutenprintui2 \
--disable-samples \
+ --without-doc \
--without-gimp2 \
--without-foomatic \
--without-foomatic3 \
@@ -42,6 +45,13 @@ HOST_GUTENPRINT_DEPENDENCIES =
# The host-gutenprint shall create the required header
HOST_GUTENPRINT_MAKE_ENV =
+# Even with --without-cups, gutenprint will still add the output of
+# cups-config --cflags / --ldflags to it's compiler/linker flags if
+# available on host.
+# Notice: Because of the configure logic, it needs to be set to the
+# empty string to to disable this, not just to /bin/false like elsewhere.
+HOST_GUTENPRINT_CONF_ENV = ac_cv_path_CUPS_CONFIG=''
+
HOST_GUTENPRINT_CONF_OPT = --disable-libgutenprintui2 \
--disable-samples \
--without-gimp2 \
@@ -52,7 +62,8 @@ HOST_GUTENPRINT_CONF_OPT = --disable-libgutenprintui2 \
--without-foomatic3 \
--disable-escputil \
--disable-test \
- --disable-testpattern
+ --disable-testpattern \
+ --without-cups
# Needed by autoreconf
define GUTENPRINT_CREATE_M4_DIR