summaryrefslogtreecommitdiffstats
path: root/package/gnutls
diff options
context:
space:
mode:
Diffstat (limited to 'package/gnutls')
-rw-r--r--package/gnutls/Config.in4
-rw-r--r--package/gnutls/gnutls.mk5
2 files changed, 4 insertions, 5 deletions
diff --git a/package/gnutls/Config.in b/package/gnutls/Config.in
index 556caea2d..cedf120ee 100644
--- a/package/gnutls/Config.in
+++ b/package/gnutls/Config.in
@@ -1,12 +1,8 @@
config BR2_PACKAGE_GNUTLS
bool "gnutls"
select BR2_PACKAGE_LIBGCRYPT
- depends on BR2_USE_WCHAR
help
GnuTLS is a secure communications library implementing the SSL
and TLS protocols and technologies around them.
http://www.gnu.org/software/gnutls/gnutls.html
-
-comment "gnutls requires a toolchain with WCHAR support"
- depends on !BR2_USE_WCHAR
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 263464257..506d7f5b8 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -10,7 +10,10 @@ GNUTLS_SITE = $(BR2_GNU_MIRROR)/gnutls
GNUTLS_LICENSE = GPLv3+ LGPLv2.1+
GNUTLS_LICENSE_FILES = COPYING lib/COPYING
GNUTLS_DEPENDENCIES = host-pkgconf libgcrypt $(if $(BR2_PACKAGE_ZLIB),zlib)
-GNUTLS_CONF_ENV = acl_cv_rpath=no
+GNUTLS_CONF_ENV = acl_cv_rpath=no \
+ ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \
+ gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no) \
+ gt_cv_c_wint_t=$(if $(BR2_USE_WCHAR),yes,no)
GNUTLS_CONF_OPT = --with-libgcrypt --without-libgcrypt-prefix \
--without-p11-kit --disable-rpath
GNUTLS_INSTALL_STAGING = YES