summaryrefslogtreecommitdiffstats
path: root/package/efl
diff options
context:
space:
mode:
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/Config.in2
-rw-r--r--package/efl/expedite/expedite.mk2
-rw-r--r--package/efl/libecore/libecore-ecore_exe-fix-build-with-glibc-2-16.patch94
-rw-r--r--package/efl/libecore/libecore.mk2
-rw-r--r--package/efl/libedbus/libedbus.mk2
-rw-r--r--package/efl/libedje/libedje.mk2
-rw-r--r--package/efl/libeet/libeet.mk2
-rw-r--r--package/efl/libefreet/libefreet.mk2
-rw-r--r--package/efl/libeina/libeina.mk2
-rw-r--r--package/efl/libeio/Config.in18
-rw-r--r--package/efl/libeio/libeio.mk16
-rw-r--r--package/efl/libelementary/libelementary.mk4
-rw-r--r--package/efl/libembryo/libembryo.mk2
-rw-r--r--package/efl/libethumb/libethumb.mk4
-rw-r--r--package/efl/libevas-generic-loaders/Config.in21
-rw-r--r--package/efl/libevas-generic-loaders/libevas-generic-loaders.mk31
-rw-r--r--package/efl/libevas/Config.in6
-rw-r--r--package/efl/libevas/libevas.mk18
18 files changed, 111 insertions, 119 deletions
diff --git a/package/efl/Config.in b/package/efl/Config.in
index c783d7f07..bb1a986cb 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -13,7 +13,9 @@ source "package/efl/libeina/Config.in"
source "package/efl/libecore/Config.in"
source "package/efl/libeet/Config.in"
source "package/efl/libefreet/Config.in"
+source "package/efl/libeio/Config.in"
source "package/efl/libevas/Config.in"
+source "package/efl/libevas-generic-loaders/Config.in"
source "package/efl/libembryo/Config.in"
source "package/efl/libedje/Config.in"
source "package/efl/libethumb/Config.in"
diff --git a/package/efl/expedite/expedite.mk b/package/efl/expedite/expedite.mk
index 26d25f5ba..4b245ec9b 100644
--- a/package/efl/expedite/expedite.mk
+++ b/package/efl/expedite/expedite.mk
@@ -4,7 +4,7 @@
#
#############################################################
-EXPEDITE_VERSION = 1.1.0
+EXPEDITE_VERSION = 1.7.4
EXPEDITE_SITE = http://download.enlightenment.org/releases/
EXPEDITE_LICENSE = BSD-2c
EXPEDITE_LICENSE_FILES = COPYING
diff --git a/package/efl/libecore/libecore-ecore_exe-fix-build-with-glibc-2-16.patch b/package/efl/libecore/libecore-ecore_exe-fix-build-with-glibc-2-16.patch
deleted file mode 100644
index d9b439cb7..000000000
--- a/package/efl/libecore/libecore-ecore_exe-fix-build-with-glibc-2-16.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-Backported for commit a0df6712b6afcd07facd32e5a66809170277bdf3
-Fixed the ChangeLog part.
-
-This patch fix build with glibc >=2.16, avoiding the following error occurs:
-
-Making all in ecore
-make[6]: Entering directory `/opt/buildroot/output/build/host-libecore-1.1.0/src/lib/ecore'
- CC ecore.lo
- CC ecore_anim.lo
- CC ecore_app.lo
- CC ecore_events.lo
- CC ecore_getopt.lo
- CC ecore_idle_enterer.lo
- CC ecore_idle_exiter.lo
- CC ecore_idler.lo
- CC ecore_job.lo
- CC ecore_main.lo
- CC ecore_pipe.lo
- CC ecore_poll.lo
- CC ecore_time.lo
- CC ecore_timer.lo
- CC ecore_thread.lo
- CC ecore_glib.lo
- CC ecore_throttle.lo
- CC ecore_signal.lo
- CC ecore_exe.lo
-ecore_exe.c: In function ‘ecore_exe_pipe_run’:
-ecore_exe.c:486:15: warning: implicit declaration of function ‘setpriority’ [-Wimplicit-function-declaration]
-ecore_exe.c:486:27: error ‘PRIO_PROCESS’ undeclared (first use in this function)
-ecore_exe.c:486:27: note: each undeclared identifier is reported only once for each function it appears in
-make[6]: *** [ecore_exe.lo] Error 1
-
-
-Signed-off-by: Samuel Martin <s.martin49@gmail.com>
-
----
-From a0df6712b6afcd07facd32e5a66809170277bdf3 Mon Sep 17 00:00:00 2001
-From: caro <caro>
-Date: Fri, 22 Jun 2012 05:36:00 +0000
-Subject: [PATCH] ecore_exe: fix compilation on fedora 18.
-
-setpriority needs sys/resource.h. See:
-
-http://linux.die.net/man/2/setpriority
-
-I let sys/time.h, it does not hurt on linux and is anyway needed for BSD systems.
-
-
-git-svn-id: http://svn.enlightenment.org/svn/e@72684 7cbeb6ba-43b4-40fd-8cce-4c39aea84d33
----
- ChangeLog | 4 ++++
- src/lib/ecore/ecore_exe.c | 7 ++-----
- 2 files changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/ChangeLog b/ChangeLog
-index a306f75..549ad19 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -763,3 +763,7 @@
- 2011-11-29 Mike McCormack
-
- * Allow quitting before entering the glib version of the main loop
-+
-+2012-06-22 Vincent Torri
-+
-+ * ecore_exe: fix compilation on fedora 18.
-diff --git a/src/lib/ecore/ecore_exe.c b/src/lib/ecore/ecore_exe.c
-index 7931a96..6db32a9 100644
---- a/src/lib/ecore/ecore_exe.c
-+++ b/src/lib/ecore/ecore_exe.c
-@@ -2,11 +2,6 @@
- # include <config.h>
- #endif
-
--#if defined (__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__)
--# include <sys/time.h>
--# include <sys/resource.h>
--#endif
--
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -14,6 +9,8 @@
- #include <sys/types.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#include <sys/time.h>
-+#include <sys/resource.h>
-
- #ifdef HAVE_SYS_PRCTL_H
- # include <sys/prctl.h>
---
-1.7.12.2
-
diff --git a/package/efl/libecore/libecore.mk b/package/efl/libecore/libecore.mk
index 9eb09ac2f..0220017df 100644
--- a/package/efl/libecore/libecore.mk
+++ b/package/efl/libecore/libecore.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBECORE_VERSION = 1.1.0
+LIBECORE_VERSION = 1.7.4
LIBECORE_SOURCE = ecore-$(LIBECORE_VERSION).tar.bz2
LIBECORE_SITE = http://download.enlightenment.org/releases/
LIBECORE_LICENSE = BSD-2c
diff --git a/package/efl/libedbus/libedbus.mk b/package/efl/libedbus/libedbus.mk
index 60651e307..9c62ead8f 100644
--- a/package/efl/libedbus/libedbus.mk
+++ b/package/efl/libedbus/libedbus.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBEDBUS_VERSION = 1.1.0
+LIBEDBUS_VERSION = 1.7.4
LIBEDBUS_SOURCE = e_dbus-$(LIBEDBUS_VERSION).tar.bz2
LIBEDBUS_SITE = http://download.enlightenment.org/releases/
LIBEDBUS_LICENSE = BSD-2c
diff --git a/package/efl/libedje/libedje.mk b/package/efl/libedje/libedje.mk
index ce17da514..a02eaa9a7 100644
--- a/package/efl/libedje/libedje.mk
+++ b/package/efl/libedje/libedje.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBEDJE_VERSION = 1.1.0
+LIBEDJE_VERSION = 1.7.4
LIBEDJE_SOURCE = edje-$(LIBEDJE_VERSION).tar.bz2
LIBEDJE_SITE = http://download.enlightenment.org/releases/
LIBEDJE_LICENSE = GPLv2+ (epp binary), BSD-2c (everything else)
diff --git a/package/efl/libeet/libeet.mk b/package/efl/libeet/libeet.mk
index ccb350187..a5a1ce1d5 100644
--- a/package/efl/libeet/libeet.mk
+++ b/package/efl/libeet/libeet.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBEET_VERSION = 1.5.0
+LIBEET_VERSION = 1.7.4
LIBEET_SOURCE = eet-$(LIBEET_VERSION).tar.bz2
LIBEET_SITE = http://download.enlightenment.org/releases/
LIBEET_LICENSE = BSD-2c
diff --git a/package/efl/libefreet/libefreet.mk b/package/efl/libefreet/libefreet.mk
index c0d73971d..b23a5a507 100644
--- a/package/efl/libefreet/libefreet.mk
+++ b/package/efl/libefreet/libefreet.mk
@@ -4,7 +4,7 @@
#
################################################################################
-LIBEFREET_VERSION = 1.1.0
+LIBEFREET_VERSION = 1.7.4
LIBEFREET_SOURCE = efreet-$(LIBEFREET_VERSION).tar.bz2
LIBEFREET_SITE = http://download.enlightenment.org/releases/
LIBEFREET_LICENSE = BSD-2c
diff --git a/package/efl/libeina/libeina.mk b/package/efl/libeina/libeina.mk
index e5b89c1ce..d99a237cc 100644
--- a/package/efl/libeina/libeina.mk
+++ b/package/efl/libeina/libeina.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBEINA_VERSION = 1.1.0
+LIBEINA_VERSION = 1.7.4
LIBEINA_SOURCE = eina-$(LIBEINA_VERSION).tar.bz2
LIBEINA_SITE = http://download.enlightenment.org/releases/
LIBEINA_LICENSE = LGPLv2.1+
diff --git a/package/efl/libeio/Config.in b/package/efl/libeio/Config.in
new file mode 100644
index 000000000..0b2751ce6
--- /dev/null
+++ b/package/efl/libeio/Config.in
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_LIBEIO
+ bool "libeio"
+ select BR2_PACKAGE_LIBEET
+ select BR2_PACKAGE_LIBEINA
+ select BR2_PACKAGE_LIBECORE
+ help
+ Eio integrates with EFL (Ecore, Eina) to provide efficient
+ filesystem Input/Output (I/O). It use the best techniques to
+ achieve such purpose, like using at-variants, splice,
+ properly handling errors and doing it in an asynchronous
+ fashion by means of worker threads. It is also ported to
+ Windows, so multi-platform.
+
+ Whenever you need to list a directory, copy, move or delete
+ files, Eio will do that task better than you'd achieve with
+ naive implementations, and it is easy to use.
+
+ http://trac.enlightenment.org/e/wiki/Eio
diff --git a/package/efl/libeio/libeio.mk b/package/efl/libeio/libeio.mk
new file mode 100644
index 000000000..f5e08de5b
--- /dev/null
+++ b/package/efl/libeio/libeio.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# libeio
+#
+#############################################################
+
+LIBEIO_VERSION = 1.7.4
+LIBEIO_SOURCE = eio-$(LIBEIO_VERSION).tar.bz2
+LIBEIO_SITE = http://download.enlightenment.org/releases/
+LIBEIO_LICENSE = LGPLv2.1
+LIBEIO_LICENSE_FILES = COPYING
+
+LIBEIO_INSTALL_STAGING = YES
+LIBEIO_DEPENDENCIES = libeina libeet libecore
+
+$(eval $(autotools-package))
diff --git a/package/efl/libelementary/libelementary.mk b/package/efl/libelementary/libelementary.mk
index 8957d038d..81289ff03 100644
--- a/package/efl/libelementary/libelementary.mk
+++ b/package/efl/libelementary/libelementary.mk
@@ -4,9 +4,9 @@
#
################################################################################
-LIBELEMENTARY_VERSION = 0.8.0.65643
+LIBELEMENTARY_VERSION = 1.7.4
LIBELEMENTARY_SOURCE = elementary-$(LIBELEMENTARY_VERSION).tar.bz2
-LIBELEMENTARY_SITE = http://download.enlightenment.org/snapshots/2011-11-28
+LIBELEMENTARY_SITE = http://download.enlightenment.org/releases/
LIBELEMENTARY_LICENSE = LGPLv2.1
LIBELEMENTARY_LICENSE_FILES = COPYING
diff --git a/package/efl/libembryo/libembryo.mk b/package/efl/libembryo/libembryo.mk
index 9cab5aaaf..ce5c96824 100644
--- a/package/efl/libembryo/libembryo.mk
+++ b/package/efl/libembryo/libembryo.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBEMBRYO_VERSION = 1.1.0
+LIBEMBRYO_VERSION = 1.7.4
LIBEMBRYO_SOURCE = embryo-$(LIBEMBRYO_VERSION).tar.bz2
LIBEMBRYO_SITE = http://download.enlightenment.org/releases/
LIBEMBRYO_LICENSE = BSD-2c, Embryo license
diff --git a/package/efl/libethumb/libethumb.mk b/package/efl/libethumb/libethumb.mk
index ba77e4c07..eb098eaef 100644
--- a/package/efl/libethumb/libethumb.mk
+++ b/package/efl/libethumb/libethumb.mk
@@ -4,9 +4,9 @@
#
################################################################################
-LIBETHUMB_VERSION = 0.1.1.65643
+LIBETHUMB_VERSION = 1.7.4
LIBETHUMB_SOURCE = ethumb-$(LIBETHUMB_VERSION).tar.bz2
-LIBETHUMB_SITE = http://download.enlightenment.org/snapshots/2011-11-28
+LIBETHUMB_SITE = http://download.enlightenment.org/releases/
LIBETHUMB_LICENSE = LGPLv2.1+
LIBETHUMB_LICENSE_FILES = COPYING
diff --git a/package/efl/libevas-generic-loaders/Config.in b/package/efl/libevas-generic-loaders/Config.in
new file mode 100644
index 000000000..44bc37da2
--- /dev/null
+++ b/package/efl/libevas-generic-loaders/Config.in
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
+ bool "libevas generic loaders"
+ select BR2_PACKAGE_LIBEINA
+ help
+ These are additional "generic" loaders for Evas that are
+ stand-alone executables that evas may run from its generic
+ loader module.
+
+ http://trac.enlightenment.org/e/wiki/Evas_Generic_Loaders
+
+if BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS
+
+config BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG
+ bool "SVG loader"
+ select BR2_PACKAGE_LIBRSVG
+ select BR2_PACKAGE_CAIRO
+ depends on BR2_USE_WCHAR # librsvg -> glib2
+ help
+ This option enables the Evas generic SVG loader
+
+endif
diff --git a/package/efl/libevas-generic-loaders/libevas-generic-loaders.mk b/package/efl/libevas-generic-loaders/libevas-generic-loaders.mk
new file mode 100644
index 000000000..76236b12c
--- /dev/null
+++ b/package/efl/libevas-generic-loaders/libevas-generic-loaders.mk
@@ -0,0 +1,31 @@
+#############################################################
+#
+# libevas-generic-loaders
+#
+#############################################################
+
+LIBEVAS_GENERIC_LOADERS_VERSION = 1.7.4
+LIBEVAS_GENERIC_LOADERS_SOURCE = evas_generic_loaders-$(LIBEVAS_GENERIC_LOADERS_VERSION).tar.bz2
+LIBEVAS_GENERIC_LOADERS_SITE = http://download.enlightenment.org/releases/
+LIBEVAS_GENERIC_LOADERS_LICENSE = GPLv2
+LIBEVAS_GENERIC_LOADERS_LICENSE_FILES = COPYING
+
+LIBEVAS_GENERIC_LOADERS_INSTALL_STAGING = YES
+
+LIBEVAS_GENERIC_LOADERS_DEPENDENCIES = libeina
+
+# For now, we only support the SVG loader
+LIBEVAS_GENERIC_LOADERS_CONF_OPT += \
+ --disable-poppler \
+ --disable-spectre \
+ --disable-libraw \
+ --disable-gstreamer
+
+ifeq ($(BR2_PACKAGE_LIBEVAS_GENERIC_LOADERS_SVG),y)
+LIBEVAS_GENERIC_LOADERS_DEPENDENCIES += librsvg cairo
+LIBEVAS_GENERIC_LOADERS_CONF_OPT += --enable-svg
+else
+LIBEVAS_GENERIC_LOADERS_CONF_OPT += --disable-svg
+endif
+
+$(eval $(autotools-package))
diff --git a/package/efl/libevas/Config.in b/package/efl/libevas/Config.in
index ddac49ef3..bd845c115 100644
--- a/package/efl/libevas/Config.in
+++ b/package/efl/libevas/Config.in
@@ -91,6 +91,7 @@ config BR2_PACKAGE_LIBEVAS_X11
bool "libevas X11 backend"
depends on BR2_PACKAGE_XORG7
select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXEXT
help
This enables the software X11 rendering engine that renders
to X drawable targets using highly optimised software
@@ -181,11 +182,6 @@ config BR2_PACKAGE_LIBEVAS_TIFF
help
This enables the loader code that loads tiff files.
-config BR2_PACKAGE_LIBEVAS_SVG
- bool "libevas svg loader"
- help
- This enables the loader code that loads svg files.
-
config BR2_PACKAGE_LIBEVAS_XPM
bool "libevas xpm loader"
help
diff --git a/package/efl/libevas/libevas.mk b/package/efl/libevas/libevas.mk
index 1f053e37c..0a908424f 100644
--- a/package/efl/libevas/libevas.mk
+++ b/package/efl/libevas/libevas.mk
@@ -4,7 +4,7 @@
#
#############################################################
-LIBEVAS_VERSION = 1.1.0
+LIBEVAS_VERSION = 1.7.4
LIBEVAS_SOURCE = evas-$(LIBEVAS_VERSION).tar.bz2
LIBEVAS_SITE = http://download.enlightenment.org/releases/
LIBEVAS_LICENSE = BSD-2c
@@ -63,7 +63,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
LIBEVAS_CONF_OPT += --enable-software-xlib
-LIBEVAS_DEPENDENCIES += xproto_xproto
+LIBEVAS_DEPENDENCIES += xlib_libX11 xlib_libXext
endif
ifeq ($(BR2_PACKAGE_LIBEVAS_X11_GLX),y)
@@ -176,12 +176,6 @@ else
LIBEVAS_CONF_OPT += --disable-image-loader-pmaps
endif
-ifeq ($(BR2_PACKAGE_LIBEVAS_SVG),y)
-LIBEVAS_CONF_OPT += --enable-image-loader-svg
-else
-LIBEVAS_CONF_OPT += --disable-image-loader-svg
-endif
-
ifeq ($(BR2_PACKAGE_LIBEVAS_TIFF),y)
LIBEVAS_CONF_OPT += --enable-image-loader-tiff
LIBEVAS_DEPENDENCIES += tiff
@@ -209,5 +203,13 @@ else
LIBEVAS_CONF_OPT += --disable-font-loader-eet
endif
+# libevas installs the source code of examples on the target, which
+# are generally not useful.
+define LIBEVAS_REMOVE_EXAMPLES
+ rm -rf $(TARGET_DIR)/usr/share/evas/examples/
+endef
+
+LIBEVAS_POST_INSTALL_TARGET_HOOKS += LIBEVAS_REMOVE_EXAMPLES
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))