summaryrefslogtreecommitdiffstats
path: root/package/dosfstools/dosfstools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/dosfstools/dosfstools.mk')
-rw-r--r--package/dosfstools/dosfstools.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/package/dosfstools/dosfstools.mk b/package/dosfstools/dosfstools.mk
index 4f89364c7..e3cc9cfb5 100644
--- a/package/dosfstools/dosfstools.mk
+++ b/package/dosfstools/dosfstools.mk
@@ -4,17 +4,24 @@
#
#############################################################
-DOSFSTOOLS_VERSION = 3.0.12
-DOSFSTOOLS_SITE = http://fossies.org/linux/misc/
+DOSFSTOOLS_VERSION = 3.0.15
+DOSFSTOOLS_SITE = http://fossies.org/linux/misc
DOSFSTOOLS_LICENSE = GPLv3+
DOSFSTOOLS_LICENSE_FILES = COPYING
+DOSFSTOOLS_LDFLAGS = $(TARGET_LDFLAGS)
+
+ifneq ($(BR2_ENABLE_LOCALE),y)
+DOSFSTOOLS_DEPENDENCIES += libiconv
+DOSFSTOOLS_LDFLAGS += -liconv
+endif
+
MKDOSFS_BINARY = mkdosfs
DOSFSCK_BINARY = dosfsck
DOSFSLABEL_BINARY = dosfslabel
define DOSFSTOOLS_BUILD_CMDS
- $(MAKE) CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" \
- CC="$(TARGET_CC)" -C $(@D)
+ $(MAKE) CFLAGS="$(TARGET_CFLAGS)" CC="$(TARGET_CC)" \
+ LDFLAGS="$(DOSFSTOOLS_LDFLAGS)" -C $(@D)
endef
DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_MKDOSFS)+=$(MKDOSFS_BINARY)