summaryrefslogtreecommitdiffstats
path: root/package/crosstool-ng
diff options
context:
space:
mode:
Diffstat (limited to 'package/crosstool-ng')
-rw-r--r--package/crosstool-ng/crosstool-ng-000-makefile-recursion.patch2
-rw-r--r--package/crosstool-ng/crosstool-ng-001-wget-instead-of-curl.patch52
-rw-r--r--package/crosstool-ng/crosstool-ng.mk2
3 files changed, 54 insertions, 2 deletions
diff --git a/package/crosstool-ng/crosstool-ng-000-makefile-recursion.patch b/package/crosstool-ng/crosstool-ng-000-makefile-recursion.patch
index 4f6674472..b875e3f1a 100644
--- a/package/crosstool-ng/crosstool-ng-000-makefile-recursion.patch
+++ b/package/crosstool-ng/crosstool-ng-000-makefile-recursion.patch
@@ -18,7 +18,7 @@ Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
diff -du crosstool-ng-1.12.0/Makefile.in host-crosstool-ng-1.12.0/Makefile.in
--- crosstool-ng-1.12.0/Makefile.in 2011-08-01 01:21:34.000000000 +0200
+++ host-crosstool-ng-1.12.0/Makefile.in 2011-08-07 21:39:16.055958219 +0200
-@@ -95,9 +95,14 @@
+@@ -101,9 +101,14 @@
# level.
# This has the side effect of only showing the real targets, and hiding our
# internal ones. :-)
diff --git a/package/crosstool-ng/crosstool-ng-001-wget-instead-of-curl.patch b/package/crosstool-ng/crosstool-ng-001-wget-instead-of-curl.patch
new file mode 100644
index 000000000..d40f178b8
--- /dev/null
+++ b/package/crosstool-ng/crosstool-ng-001-wget-instead-of-curl.patch
@@ -0,0 +1,52 @@
+Use wget instead of curl
+
+While crosstool-NG did support either curl or wget in the past, it now
+only supports curl. Unfortunately, Buildroot uses wget for all its
+downloads, so wget is a hard dependency of Buildroot, while curl
+isn't.
+
+Instead of adding curl as a new Buildroot dependency, or building curl
+for the host, we simply tweak crosstool-NG to use wget instead of
+curl.
+
+The script/functions change has been provided by Yann E. Morin.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: crosstool-ng-1.13.0/configure
+===================================================================
+--- crosstool-ng-1.13.0.orig/configure
++++ crosstool-ng-1.13.0/configure
+@@ -496,7 +496,7 @@
+ ver='\(GNU libtool.*\) (2[[:digit:]]*\.|1\.6[[:digit:]]*\.|1\.5\.[2-9][[:digit:]]+)' \
+ err="'libtoolize' 1.5.26 or above was not found"
+ has_or_abort prog=stat
+-has_or_abort prog="curl"
++has_or_abort prog="wget"
+ has_or_abort prog=patch
+ has_or_abort prog=tar
+ has_or_abort prog=gzip
+Index: crosstool-ng-1.13.0/scripts/functions
+===================================================================
+--- crosstool-ng-1.13.0.orig/scripts/functions
++++ crosstool-ng-1.13.0/scripts/functions
+@@ -456,13 +456,12 @@
+ # Some company networks have firewalls to connect to the internet, but it's
+ # not easy to detect them, so force a global ${CT_CONNECT_TIMEOUT}-second
+ # timeout.
+- # For curl, no good progress indicator is available. So, be silent.
+- if CT_DoExecLog ALL curl --ftp-pasv \
+- --retry 3 \
+- --connect-timeout ${CT_CONNECT_TIMEOUT} \
+- --location --fail --silent \
+- --output "${tmp}" \
+- "${url}"
++ if CT_DoExecLog ALL wget --passive-ftp --tries=3 -nc \
++ -T ${CT_CONNECT_TIMEOUT} \
++ -O "${tmp}" \
++ "${url}"
++
++
+ then
+ # Success, we got it, good!
+ mv "${tmp}" "${dest}"
diff --git a/package/crosstool-ng/crosstool-ng.mk b/package/crosstool-ng/crosstool-ng.mk
index f6766972c..0337bf1fe 100644
--- a/package/crosstool-ng/crosstool-ng.mk
+++ b/package/crosstool-ng/crosstool-ng.mk
@@ -1,4 +1,4 @@
-CROSSTOOL_NG_VERSION = 1.13.0
+CROSSTOOL_NG_VERSION = 1.13.2
CROSSTOOL_NG_SOURCE = crosstool-ng-$(CROSSTOOL_NG_VERSION).tar.bz2
CROSSTOOL_NG_SITE = http://crosstool-ng.org/download/crosstool-ng/
CROSSTOOL_NG_INSTALL_STAGING = NO