summaryrefslogtreecommitdiffstats
path: root/package/coreutils/coreutils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/coreutils/coreutils.mk')
-rw-r--r--package/coreutils/coreutils.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index caad648a8..df07a0885 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -73,7 +73,13 @@ $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY): $(COREUTILS_DIR)/$(COREUTILS_BINARY)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+#If both coreutils and busybox are selected, make certain coreutils
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+coreutils: uclibc busybox $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+else
coreutils: uclibc $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+endif
coreutils-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) uninstall