aboutsummaryrefslogtreecommitdiffstats
path: root/package/bustle/bustle.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/bustle/bustle.mk')
-rw-r--r--package/bustle/bustle.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/bustle/bustle.mk b/package/bustle/bustle.mk
new file mode 100644
index 000000000..88d49b62e
--- /dev/null
+++ b/package/bustle/bustle.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# bustle
+#
+#############################################################
+
+BUSTLE_VERSION = 0.4.2
+BUSTLE_SITE = http://www.willthompson.co.uk/bustle/releases/$(BUSTLE_VERSION)/
+BUSTLE_LICENSE = LGPLv2.1+
+BUSTLE_LICENSE_FILES = LICENSE
+BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
+
+define BUSTLE_BUILD_CMDS
+ PATH=$(TARGET_PATH) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+ PCAP_FLAGS='-lpcap' -C $(@D) dist/build/bustle-pcap
+endef
+
+define BUSTLE_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/dist/build/bustle-pcap \
+ $(TARGET_DIR)/usr/bin/bustle-pcap
+endef
+
+$(eval $(generic-package))