summaryrefslogtreecommitdiffstats
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index ae48654e2..16fc37192 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -130,9 +130,10 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
-# support make source/source-check/external-deps
-ifneq ($(filter source,$(MAKECMDGOALS)),)
+# support make source-check/external-deps
+ifeq ($(MAKELEVEL),1)
$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
+ $(if $($(PKG)_PATCH),$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
else
$(call MESSAGE,"Downloading")
ifneq ($(strip $(subst ",,$(BR2_PRIMARY_SITE))),)