summaryrefslogtreecommitdiffstats
path: root/make/user-mode-linux.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/user-mode-linux.mk')
-rw-r--r--make/user-mode-linux.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/make/user-mode-linux.mk b/make/user-mode-linux.mk
index 5b0750230..79968a769 100644
--- a/make/user-mode-linux.mk
+++ b/make/user-mode-linux.mk
@@ -55,3 +55,12 @@ user-mode-linux_clean: clean
user-mode-linux-dirclean:
rm -rf $(UMLINUX_DIR)
+#############################################################
+#
+# Setup the kernel headers, but don't compile anything for the target yet,
+# since we still need to build a cross-compiler to do that little task for
+# us... Try to work around this little chicken-and-egg problem..
+#
+#############################################################
+linux_headers: $(UMLINUX_DIR)/.configured
+