summaryrefslogtreecommitdiffstats
path: root/make/mke2fs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/mke2fs.mk')
-rw-r--r--make/mke2fs.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/mke2fs.mk b/make/mke2fs.mk
index 589da672b..759d86528 100644
--- a/make/mke2fs.mk
+++ b/make/mke2fs.mk
@@ -21,9 +21,11 @@ $(MKE2FS_DIR)/.unpacked: $(DL_DIR)/$(MKE2FS_SOURCE)
$(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
(cd $(MKE2FS_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ $(TARGET_CONFIGURE_OPTS) \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--with-cc=$(TARGET_CC) \
--with-linker=$(TARGET_CROSS)ld \
--prefix=/usr \