summaryrefslogtreecommitdiffstats
path: root/docs/manual
diff options
context:
space:
mode:
Diffstat (limited to 'docs/manual')
-rw-r--r--docs/manual/adding-packages-autotools.txt34
-rw-r--r--docs/manual/adding-packages-cmake.txt34
-rw-r--r--docs/manual/adding-packages-conclusion.txt1
-rw-r--r--docs/manual/adding-packages-directory.txt1
-rw-r--r--docs/manual/adding-packages-generic.txt84
-rw-r--r--docs/manual/adding-packages-gettext.txt1
-rw-r--r--docs/manual/adding-packages-tips.txt1
-rw-r--r--docs/manual/adding-packages.txt3
-rw-r--r--docs/manual/advanced.txt1
-rw-r--r--docs/manual/appendix.txt1
-rw-r--r--docs/manual/beyond-buildroot.txt1
-rw-r--r--docs/manual/ccache-support.txt3
-rw-r--r--docs/manual/common-usage.txt1
-rw-r--r--docs/manual/configure.txt6
-rw-r--r--docs/manual/contribute.txt1
-rw-r--r--docs/manual/customize-busybox-config.txt3
-rw-r--r--docs/manual/customize-kernel-config.txt3
-rw-r--r--docs/manual/customize-rootfs.txt33
-rw-r--r--docs/manual/customize-store.txt10
-rw-r--r--docs/manual/customize-toolchain.txt5
-rw-r--r--docs/manual/customize-uclibc-config.txt3
-rw-r--r--docs/manual/customize.txt1
-rw-r--r--docs/manual/developer-guide.txt1
-rw-r--r--docs/manual/download-infra.txt3
-rw-r--r--docs/manual/download-location.txt1
-rw-r--r--docs/manual/eclipse-integration.txt1
-rw-r--r--docs/manual/faq-troubleshooting.txt1
-rw-r--r--docs/manual/get-involved.txt1
-rw-r--r--docs/manual/getting.txt3
-rw-r--r--docs/manual/going-further.txt1
-rw-r--r--docs/manual/how-buildroot-works.txt1
-rw-r--r--docs/manual/introduction.txt1
-rw-r--r--docs/manual/legal-notice.txt1
-rw-r--r--docs/manual/make-tips.txt3
-rw-r--r--docs/manual/makedev-syntax.txt3
-rw-r--r--docs/manual/manual.mk2
-rw-r--r--docs/manual/manual.txt1
-rw-r--r--docs/manual/package-make-target.txt1
-rw-r--r--docs/manual/patch-policy.txt18
-rw-r--r--docs/manual/prerequisite.txt3
-rw-r--r--docs/manual/rebuilding-packages.txt3
-rw-r--r--docs/manual/starting-up.txt1
-rw-r--r--docs/manual/using-buildroot-toolchain.txt1
-rw-r--r--docs/manual/using.txt1
-rw-r--r--docs/manual/working-with.txt4
-rw-r--r--docs/manual/writing-rules.txt1
46 files changed, 178 insertions, 110 deletions
diff --git a/docs/manual/adding-packages-autotools.txt b/docs/manual/adding-packages-autotools.txt
index 84d76f929..1d5f30bc3 100644
--- a/docs/manual/adding-packages-autotools.txt
+++ b/docs/manual/adding-packages-autotools.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Infrastructure for autotools-based packages
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
@@ -17,24 +18,25 @@ package, with an example :
03: # libfoo
04: #
05: #############################################################
-06: LIBFOO_VERSION = 1.0
-07: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
-08: LIBFOO_SITE = http://www.foosoftware.org/download
-09: LIBFOO_INSTALL_STAGING = YES
-10: LIBFOO_INSTALL_TARGET = NO
-11: LIBFOO_CONF_OPT = --disable-shared
-12: LIBFOO_DEPENDENCIES = libglib2 host-pkgconf
-13:
-14: $(eval $(autotools-package))
+06:
+07: LIBFOO_VERSION = 1.0
+08: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
+09: LIBFOO_SITE = http://www.foosoftware.org/download
+10: LIBFOO_INSTALL_STAGING = YES
+11: LIBFOO_INSTALL_TARGET = NO
+12: LIBFOO_CONF_OPT = --disable-shared
+13: LIBFOO_DEPENDENCIES = libglib2 host-pkgconf
+14:
+15: $(eval $(autotools-package))
------------------------
-On line 6, we declare the version of the package.
+On line 7, we declare the version of the package.
-On line 7 and 8, we declare the name of the tarball and the location
+On line 8 and 9, we declare the name of the tarball and the location
of the tarball on the Web. Buildroot will automatically download the
tarball from this location.
-On line 9, we tell Buildroot to install the package to the staging
+On line 10, we tell Buildroot to install the package to the staging
directory. The staging directory, located in +output/staging/+
is the directory where all the packages are installed, including their
development files, etc. By default, packages are not installed to the
@@ -44,7 +46,7 @@ other libraries or applications depending on them. Also by default, when
staging installation is enabled, packages are installed in this location
using the +make install+ command.
-On line 10, we tell Buildroot to not install the package to the
+On line 11, we tell Buildroot to not install the package to the
target directory. This directory contains what will become the root
filesystem running on the target. For purely static libraries, it is
not necessary to install them in the target directory because they will
@@ -52,14 +54,14 @@ not be used at runtime. By default, target installation is enabled; setting
this variable to NO is almost never needed. Also by default, packages are
installed in this location using the +make install+ command.
-On line 11, we tell Buildroot to pass a custom configure option, that
+On line 12, we tell Buildroot to pass a custom configure option, that
will be passed to the +./configure+ script before configuring
and building the package.
-On line 12, we declare our dependencies, so that they are built
+On line 13, we declare our dependencies, so that they are built
before the build process of our package starts.
-Finally, on line line 14, we invoke the +autotools-package+
+Finally, on line line 15, we invoke the +autotools-package+
macro that generates all the Makefile rules that actually allows the
package to be built.
diff --git a/docs/manual/adding-packages-cmake.txt b/docs/manual/adding-packages-cmake.txt
index bb1705bfd..6ac073c35 100644
--- a/docs/manual/adding-packages-cmake.txt
+++ b/docs/manual/adding-packages-cmake.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Infrastructure for CMake-based packages
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
@@ -17,24 +18,25 @@ with an example :
03: # libfoo
04: #
05: #############################################################
-06: LIBFOO_VERSION = 1.0
-07: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
-08: LIBFOO_SITE = http://www.foosoftware.org/download
-09: LIBFOO_INSTALL_STAGING = YES
-10: LIBFOO_INSTALL_TARGET = NO
-11: LIBFOO_CONF_OPT = -DBUILD_DEMOS=ON
-12: LIBFOO_DEPENDENCIES = libglib2 host-pkgconf
-13:
-14: $(eval $(cmake-package))
+06:
+07: LIBFOO_VERSION = 1.0
+08: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
+09: LIBFOO_SITE = http://www.foosoftware.org/download
+10: LIBFOO_INSTALL_STAGING = YES
+11: LIBFOO_INSTALL_TARGET = NO
+12: LIBFOO_CONF_OPT = -DBUILD_DEMOS=ON
+13: LIBFOO_DEPENDENCIES = libglib2 host-pkgconf
+14:
+15: $(eval $(cmake-package))
------------------------
-On line 6, we declare the version of the package.
+On line 7, we declare the version of the package.
-On line 7 and 8, we declare the name of the tarball and the location
+On line 8 and 9, we declare the name of the tarball and the location
of the tarball on the Web. Buildroot will automatically download the
tarball from this location.
-On line 9, we tell Buildroot to install the package to the staging
+On line 10, we tell Buildroot to install the package to the staging
directory. The staging directory, located in +output/staging/+
is the directory where all the packages are installed, including their
development files, etc. By default, packages are not installed to the
@@ -44,7 +46,7 @@ other libraries or applications depending on them. Also by default, when
staging installation is enabled, packages are installed in this location
using the +make install+ command.
-On line 10, we tell Buildroot to not install the package to the
+On line 11, we tell Buildroot to not install the package to the
target directory. This directory contains what will become the root
filesystem running on the target. For purely static libraries, it is
not necessary to install them in the target directory because they will
@@ -52,13 +54,13 @@ not be used at runtime. By default, target installation is enabled; setting
this variable to NO is almost never needed. Also by default, packages are
installed in this location using the +make install+ command.
-On line 11, we tell Buildroot to pass custom options to CMake when it is
+On line 12, we tell Buildroot to pass custom options to CMake when it is
configuring the package.
-On line 12, we declare our dependencies, so that they are built
+On line 13, we declare our dependencies, so that they are built
before the build process of our package starts.
-Finally, on line line 14, we invoke the +cmake-package+
+Finally, on line line 15, we invoke the +cmake-package+
macro that generates all the Makefile rules that actually allows the
package to be built.
diff --git a/docs/manual/adding-packages-conclusion.txt b/docs/manual/adding-packages-conclusion.txt
index 0f6f0ca0a..8e1b2c6a7 100644
--- a/docs/manual/adding-packages-conclusion.txt
+++ b/docs/manual/adding-packages-conclusion.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Conclusion
~~~~~~~~~~
diff --git a/docs/manual/adding-packages-directory.txt b/docs/manual/adding-packages-directory.txt
index cc6849710..6296596d7 100644
--- a/docs/manual/adding-packages-directory.txt
+++ b/docs/manual/adding-packages-directory.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Package directory
~~~~~~~~~~~~~~~~~
diff --git a/docs/manual/adding-packages-generic.txt b/docs/manual/adding-packages-generic.txt
index 78df24ade..a615ae2c9 100644
--- a/docs/manual/adding-packages-generic.txt
+++ b/docs/manual/adding-packages-generic.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Infrastructure for packages with specific build systems
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
@@ -19,42 +20,43 @@ system is based on hand-written Makefiles or shell scripts.
03: # libfoo
04: #
05: #############################################################
-06: LIBFOO_VERSION = 1.0
-07: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
-08: LIBFOO_SITE = http://www.foosoftware.org/download
-09: LIBFOO_LICENSE = GPLv3+
-10: LIBFOO_LICENSE_FILES = COPYING
-11: LIBFOO_INSTALL_STAGING = YES
-12: LIBFOO_CONFIG_SCRIPTS = libfoo-config
-13: LIBFOO_DEPENDENCIES = host-libaaa libbbb
-14:
-15: define LIBFOO_BUILD_CMDS
-16: $(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D) all
-17: endef
-18:
-19: define LIBFOO_INSTALL_STAGING_CMDS
-20: $(INSTALL) -D -m 0755 $(@D)/libfoo.a $(STAGING_DIR)/usr/lib/libfoo.a
-21: $(INSTALL) -D -m 0644 $(@D)/foo.h $(STAGING_DIR)/usr/include/foo.h
-22: $(INSTALL) -D -m 0755 $(@D)/libfoo.so* $(STAGING_DIR)/usr/lib
-23: endef
-24:
-25: define LIBFOO_INSTALL_TARGET_CMDS
-26: $(INSTALL) -D -m 0755 $(@D)/libfoo.so* $(TARGET_DIR)/usr/lib
-27: $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/foo.d
-28: endef
-29:
-30: define LIBFOO_DEVICES
-31: /dev/foo c 666 0 0 42 0 - - -
-32: endef
-33:
-34: define LIBFOO_PERMISSIONS
-35: /bin/foo f 4755 0 0 - - - - -
-36: endef
-37:
-38: $(eval $(generic-package))
+06:
+07: LIBFOO_VERSION = 1.0
+08: LIBFOO_SOURCE = libfoo-$(LIBFOO_VERSION).tar.gz
+09: LIBFOO_SITE = http://www.foosoftware.org/download
+10: LIBFOO_LICENSE = GPLv3+
+11: LIBFOO_LICENSE_FILES = COPYING
+12: LIBFOO_INSTALL_STAGING = YES
+13: LIBFOO_CONFIG_SCRIPTS = libfoo-config
+14: LIBFOO_DEPENDENCIES = host-libaaa libbbb
+15:
+16: define LIBFOO_BUILD_CMDS
+17: $(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D) all
+18: endef
+19:
+20: define LIBFOO_INSTALL_STAGING_CMDS
+21: $(INSTALL) -D -m 0755 $(@D)/libfoo.a $(STAGING_DIR)/usr/lib/libfoo.a
+22: $(INSTALL) -D -m 0644 $(@D)/foo.h $(STAGING_DIR)/usr/include/foo.h
+23: $(INSTALL) -D -m 0755 $(@D)/libfoo.so* $(STAGING_DIR)/usr/lib
+24: endef
+25:
+26: define LIBFOO_INSTALL_TARGET_CMDS
+27: $(INSTALL) -D -m 0755 $(@D)/libfoo.so* $(TARGET_DIR)/usr/lib
+28: $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/foo.d
+29: endef
+30:
+31: define LIBFOO_DEVICES
+32: /dev/foo c 666 0 0 42 0 - - -
+33: endef
+34:
+35: define LIBFOO_PERMISSIONS
+36: /bin/foo f 4755 0 0 - - - - -
+37: endef
+38:
+39: $(eval $(generic-package))
--------------------------------
-The Makefile begins on line 6 to 10 with metadata information: the
+The Makefile begins on line 7 to 11 with metadata information: the
version of the package (+LIBFOO_VERSION+), the name of the
tarball containing the package (+LIBFOO_SOURCE+) the
Internet location at which the tarball can be downloaded from
@@ -64,13 +66,13 @@ the same prefix, +LIBFOO_+ in this case. This prefix is always the
uppercased version of the package name (see below to understand where
the package name is defined).
-On line 11, we specify that this package wants to install something to
+On line 12, we specify that this package wants to install something to
the staging space. This is often needed for libraries, since they must
install header files and other development files in the staging space.
This will ensure that the commands listed in the
+LIBFOO_INSTALL_STAGING_CMDS+ variable will be executed.
-On line 12, we specify that there is some fixing to be done to some
+On line 13, we specify that there is some fixing to be done to some
of the 'libfoo-config' files that were installed during
+LIBFOO_INSTALL_STAGING_CMDS+ phase.
These *-config files are executable shell script files that are
@@ -112,14 +114,14 @@ IMAGEMAGICK_CONFIG_SCRIPTS = \
Magick-config Magick++-config \
MagickCore-config MagickWand-config Wand-config
-On line 13, we specify the list of dependencies this package relies
+On line 14, we specify the list of dependencies this package relies
on. These dependencies are listed in terms of lower-case package names,
which can be packages for the target (without the +host-+
prefix) or packages for the host (with the +host-+) prefix).
Buildroot will ensure that all these packages are built and installed
'before' the current package starts its configuration.
-The rest of the Makefile, lines 14..27, defines what should be done
+The rest of the Makefile, lines 16..29, defines what should be done
at the different steps of the package configuration, compilation and
installation.
+LIBFOO_BUILD_CMDS+ tells what steps should be performed to
@@ -132,13 +134,13 @@ All these steps rely on the +$(@D)+ variable, which
contains the directory where the source code of the package has been
extracted.
-On line 29..31, we define a device-node file used by this package
+On line 31..33, we define a device-node file used by this package
(+LIBFOO_DEVICES+).
-On line 33..35, we define the permissions to set to specific files
+On line 35..37, we define the permissions to set to specific files
installed by this package (+LIBFOO_PERMISSIONS+).
-Finally, on line 37, we call the +generic-package+ function, which
+Finally, on line 39, we call the +generic-package+ function, which
generates, according to the variables defined previously, all the
Makefile code necessary to make your package working.
diff --git a/docs/manual/adding-packages-gettext.txt b/docs/manual/adding-packages-gettext.txt
index 58fd98d4e..98c994cda 100644
--- a/docs/manual/adding-packages-gettext.txt
+++ b/docs/manual/adding-packages-gettext.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Gettext integration and interaction with packages
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
diff --git a/docs/manual/adding-packages-tips.txt b/docs/manual/adding-packages-tips.txt
index acdee40e7..21e520bcd 100644
--- a/docs/manual/adding-packages-tips.txt
+++ b/docs/manual/adding-packages-tips.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Tips and tricks
~~~~~~~~~~~~~~~
diff --git a/docs/manual/adding-packages.txt b/docs/manual/adding-packages.txt
index b909d47a8..0123b32f8 100644
--- a/docs/manual/adding-packages.txt
+++ b/docs/manual/adding-packages.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[adding-packages]]
Adding new packages to Buildroot
diff --git a/docs/manual/advanced.txt b/docs/manual/advanced.txt
index 314d30098..764b71a5c 100644
--- a/docs/manual/advanced.txt
+++ b/docs/manual/advanced.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Advanced usage
--------------
diff --git a/docs/manual/appendix.txt b/docs/manual/appendix.txt
index 6f1e9f361..ef34169f8 100644
--- a/docs/manual/appendix.txt
+++ b/docs/manual/appendix.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Appendix
========
diff --git a/docs/manual/beyond-buildroot.txt b/docs/manual/beyond-buildroot.txt
index a87b584aa..a0d4af0a7 100644
--- a/docs/manual/beyond-buildroot.txt
+++ b/docs/manual/beyond-buildroot.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Beyond Buildroot
================
diff --git a/docs/manual/ccache-support.txt b/docs/manual/ccache-support.txt
index 95cd66203..4969180a2 100644
--- a/docs/manual/ccache-support.txt
+++ b/docs/manual/ccache-support.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[ccache]]
Using +ccache+ in Buildroot
diff --git a/docs/manual/common-usage.txt b/docs/manual/common-usage.txt
index 5566a39b0..c7f511ad7 100644
--- a/docs/manual/common-usage.txt
+++ b/docs/manual/common-usage.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Daily use
---------
diff --git a/docs/manual/configure.txt b/docs/manual/configure.txt
index 65e0eeb2f..4f9a6bbcf 100644
--- a/docs/manual/configure.txt
+++ b/docs/manual/configure.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[configure]]
Details on Buildroot configuration
@@ -63,6 +64,7 @@ Type+ option in the +Toolchain+ menu. Once one solution has been
chosen, a number of configuration options appear, they are detailed in
the following sections.
+[[internal-toolchain-backend]]
Internal toolchain backend
^^^^^^^^^^^^^^^^^^^^^^^^^^
@@ -137,6 +139,7 @@ Drawbacks of this backend:
using the _External toolchain backend_.
* Limited to the _uClibc_ C library.
+[[external-toolchain-backend]]
External toolchain backend
^^^^^^^^^^^^^^^^^^^^^^^^^^
@@ -239,6 +242,7 @@ Drawbacks of this backend:
fix from the toolchain vendor, unless you build your external
toolchain by yourself using Crosstool-NG.
+[[crosstool-ng-toolchain-backend]]
Crosstool-NG toolchain backend
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
diff --git a/docs/manual/contribute.txt b/docs/manual/contribute.txt
index a33aab2af..9425effdd 100644
--- a/docs/manual/contribute.txt
+++ b/docs/manual/contribute.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Contibuting to Buildroot
========================
diff --git a/docs/manual/customize-busybox-config.txt b/docs/manual/customize-busybox-config.txt
index fe9cddaad..981d534af 100644
--- a/docs/manual/customize-busybox-config.txt
+++ b/docs/manual/customize-busybox-config.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[busybox-custom]]
Customizing the Busybox configuration
diff --git a/docs/manual/customize-kernel-config.txt b/docs/manual/customize-kernel-config.txt
index 107227040..a2d31ed84 100644
--- a/docs/manual/customize-kernel-config.txt
+++ b/docs/manual/customize-kernel-config.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[kernel-custom]]
Customizing the Linux kernel configuration
diff --git a/docs/manual/customize-rootfs.txt b/docs/manual/customize-rootfs.txt
index b1662cb79..7ff8d8b1e 100644
--- a/docs/manual/customize-rootfs.txt
+++ b/docs/manual/customize-rootfs.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[rootfs-custom]]
Customizing the generated target filesystem
@@ -24,18 +25,18 @@ there are a few ways to customize the resulting target filesystem.
directories, +.empty+ files and files ending with +~+ are excluded.
_Among these first 3 methods, this one should be preferred_.
-* In the Buildroot configuration, you can specify the path to a
- *post-build script*, that gets called 'after' Buildroot builds all the
- selected software, but 'before' the rootfs packages are
- assembled. The +BR2_ROOTFS_POST_BUILD_SCRIPT+ will allow you to
- specify the location of your post-build script. This option can be
+* In the Buildroot configuration, you can specify the paths to one or
+ more *post-build scripts*. These scripts are called in the given order,
+ 'after' Buildroot builds all the selected software, but 'before' the
+ rootfs images are assembled. The +BR2_ROOTFS_POST_BUILD_SCRIPT+ allows
+ you to specify the location of your post-build scripts. This option can be
found in the +System configuration+ menu. The destination root
- filesystem folder is given as the first argument to this script,
- and this script can then be used to remove or modify any file in your
+ filesystem folder is given as the first argument to these scripts,
+ and these scripts can then be used to remove or modify any file in your
target filesystem. You should, however, use this feature with care.
Whenever you find that a certain package generates wrong or unneeded
- files, you should fix that package rather than work around it with a
- post-build cleanup script.
+ files, you should fix that package rather than work around it with some
+ post-build cleanup scripts.
You may also use these variables in your post-build script:
- +BUILDROOT_CONFIG+: the path to the Buildroot .config file
- +HOST_DIR+, +STAGING_DIR+, +TARGET_DIR+: see
@@ -54,23 +55,25 @@ there are a few ways to customize the resulting target filesystem.
installation. Note that this method is *not recommended*, as it
duplicates the entire skeleton, which prevents from taking advantage
of the fixes or improvements brought to the default Buildroot
- skeleton. The recommended method is to use the _post-build script_
+ skeleton. The recommended method is to use the _post-build scripts_
mechanism described in the previous item.
-Note also that if you want to perform some specific actions *after*
-all filesystem images have been created (for example to automatically
+Note also that you can use the *post-image scripts*
+if you want to perform some specific actions 'after' all
+filesystem images have been created (for example to automatically
extract your root filesystem tarball in a location exported by your
NFS server, or to create a special firmware image that bundles your
root filesystem and kernel image, or any other custom action), you can
specify a space-separated list of scripts in the
-+BR2_ROOTFS_POST_IMAGE_SCRIPT+ configuration option.
++BR2_ROOTFS_POST_IMAGE_SCRIPT+ configuration option. This option can be
+found in the +System configuration+ menu as well.
Each of those scripts will be called with the path to the +images+
output directory as first and unique argument, and will be executed
with the main Buildroot source directory as the current
directory. Those scripts will be executed as the user that executes
Buildroot, which should normally not be the root user. Therefore, any
-action requiring root permissions in one of these post-image script
+action requiring root permissions in one of these _post-image scripts_
will require special handling (usage of fakeroot or sudo), which is
left to the script developer.
diff --git a/docs/manual/customize-store.txt b/docs/manual/customize-store.txt
index 63ea82dcf..5083339ec 100644
--- a/docs/manual/customize-store.txt
+++ b/docs/manual/customize-store.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*-
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[customize-store]]
Storing the configuration
@@ -12,10 +13,13 @@ consists of the buildroot configuration, the configuration files for
packages that you use (kernel, busybox, uClibc, ...), and your rootfs
modifications.
+
+[[customize-store-basics]]
Basics for storing the configuration
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-[[customize-store-basics]]
+
+[[customize-store-buildroot-config]]
Buildroot configuration
^^^^^^^^^^^^^^^^^^^^^^^
@@ -34,6 +38,7 @@ Alternatively, you can copy the file to any other place and rebuild with
+make defconfig BR2_DEFCONFIG=<path-to-defconfig-file>+.
+[[customize-store-package-config]]
Other package configuration
^^^^^^^^^^^^^^^^^^^^^^^^^^^
@@ -70,6 +75,7 @@ configuration files easier.
resp. +BR2_TARGET_AT91BOOTSTRAP3_CUSTOM_CONFIG_FILE+.
+[[customize-store-board-support]]
Creating your own board support
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
diff --git a/docs/manual/customize-toolchain.txt b/docs/manual/customize-toolchain.txt
index 2b244120b..811a6dc7f 100644
--- a/docs/manual/customize-toolchain.txt
+++ b/docs/manual/customize-toolchain.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[toolchain-custom]]
Customizing the toolchain
@@ -14,7 +15,7 @@ There is no way of tuning an external toolchain since Buildroot does not
generate it.
It also requires to set the Buildroot settings according to the toolchain ones
-(see xref:external-toolchain[]).
+(see xref:external-toolchain-backend[]).
Using the internal Buildroot toolchain backend
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
diff --git a/docs/manual/customize-uclibc-config.txt b/docs/manual/customize-uclibc-config.txt
index 38a1575a5..7fd20f706 100644
--- a/docs/manual/customize-uclibc-config.txt
+++ b/docs/manual/customize-uclibc-config.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[uclibc-custom]]
Customizing the uClibc configuration
diff --git a/docs/manual/customize.txt b/docs/manual/customize.txt
index a13ba8f3e..3b1a5a734 100644
--- a/docs/manual/customize.txt
+++ b/docs/manual/customize.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Customization
-------------
diff --git a/docs/manual/developer-guide.txt b/docs/manual/developer-guide.txt
index 500289707..43272f567 100644
--- a/docs/manual/developer-guide.txt
+++ b/docs/manual/developer-guide.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Developer Guidelines
====================
diff --git a/docs/manual/download-infra.txt b/docs/manual/download-infra.txt
index 63908adad..fe031a640 100644
--- a/docs/manual/download-infra.txt
+++ b/docs/manual/download-infra.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[download-infra]]
diff --git a/docs/manual/download-location.txt b/docs/manual/download-location.txt
index 36a13562e..4aa8cead3 100644
--- a/docs/manual/download-location.txt
+++ b/docs/manual/download-location.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Location of downloaded packages
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
diff --git a/docs/manual/eclipse-integration.txt b/docs/manual/eclipse-integration.txt
index 3d8179fa6..d1a42cf07 100644
--- a/docs/manual/eclipse-integration.txt
+++ b/docs/manual/eclipse-integration.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Integration with Eclipse
------------------------
diff --git a/docs/manual/faq-troubleshooting.txt b/docs/manual/faq-troubleshooting.txt
index 5d9531b12..f91a8ef50 100644
--- a/docs/manual/faq-troubleshooting.txt
+++ b/docs/manual/faq-troubleshooting.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Frequently Asked Questions & Troubleshooting
============================================
diff --git a/docs/manual/get-involved.txt b/docs/manual/get-involved.txt
index 59ddd711b..8515d34dc 100644
--- a/docs/manual/get-involved.txt
+++ b/docs/manual/get-involved.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Getting involved
================
diff --git a/docs/manual/getting.txt b/docs/manual/getting.txt
index a51caa0e7..6b2a824f9 100644
--- a/docs/manual/getting.txt
+++ b/docs/manual/getting.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[getting-buildroot]]
Getting Buildroot
diff --git a/docs/manual/going-further.txt b/docs/manual/going-further.txt
index 070e0a33a..d3f183037 100644
--- a/docs/manual/going-further.txt
+++ b/docs/manual/going-further.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Going further in Buildroot's innards
====================================
diff --git a/docs/manual/how-buildroot-works.txt b/docs/manual/how-buildroot-works.txt
index ec08f9520..68ddd1379 100644
--- a/docs/manual/how-buildroot-works.txt
+++ b/docs/manual/how-buildroot-works.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
How Buildroot works
-------------------
diff --git a/docs/manual/introduction.txt b/docs/manual/introduction.txt
index a567cec64..c014565ab 100644
--- a/docs/manual/introduction.txt
+++ b/docs/manual/introduction.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
About Buildroot
===============
diff --git a/docs/manual/legal-notice.txt b/docs/manual/legal-notice.txt
index 0f30234b2..51292f6d3 100644
--- a/docs/manual/legal-notice.txt
+++ b/docs/manual/legal-notice.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[legal-info]]
diff --git a/docs/manual/make-tips.txt b/docs/manual/make-tips.txt
index 8cd77c030..b4a9c123d 100644
--- a/docs/manual/make-tips.txt
+++ b/docs/manual/make-tips.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[make-tips]]
'make' tips
diff --git a/docs/manual/makedev-syntax.txt b/docs/manual/makedev-syntax.txt
index 27517b3b9..2c985312b 100644
--- a/docs/manual/makedev-syntax.txt
+++ b/docs/manual/makedev-syntax.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[makedev-syntax]]
Makedev syntax documentation
diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
index d664603a6..aa205341d 100644
--- a/docs/manual/manual.mk
+++ b/docs/manual/manual.mk
@@ -18,7 +18,7 @@ $(1): $(1)-$(3)
$(1)-$(3): $$(O)/docs/$(1)/$(1).$(4)
$$(O)/docs/$(1)/$(1).$(4): docs/$(1)/$(1).txt $$($(call UPPERCASE,$(1))_SOURCES)
- @echo "Generating $(5) $(1)..."
+ @$(call MESSAGE,"Generating $(5) $(1)...")
$(Q)mkdir -p $$(@D)
$(Q)a2x $(6) -f $(2) -d book -L -r $(TOPDIR)/docs/images \
-D $$(@D) $$<
diff --git a/docs/manual/manual.txt b/docs/manual/manual.txt
index c34e0ca46..ffb6fb93e 100644
--- a/docs/manual/manual.txt
+++ b/docs/manual/manual.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
The Buildroot user manual
=========================
diff --git a/docs/manual/package-make-target.txt b/docs/manual/package-make-target.txt
index 7374957b8..dc9d31072 100644
--- a/docs/manual/package-make-target.txt
+++ b/docs/manual/package-make-target.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[pkg-build-steps]]
diff --git a/docs/manual/patch-policy.txt b/docs/manual/patch-policy.txt
index 9bc6537ca..0f55b26dc 100644
--- a/docs/manual/patch-policy.txt
+++ b/docs/manual/patch-policy.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[patch-policy]]
@@ -33,12 +34,18 @@ Most patches are provided within Buildroot, in the package
directory; these typically aim to fix cross-compilation, libc support,
or other such issues.
-These patch files should be named +<packagename>-*.patch+.
+These patch files should be named +<packagename>-<number>-<description>.patch+.
A +series+ file, as used by +quilt+, may also be added in the
package directory. In that case, the +series+ file defines the patch
application order.
+.Notes
+- The patch files coming with Buildroot should not contain any package version
+reference in their filename.
+- The field +<number>+ in the patch file name refers to the 'apply order'.
+
+
How patches are applied
~~~~~~~~~~~~~~~~~~~~~~~
@@ -55,9 +62,12 @@ How patches are applied
* If a +series+ file exists in the package directory, then patches are
applied according to the +series+ file;
+
-* Otherwise, patch files matching `<packagename>-*.patch` or
- `<packagename>-*.patch.<arch>` (where +<arch>+ is the architecture
- name) are applied following the +ls+ command order.
+* Otherwise, patch files matching +<packagename>-*.patch+
+ are applied in alphabetical order.
+ So, to ensure they are applied in the right order, it is hightly
+ recommended to named the patch files like this:
+ +<packagename>-<number>-<description>.patch+, where +<number>+
+ refers to the 'apply order'.
. Run the +<packagename>_POST_PATCH_HOOKS+ commands if defined.
diff --git a/docs/manual/prerequisite.txt b/docs/manual/prerequisite.txt
index 21e46273d..5a9d049e0 100644
--- a/docs/manual/prerequisite.txt
+++ b/docs/manual/prerequisite.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[requirement]]
System requirements
diff --git a/docs/manual/rebuilding-packages.txt b/docs/manual/rebuilding-packages.txt
index d6a77a7fc..044c90896 100644
--- a/docs/manual/rebuilding-packages.txt
+++ b/docs/manual/rebuilding-packages.txt
@@ -1,4 +1,5 @@
-// -*- mode:doc -*- ;
+// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
[[full-rebuild]]
Understanding when a full rebuild is necessary
diff --git a/docs/manual/starting-up.txt b/docs/manual/starting-up.txt
index 2999fd488..7326f60c7 100644
--- a/docs/manual/starting-up.txt
+++ b/docs/manual/starting-up.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Starting up
===========
diff --git a/docs/manual/using-buildroot-toolchain.txt b/docs/manual/using-buildroot-toolchain.txt
index 750fa9948..b4db68625 100644
--- a/docs/manual/using-buildroot-toolchain.txt
+++ b/docs/manual/using-buildroot-toolchain.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Using the generated toolchain outside Buildroot
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
diff --git a/docs/manual/using.txt b/docs/manual/using.txt
index 857aa333b..de29ad6b5 100644
--- a/docs/manual/using.txt
+++ b/docs/manual/using.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Using Buildroot
---------------
diff --git a/docs/manual/working-with.txt b/docs/manual/working-with.txt
index fb6bc40e3..4432b548d 100644
--- a/docs/manual/working-with.txt
+++ b/docs/manual/working-with.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Working with Buildroot
======================
@@ -24,4 +25,5 @@ interested in hacking it to add:
* new packages: refer to the xref:adding-packages[Developer guide]
-* new board support: refer to the xref:board-support[Developer guide]
+* new board support: refer to the
+ xref:customize-store-board-support[Developer guide].
diff --git a/docs/manual/writing-rules.txt b/docs/manual/writing-rules.txt
index f6382b56d..c9816a440 100644
--- a/docs/manual/writing-rules.txt
+++ b/docs/manual/writing-rules.txt
@@ -1,4 +1,5 @@
// -*- mode:doc; -*-
+// vim: set syntax=asciidoc:
Coding style
------------