summaryrefslogtreecommitdiffstats
path: root/docs/manual/how-buildroot-works.txt
diff options
context:
space:
mode:
Diffstat (limited to 'docs/manual/how-buildroot-works.txt')
-rw-r--r--docs/manual/how-buildroot-works.txt33
1 files changed, 21 insertions, 12 deletions
diff --git a/docs/manual/how-buildroot-works.txt b/docs/manual/how-buildroot-works.txt
index 7e33d8e01..ec08f9520 100644
--- a/docs/manual/how-buildroot-works.txt
+++ b/docs/manual/how-buildroot-works.txt
@@ -10,25 +10,34 @@ involved in the cross-compilation toolchain (+gcc+, +binutils+ and
+uClibc+).
There is basically one Makefile per software package, and they are
-named with the +.mk+ extension. Makefiles are split into three main
-sections:
+named with the +.mk+ extension. Makefiles are split into many different
+parts.
-* *toolchain* (in the +toolchain/+ directory) contains the Makefiles
+* The +toolchain/+ directory contains the Makefiles
and associated files for all software related to the
cross-compilation toolchain: +binutils+, +gcc+, +gdb+,
+kernel-headers+ and +uClibc+.
-* *package* (in the +package/+ directory) contains the Makefiles and
- associated files for all user-space tools that Buildroot can compile
- and add to the target root filesystem. There is one sub-directory
- per tool.
+* The +arch/+ directory contains the definitions for all the processor
+ architectures that are supported by Buildroot.
-* *target* (in the +target+ directory) contains the Makefiles and
+* The +package/+ directory contains the Makefiles and
+ associated files for all user-space tools and libraries that Buildroot
+ can compile and add to the target root filesystem. There is one
+ sub-directory per package.
+
+* The +linux/+ directory contains the Makefiles and associated files for
+ the Linux kernel.
+
+* The +boot/+ directory contains the Makefiles and associated files for
+ the bootloaders supported by Buildroot.
+
+* The +system/+ directory contains support for system integration, e.g.
+ the target filesystem skeleton and the selection of an init system.
+
+* The +fs/+ directory contains the Makefiles and
associated files for software related to the generation of the
- target root filesystem image. Four types of filesystems are
- supported: ext2, jffs2, cramfs and squashfs. For each of them there
- is a sub-directory with the required files. There is also a
- +default/+ directory that contains the target filesystem skeleton.
+ target root filesystem image.
Each directory contains at least 2 files: