summaryrefslogtreecommitdiffstats
path: root/boot
diff options
context:
space:
mode:
Diffstat (limited to 'boot')
-rw-r--r--boot/syslinux/syslinux-build-fix-for-uuid.patch15
-rw-r--r--boot/syslinux/syslinux.mk2
-rw-r--r--boot/uboot/Config.in23
-rw-r--r--boot/uboot/uboot.mk16
4 files changed, 40 insertions, 16 deletions
diff --git a/boot/syslinux/syslinux-build-fix-for-uuid.patch b/boot/syslinux/syslinux-build-fix-for-uuid.patch
deleted file mode 100644
index 04ff56235..000000000
--- a/boot/syslinux/syslinux-build-fix-for-uuid.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Author: Micah Gersten <micahg@ubuntu.com>
-Description: Fix build failure with --as-needed (Closes: #654838).
-
-diff -Naurp syslinux.orig/utils/Makefile syslinux/utils/Makefile
---- syslinux.orig/utils/Makefile 2011-12-23 14:53:26.653571511 +0100
-+++ syslinux/utils/Makefile 2012-01-22 18:55:03.849466924 +0100
-@@ -51,7 +51,7 @@ isohdpfx.c: $(ISOHDPFX) isohdpfxarray.pl
- $(PERL) isohdpfxarray.pl $(ISOHDPFX) > $@
-
- isohybrid: isohybrid.o isohdpfx.o
-- $(CC) $(LDFLAGS) -luuid -o $@ $^
-+ $(CC) $(LDFLAGS) -o $@ $^ -luuid
-
- gethostip: gethostip.o
- $(CC) $(LDFLAGS) -o $@ $^
diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index f63f2e06c..046bdc352 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -4,7 +4,7 @@
#
#############################################################
-SYSLINUX_VERSION = 4.05
+SYSLINUX_VERSION = 4.06
SYSLINUX_SOURCE = syslinux-$(SYSLINUX_VERSION).tar.bz2
SYSLINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/boot/syslinux/4.xx/
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index d22e23bd7..bc5ce19da 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -212,4 +212,27 @@ config BR2_TARGET_UBOOT_SPL_NAME
u-boot build. For most platform it is u-boot-spl.bin
but not always. It is MLO on OMAP for example.
+menuconfig BR2_TARGET_UBOOT_ENVIMAGE
+ bool "Environment image"
+ help
+ Generate a valid binary environment image from a text file
+ describing the key=value pairs of the environment.
+
+ The environment image will be called uboot-env.bin.
+
+if BR2_TARGET_UBOOT_ENVIMAGE
+
+config BR2_TARGET_UBOOT_ENVIMAGE_SOURCE
+ string "Source file for environment"
+ help
+ Text file describing the environment.
+
+config BR2_TARGET_UBOOT_ENVIMAGE_SIZE
+ string "Size of environment"
+ help
+ Size of envronment, can be prefixed with 0x for hexadecimal
+ values.
+
+endif # BR2_TARGET_UBOOT_ENVIMAGE
+
endif # BR2_TARGET_UBOOT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index ea77259d1..c337e7552 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -104,6 +104,9 @@ define UBOOT_INSTALL_IMAGES_CMDS
cp -dpf $(@D)/$(UBOOT_BIN) $(BINARIES_DIR)/
$(if $(BR2_TARGET_UBOOT_SPL),
cp -dpf $(@D)/$(BR2_TARGET_UBOOT_SPL_NAME) $(BINARIES_DIR)/)
+ $(if $(BR2_TARGET_UBOOT_ENVIMAGE),
+ $(HOST_DIR)/usr/bin/mkenvimage -s $(BR2_TARGET_UBOOT_ENVIMAGE_SIZE) \
+ -o $(BINARIES_DIR)/uboot-env.bin $(BR2_TARGET_UBOOT_ENVIMAGE_SOURCE))
endef
define UBOOT_INSTALL_OMAP_IFT_IMAGE
@@ -125,6 +128,19 @@ UBOOT_POST_BUILD_HOOKS += UBOOT_BUILD_OMAP_IFT
UBOOT_POST_INSTALL_IMAGES_HOOKS += UBOOT_INSTALL_OMAP_IFT_IMAGE
endif
+ifeq ($(BR2_TARGET_UBOOT_ENVIMAGE),y)
+# we NEED a environment settings unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
+ifeq ($(call qstrip,$(BR2_TARGET_UBOOT_ENVIMAGE_SOURCE)),)
+$(error Please define a source file for Uboot environment (BR2_TARGET_UBOOT_ENVIMAGE_SOURCE setting))
+endif
+ifeq ($(call qstrip,$(BR2_TARGET_UBOOT_ENVIMAGE_SIZE)),)
+$(error Please provide Uboot environment size (BR2_TARGET_UBOOT_ENVIMAGE_SIZE setting))
+endif
+endif
+UBOOT_DEPENDENCIES += host-uboot-tools
+endif
+
$(eval $(generic-package))
ifeq ($(BR2_TARGET_UBOOT),y)